If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Search found 25311 matches

by steve
Tue May 23, 2017 4:39 pm
Forum: Cumulus 1
Topic: Error 32701
Replies: 4
Views: 39

Re: Error 32701

Yes, you're right, the FAQ doesn't abbreviate it ("Silicon Labs"). Anyway, here's the link now I've looked for it - http://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
by steve
Tue May 23, 2017 1:19 pm
Forum: Cumulus MX
Topic: RaspberryPi at boot gives Weather Underground 0 reading for temp and others
Replies: 4
Views: 37

Re: RaspberryPi at boot gives Weather Underground 0 reading for temp and others

I can't remember whether I've written the code to fix this yet. Basically, I need to make it do the same as Cumulus 1. I'm afraid I'm far too busy with other things at the moment to have any chance of writing Cumulus code.
by steve
Tue May 23, 2017 12:42 pm
Forum: Cumulus 1
Topic: Error 32701
Replies: 4
Views: 39

Re: Error 32701

A reboot may fix it. If not, you could try reinstalling the drivers from the Silabs site (location should be in the FAQ).
by steve
Tue May 23, 2017 11:39 am
Forum: Cumulus MX
Topic: RaspberryPi at boot gives Weather Underground 0 reading for temp and others
Replies: 4
Views: 37

Re: RaspberryPi at boot gives Weather Underground 0 reading for temp and others

It's probably doing a WU update before it's read any data - see the Known Issues/FAQ - http://sandaysoft.com/forum/viewtopic.php?f=27&t=12943 Some timer-based actions (e.g. data logging, graph plotting, realtime FTP and realtime SQL update) can happen before first data is read Are you using 'rap...
by steve
Tue May 23, 2017 8:21 am
Forum: Cumulus MX
Topic: CumulusMX temperature records
Replies: 6
Views: 137

Re: CumulusMX temperature records

The spike removal setting works for both highs and lows - it's not an absolute value, it works on the difference between consecutive readings. So, if you set it to 30, any reading more than 30 degrees higher or lower than the previous reading is ignored. A setting of 30 is probably too high, you sho...
by steve
Mon May 22, 2017 2:49 pm
Forum: Cumulus MX
Topic: Timeouts after Linux upgrades
Replies: 2
Views: 34

Re: Timeouts after Linux upgrades

As it's affecting both http and ftp, the issue is apparently at a lower level, so it's unlikely you'll get any useful information out of Cumulus. I think you'll have to look for answers in Ubuntu. Googling suggests there have been a number of internet related issues with 17.04, DNS lookups in partic...
by steve
Mon May 22, 2017 11:53 am
Forum: Cumulus MX
Topic: _wapi_connect: error looking up socket handle
Replies: 5
Views: 72

Re: _wapi_connect: error looking up socket handle

They are output by Mono, not Cumulus. There may be a way to turn them off, I don't know.
by steve
Mon May 22, 2017 9:06 am
Forum: Web site - General
Topic: Struggling with SFTP
Replies: 1
Views: 30

Re: Struggling with SFTP

You upload a file by including a 'put' command in your WinSCP command file, like the example in the wiki: put "localpath\realtime.txt" /remotepath and like the lines in the Webpages_Upload.txt script in the post you linked to, e.g. put "index.htm" index.html Note that these are e...
by steve
Mon May 22, 2017 8:56 am
Forum: Cumulus MX
Topic: Mx Stopping
Replies: 25
Views: 214

Re: Mx Stopping

Does your logger upload to weatherlink.com? Yes Then this is almost certainly your problem. The design of the logger only allows one TCP/IP connection at a time, hence the 'peridioc disconnect interval' setting in MX, to allow uploads to weatherlink.com. Despite this, it appears that the logger can...
by steve
Sun May 21, 2017 6:55 pm
Forum: Cumulus MX
Topic: Mx Stopping
Replies: 25
Views: 214

Re: Mx Stopping

and secondly, Cumulus-Original is now running a couple days after the fact of CMX beginning it's crash series. Why? Assuming you mean the crash as in the orginal post in this thread, i.e caused by the communication with the logger being lost, rather than the other (spurious) crashes caused by an in...
by steve
Sun May 21, 2017 8:28 am
Forum: Cumulus MX
Topic: CumulusMX temperature records
Replies: 6
Views: 137

Re: CumulusMX temperature records

I can't unzip that file, it seems to be corrupt/incomplete. Those messages are normal, they are just Cumulus having to retry reading data from the station; La Crosse stations are a pain and don't give up their data easily. They are also known to have problems with USB/Serial adapters, and presumably...
by steve
Sun May 21, 2017 8:23 am
Forum: Cumulus MX
Topic: Mx Stopping
Replies: 25
Views: 214

Re: Mx Stopping

I don't think those errors are related to the communication being lost. They look related to the incomplete installation of Cumulus.
by steve
Sat May 20, 2017 2:56 pm
Forum: Cumulus MX
Topic: Web pages won't load
Replies: 3
Views: 82

Re: Web pages won't load

COM0 is not a valid device identifier in Linux. The MX FAQ explains what to do: "Serial device names on Linux are not COM0 etc as in Windows. You need to specify something like /dev/ttyUSB0 - do a dmesg at a command line prompt and look for the actual device name from your adapter. If dmesg say...
by steve
Sat May 20, 2017 2:53 pm
Forum: Cumulus MX
Topic: _wapi_connect: error looking up socket handle
Replies: 5
Views: 72

Re: _wapi_connect: error looking up socket handle

Sorry, I don't understand. What is the actual problem that you are having? What isn't working?
by steve
Sat May 20, 2017 11:15 am
Forum: Cumulus MX
Topic: CumulusMX temperature records
Replies: 6
Views: 137

Re: CumulusMX temperature records

Just before the time that the problem occurs, turn on debug logging and data logging. After the problem occurs, zip up the latest MXdiags file and attach it to a reply here.

To upgrade, just copy the files contained in the zip file into your existing installation, as it says in the MX FAQ.

Go to advanced search