Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Search found 25921 matches

by steve
Thu Jun 21, 2018 6:22 pm
Forum: Cumulus 1
Topic: Issue with wind speed/gust graphs
Replies: 2
Views: 16

Re: Issue with wind speed/gust graphs

There is an explanation in the FAQ/Wiki regarding wind speeds and gusts depending on the type of station. You might want to look at 'peak gust' in select-a-graph rather than 'wind gust'.
by steve
Sun Jun 17, 2018 8:59 am
Forum: Cumulus 1
Topic: Error Log
Replies: 2
Views: 145

Re: Error Log

Use a better text editor such as notepad++, that will show the problem.
by steve
Wed Jun 13, 2018 6:23 pm
Forum: General
Topic: Webpage won't always load....
Replies: 7
Views: 410

Re: Webpage won't always load....

What’s your site URL? When I go to woodlandweather.org I am told that it is for sale.
by steve
Sat Jun 09, 2018 4:44 pm
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

Yes, it looks like a bug, it seems not to add the data downloaded from the logger to the list of recent data. However, looking at the code, it definitely does that. But I now see that you are not using the latest version, and if you look at the release announcements, you will see that this bug is me...
by steve
Sat Jun 09, 2018 2:32 pm
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

Perhaps as a test, you could create a file with the followng tags: <#RecentTS m=1> <#RecentOutsideTemp m=1> <#RecentTS m=2> <#RecentOutsideTemp m=2> and so on, up to m=20, and get Cumulus to process it. Paste the contents here after Cumulus has been running for at least 30 minutes. Then stop Cumulus...
by steve
Sat Jun 09, 2018 2:21 pm
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

See the section in the wiki about the recent data tags. The tag I mentioned shows the timestamp of the data extracted using the same paramer as the data web tags (e.g. using m=10 shows the time of the data that is being extracted for the data tags using m=10).
by steve
Sat Jun 09, 2018 2:06 pm
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

I can't see any problems there (other than a frequent ftp error). Are you using the <#RecentTS> tag with the same parameter, to show the timestamp of the data being used? It may be useful to do that, if you aren't already.
by steve
Sat Jun 09, 2018 12:04 pm
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

Zip up the diags folder and attach it to a reply, together with your June log file.

I assume that after Cumulus has been running for a while, the web tags start working correctly, as far back as the restart?
by steve
Sat Jun 09, 2018 10:44 am
Forum: Davis VP/VP2/Vue
Topic: Data
Replies: 11
Views: 478

Re: Data

It’s possible there’s a problem with your June data log file. Normally Cumulus would flash the error light, and clicking on that would show you the problem. There would also be an error message in the latest diags file.
by steve
Fri Jun 08, 2018 11:41 am
Forum: Cumulus 1
Topic: Cumulus integration with Windfinder
Replies: 11
Views: 321

Re: Cumulus integration with Windfinder

Windfinder contacted me a couple of years ago asking me to add support - I gave my usual response, that I could consider it in the future. They gave an example of how to do an update, it’s basically the same as WU etc (using an http get). So not difficult to do, just cloning a lot of existing code. ...
by steve
Thu Jun 07, 2018 2:01 pm
Forum: Cumulus MX
Topic: Problem with degrees symbol
Replies: 19
Views: 619

Re: Problem with degrees symbol

Because I didn’t know that’s how the third party component worked when I wrote the code.
by steve
Thu Jun 07, 2018 1:43 pm
Forum: Cumulus MX
Topic: Problem with degrees symbol
Replies: 19
Views: 619

Re: Problem with degrees symbol

Mapantz wrote:I started the processing again, and the file was converted back to UTF8 even though I don't have it enabled. The ipcamT.txt stays as ANSI while the outputted file is UTF8. I cannot keep them both in ANSI.
See my previous post.
by steve
Thu Jun 07, 2018 12:51 pm
Forum: Cumulus MX
Topic: Problem with degrees symbol
Replies: 19
Views: 619

Re: Problem with degrees symbol

All I can tell you is that Cumulus is correctly encoding the degree symbol as the hex sequence C2 B0 (look at the output from Cumulus in a hex editor). That odd A symbol that you see is what you get when software incorrectly interprets the UTF-8 encoding as ANSI, so presumably that's what your webca...
by steve
Wed Jun 06, 2018 11:41 am
Forum: Cumulus MX
Topic: Problem with degrees symbol
Replies: 19
Views: 619

Re: Problem with degrees symbol

Have you actually looked at the output file from Cumulus in Notepad++ (or another good text editor). Perhaps the problem is with whatever you are doing with it.
by steve
Wed Jun 06, 2018 10:27 am
Forum: Cumulus MX
Topic: Problem with degrees symbol
Replies: 19
Views: 619

Re: Problem with degrees symbol

The file you attached doesn't use <#tempunit>, nor does it have a degree symbol in it. I edited it (in Notepad++) to use both of those: 2018-06-06 12_19_59-C__Users_steve_Downloads_ipcamT.txt - Notepad++.png For me, MX substitutes &#176; for the degree symbol in the web tag (which is correct for...

Go to advanced search