Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Search found 5033 matches

by mcrossley
Wed Jan 17, 2018 10:14 am
Forum: Cumulus MX
Topic: Downgrade to Cumulus 1?
Replies: 3
Views: 251

Re: Downgrade to Cumulus 1?

If your locale remains the same the data should be compatible. I have moved my data files from my pi to my laptop to edit them in C1, then moved them back to CMX on the pi without any problem.

The cumulus.ini requires a bit more work as some settings change between versions.
by mcrossley
Tue Jan 16, 2018 10:25 pm
Forum: Web site - General
Topic: Highcharts Windrose
Replies: 2
Views: 41

Re: Highcharts Windrose

Line 220, change serverData("year") to serverData("24")
by mcrossley
Tue Jan 16, 2018 9:43 am
Forum: Cumulus MX
Topic: Windows 10 Drivers Problems
Replies: 7
Views: 103

Re: Windows 10 Drivers Problems

ken555 wrote:But that wouldn't explain why it works on another PC.

Ah, sorry, I missed that bit of info. :(
by mcrossley
Mon Jan 15, 2018 10:32 pm
Forum: Cumulus MX
Topic: Windows 10 Drivers Problems
Replies: 7
Views: 103

Re: Windows 10 Drivers Problems

Sorry to be pessimistic, but you will find quite a few threads where Fine Offset consoles suddenly get massive pressure offsets after a restart. Try changing drivers but I don't think it will make any difference. Once they get in that state there doesn't seem to be any going back. When mine did it I...
by mcrossley
Mon Jan 15, 2018 10:20 pm
Forum: Cumulus MX
Topic: New Hardware - no Dashboard but updates working??
Replies: 3
Views: 54

Re: New Hardware - no Dashboard but updates working??

Local firewall enabled? If it is is port 8002 open?
by mcrossley
Wed Jan 10, 2018 10:07 pm
Forum: Cumulus MX
Topic: looks like wunderground have messed up again
Replies: 36
Views: 995

Re: looks like wunderground have messed up again

If I understand it right, WU run the service on AWS.

My historic data is missing from the 9th to now, though the current data is shown - :groan:

EDIT: Though I just stepped back and forth through the days using the previous/next buttons and the data magically appeared! :bash: :bash: :groan:
by mcrossley
Sat Jan 06, 2018 3:09 pm
Forum: Cumulus 1
Topic: Daily rainfall not being totalle into the month and year totals.
Replies: 6
Views: 121

Re: Daily rainfall not being totalle into the month and year totals.

Is your computer going to sleep over the midnight period?
by mcrossley
Thu Jan 04, 2018 9:08 am
Forum: Saratoga Templates
Topic: WU-forecast.php
Replies: 20
Views: 914

Re: WU-forecast.php

Whole of WU is down from my end, has been for a few hours.

AWS implementing the Intel fix?
by mcrossley
Tue Jan 02, 2018 6:21 pm
Forum: Cumulus 1
Topic: DayFile - Annual Evapotranspiration bug
Replies: 6
Views: 488

Re: DayFile - Annual Evapotranspiration bug

Not a great deal of help, but you could add a pre-insert check on the SQL tables for negative values and set them to zero.
by mcrossley
Tue Jan 02, 2018 5:58 pm
Forum: Cumulus 1
Topic: DayFile - Annual Evapotranspiration bug
Replies: 6
Views: 488

Re: DayFile - Annual Evapotranspiration bug

I didn't have a great problem. It detected the negative values just after midnight, but they stopped after 40 seconds, and at 00:00:45 I got... 2018-01-01 00:00:45.816 StartofdayET set to 0 And that was it. I have never looked at the year rollover before - interesting to see the rain counter reset t...
by mcrossley
Sun Dec 31, 2017 4:58 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 14
Views: 362

Re: Jump in Number of Mono Threads

Rather than downgrade Mono, I decided to try upgrading to the latest release, I'm now running version 5.4.1.6. The good news is the CMX CPU utilisation has now dropped back to similar or even lower levels to running under version 3.8.2. The "base" thread count is the same as 4.6.2 at 16 fo...
by mcrossley
Fri Dec 29, 2017 9:49 pm
Forum: Cumulus MX
Topic: Server Generated Graphs for MX
Replies: 189
Views: 31252

Re: Server Generated Graphs for MX

Take a look at this...
https://httpd.apache.org/docs/current/h ... ccess.html
You could move the contents of the file into your main Apache config file as that article indicates that is more efficient anyway.
by mcrossley
Fri Dec 29, 2017 9:45 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 14
Views: 362

Re: Jump in Number of Mono Threads

I have just updated my pi to stretch and mono 4.6.2. The base usage for MX had gone up from 70-92 MB and 12 threads to 90-111 MB and 15 threads. The MX cpu usage has also increased average 1.5 up to 2.1%. Overall memory usage by all processes has dropped markedly. I think I may try reverting the mon...
by mcrossley
Fri Dec 29, 2017 8:35 pm
Forum: Cumulus MX
Topic: Server Generated Graphs for MX
Replies: 189
Views: 31252

Re: Server Generated Graphs for MX

Is your web server running on Apache?
by mcrossley
Fri Dec 29, 2017 7:48 pm
Forum: Cumulus MX
Topic: Server Generated Graphs for MX
Replies: 189
Views: 31252

Re: Server Generated Graphs for MX

It doesn't look like you have loaded the .htaccess file on your web server?
You can only access the files via their full filenames eg "graphPress.php", whereas the gauges script is looking the aliases eg "press.png"

Go to advanced search