Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Search found 5003 matches

by mcrossley
Mon Dec 11, 2017 1:19 pm
Forum: SteelSeries Gauges
Topic: Trend Indicator on Humidity Gauge
Replies: 2
Views: 49

Re: Trend Indicator on Humidity Gauge

You'd first have to calculate what the trend was, Cumulus provides the trend for temperature but not for humidity. You'll therefore have to devise a method of determining it yourself.

Once you have that, then add it to the JSON file, and copy the code in the temperature gauge for display the value.
by mcrossley
Sun Dec 10, 2017 9:10 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 7
Views: 106

Re: Jump in Number of Mono Threads

Yeah, I always use the lite builds, they are a lot cleaner, though there still lots of packages that need removing. mpstat and pidstat are both part of the sysstat package. The /proc CPU info is mainly about "load" rather than percentage use, as is the info from ps. I'm more accustomed to ...
by mcrossley
Sun Dec 10, 2017 3:54 pm
Forum: Davis VP/VP2/Vue
Topic: Rain Gauge Failing
Replies: 8
Views: 103

Re: Rain Gauge Failing

Try the wind in the rain socket briefly - that should record lots of tips if it is spinning!
by mcrossley
Sun Dec 10, 2017 3:52 pm
Forum: SteelSeries Gauges
Topic: Help configuration Gauges page
Replies: 3
Views: 58

Re: Help configuration Gauges page

1) For the pop-ups there are two settings in gauges.js lines 50 & 51 showPopupData : true, // Pop-up data displayed showPopupGraphs : true, // If pop-up data is displayed, show the graphs? 2) Again gauges.js starting line 87 gaugeGlobals = { A whole load of settings.
by mcrossley
Sun Dec 10, 2017 3:47 pm
Forum: Davis VP/VP2/Vue
Topic: Rain Gauge Failing
Replies: 8
Views: 103

Re: Rain Gauge Failing

Note sure if yours solar sensor if you have 25 re-syncs! Looks like ISS contact is being lost. Is the battery OK?
by mcrossley
Sun Dec 10, 2017 12:16 pm
Forum: Davis VP/VP2/Vue
Topic: Rain Gauge Failing
Replies: 8
Views: 103

Re: Rain Gauge Failing

I had to replace the reed switch in mine - luckily I had a couple lying around in old burglar alarm contact switches.
by mcrossley
Sun Dec 10, 2017 12:13 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 7
Views: 106

Re: Jump in Number of Mono Threads

I've restarted MX as it seemed it was using a fair bit of CPU with that high thread count. I have also 'enhanced' my System Info page to add a thread count and change the avg CPU to a 2 second value and an average. This does add a delay to the page load time, but as it is mainly for my information I...
by mcrossley
Fri Dec 08, 2017 11:52 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 7
Views: 106

Re: Jump in Number of Mono Threads

Do you have rapid fire enabled (I don't) then if the WU updates are failing you are going to clock up failures very quickly.

MX ran for over 6 months before the last restart, now on 55 days. The increase from 70 MB to 165 happened a week or so ago.
by mcrossley
Fri Dec 08, 2017 8:34 pm
Forum: Cumulus MX
Topic: Jump in Number of Mono Threads
Replies: 7
Views: 106

Re: Jump in Number of Mono Threads

What's the MX memory usage like? I haven't tracked the mono threads but I have noticed that when WU is misbehaving MX memory usage steadily climbs. It normally runs around 65-70MB, currently mine is sat at 165MB - it climbed up there last time WU played up and stopped increasing when it came back. I...
by mcrossley
Fri Dec 08, 2017 4:16 pm
Forum: SteelSeries Gauges
Topic: Space between gauges
Replies: 3
Views: 57

Re: Space between gauges

Actually there is more than missing </div>. This looks better... <!-- START OF FIRST ROW 6 GAUGES --> <div class="row"> <!-- TEMPERATURE GAUGE --> <div class="gauge"> <div id="tip_0"> <canvas id="canvas_temp" class="gaugeSizeSml"></canvas> </div> </d...
by mcrossley
Fri Dec 08, 2017 4:10 pm
Forum: SteelSeries Gauges
Topic: Space between gauges
Replies: 3
Views: 57

Re: Space between gauges

You have a missing </div> on the third gauge? With tab:4 to see it easier... <!-- START OF FIRST ROW 6 GAUGES --> <div class="row"> <!-- TEMPERATURE GAUGE --> <div class="gauge"> <div id="tip_0"> <canvas id="canvas_temp" class="gaugeSizeSml"></canvas...
by mcrossley
Fri Dec 08, 2017 3:31 pm
Forum: SteelSeries Gauges
Topic: New install, no gauges displayed
Replies: 12
Views: 149

Re: New install, no gauges displayed

You have a dangling </label> in the last gauge, and a missing </div> at the end (which may be a cut/paste error). Hard see what is going wrong there with a full page to look at. <div class="row"> <canvas id="canvas_led" width="25" height="25"></canvas>&nbs...
by mcrossley
Thu Dec 07, 2017 4:43 pm
Forum: SteelSeries Gauges
Topic: New install, no gauges displayed
Replies: 12
Views: 149

Re: New install, no gauges displayed

F12 is your friend ;)
by mcrossley
Thu Dec 07, 2017 3:53 pm
Forum: SteelSeries Gauges
Topic: New install, no gauges displayed
Replies: 12
Views: 149

Re: New install, no gauges displayed

Your link to JQuery in the page is still using http://, it needs changing to https:

If you load the http version of the page it is working fine...
http://www.melvinweather.com/gauges-ss-basic.htm
by mcrossley
Thu Dec 07, 2017 9:30 am
Forum: SteelSeries Gauges
Topic: New install, no gauges displayed
Replies: 12
Views: 149

Re: New install, no gauges displayed

I am using 3.2.1 on my personal page. :roll:

Go to advanced search