IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

I strongly advise all users using my server for their web site to make alternative arrangements.

Outgoing mail is disabled because of the malware on the server. No new forum registrations are currently possible, and mail to the forum administrator will not work.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Search found 26106 matches

by steve
Tue Oct 09, 2018 11:15 am
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

Just a quick post as I am trying to fix things. The server was blocked and it appears Hetzner were right all along, once they told me what the likely malware was, I was able to find it and remove it. Now looking at stopping it recurring. No idea how it got in but Wordpress is a likely candidate. As ...
by steve
Mon Oct 08, 2018 7:08 am
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

Current situation is that they are forwarding my responses to the complainants.
by steve
Sun Oct 07, 2018 5:11 pm
Forum: Cumulus MX
Topic: MXDiags always on, sometimes adding 2-3 GB per day
Replies: 4
Views: 319

Re: MXDiags always on, sometimes adding 2-3 GB per dayiles

Then the best thing to do would be to look at the diags file to see what is being logged frequently.

Note that the there is no setting to turn off use of the diags files, you have presumably turned off something else.
by steve
Sun Oct 07, 2018 5:01 pm
Forum: Customisation
Topic: Port Numbers ...
Replies: 9
Views: 545

Re: Port Numbers ...

An example is given in the announcement post containing the download and the installation instructions: When Cumulus starts, it will display the URL of the user interface. It runs on port 8998 by default; if this is not suitable for some reason you can over-ride it using the '-port' parameter on the...
by steve
Sun Oct 07, 2018 4:45 pm
Forum: Cumulus MX
Topic: MXDiags always on, sometimes adding 2-3 GB per day
Replies: 4
Views: 319

Re: MXDiags always on, sometimes adding 2-3 GB per day

I inadvertently made the uploading of realtimegauges.txt default, without regard for whether uploading to a web site is configured. If you don’t have an ftp server configured this will cause an error to be logged every few seconds. If this is the cause,you can turn it off in the internet settings.
by steve
Sun Oct 07, 2018 1:44 pm
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

I’m already using those PHP mail settings.
by steve
Sun Oct 07, 2018 1:42 pm
Forum: Customisation
Topic: Port Numbers ...
Replies: 9
Views: 545

Re: Port Numbers ...

Use the -port and -wsport parameters when invoking CumulusMX.exe
by steve
Sun Oct 07, 2018 12:23 pm
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

I’m back home towards the end of the month.

If the plug does get pulled, steve@sandaysoft.com will also stop working, but I have made alternative arrangements for steve@nybbles.co.uk so that will be unaffected.
by steve
Sun Oct 07, 2018 11:52 am
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

It depends on exactly how the supposed spam is being sent. I assume there are devious methods other than simply using sendmail or the PHP mail function? How do you selectively disable just the ways that spam might be sent? I don’t think the Hetzner abuse department are really interested in being hel...
by steve
Sat Oct 06, 2018 7:17 pm
Forum: General
Topic: Site going down.
Replies: 91
Views: 2630

Re: Site going down.

I don’t think I could face moving to another server.

Hopefully if they do block access, there will still be a way to download the databases containing the forum and wiki contents.

This has not come at a good time, I am on holiday on a boat on a French canal.
by steve
Fri Oct 05, 2018 7:30 pm
Forum: Announcements and News
Topic: Server may go down
Replies: 0
Views: 1038

Server may go down

I am being accused by Hetzner, who provide the dedicated server that I use for this web site and all of the web sites that I host for Cumulus users, of sending spam emails. Or rather, that this server is sending them. They have received spam reports citing this server's IP address as the originator....
by steve
Thu Oct 04, 2018 9:57 pm
Forum: Cumulus 1
Topic: Twitter problem with Cumulus v1.9.4 (1099)
Replies: 14
Views: 2321

Re: Twitter problem with Cumulus v1.9.4 (1099)

Cumulus may be prevented from posting to Twitter completely, for everyone, soon. Twitter have created yet more obstacles. It seems I have to submit a justification for the amount of tweets that Cumulus does, so that they can consider allowing it to continue. I am currently on holiday on a canal boat...
by steve
Thu Sep 27, 2018 1:24 pm
Forum: Cumulus MX
Topic: Customising which lines are displayed on graphs for Cumulus MX - now solved
Replies: 9
Views: 486

Re: Customising which lines are displayed on graphs for Cumulus MX

I’m not sure the options you mention exist, but I would have to look at the code to confirm, when I next have my laptop out. I don’t remember the bug you mention, can you point me at the thread where this was reported, so I can see what my response was? I’m pretty sure the setting is in use and work...
by steve
Tue Sep 25, 2018 5:34 pm
Forum: Fine Offset/EasyWeather
Topic: Connection issue
Replies: 5
Views: 658

Re: Connection issue

Easyweather (like Cumulus and most other software) will catch up with data it has missed while not running, so will appear up to date anyway. You could perhaps reboot your PC and run Cumulus before anything else, if you haven't already done that, to make sure EW isn't leaving something in a funny st...
by steve
Tue Sep 25, 2018 5:24 pm
Forum: Fine Offset/EasyWeather
Topic: Connection issue
Replies: 5
Views: 658

Re: Connection issue

Cumulus is getting data from the station that it can't make any sense of. This can happen if you have other software connected at the same time as Cumulus, but you say that isn't the case. The only suggestion I can think of is that you try a full reset of the station (remove batteries and USB cable ...

Go to advanced search