Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Problems with Wind-Gust-Spike

Discussion specific to Fine Offset and similar rebadged weather stations
wetterfrosch1971
Posts: 89
Joined: Sun Apr 06, 2014 1:15 pm
Weather Station: wh1080
Operating System: windows7
Location: south-west-germany

Problems with Wind-Gust-Spike

Postby wetterfrosch1971 » Tue Dec 26, 2017 4:45 pm

Hi,

sometimes I have a wind-gust-spike in cumulus, it ist a wrong read from the station.
The spike in wind-gust is approximately 100km/h, but the maximal real gust on this day is just 40km/h.
In the last 6 years I have never had this problem, the problem first appeared last month.
Someone has an idea where this error comes from?

And can someone tell me how to get rid of this spike?
I edited the wrong value in all files but in the wind-gust-graph, the error remains displayed.
from which file the graphic gets this value?

Many thanks for help.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26423
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Problems with Wind-Gust-Spike

Postby steve » Tue Dec 26, 2017 4:56 pm

It loads the values for the graphs at start up from the monthly log file (I think this is in the FAQ).

Are you not using a spike removal setting?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

wetterfrosch1971
Posts: 89
Joined: Sun Apr 06, 2014 1:15 pm
Weather Station: wh1080
Operating System: windows7
Location: south-west-germany

Re: Problems with Wind-Gust-Spike

Postby wetterfrosch1971 » Tue Dec 26, 2017 5:06 pm

Hi Steve,

I forgot to edit this monthly-log file.

I use a spike-removel setting, but I think it is the wrong value in the setting, I use 20ms spike-removal in wind-gust.

What value should I use for wind-gust-spike-removal?

Many thanks.

sfws
Posts: 372
Joined: Fri Jul 27, 2012 11:29 am
Weather Station: Maplin based, but customised
Operating System: off-line Vista and W10 PCs
Location: UK

Re: Problems with Wind-Gust-Spike

Postby sfws » Tue Dec 26, 2017 6:07 pm

wetterfrosch1971 wrote: I use 20m/s spike-removal in wind-gust

I guess that is a reasonable figure for you to use, note that spike removal applies while Cumulus is running, not to catch-up readings from the station's logger. So a possible explanation is that you had Cumulus stopped at the time when the spike happened within your weather station (and that figure was read into Cumulus without a check against the spike threshold you have selected) when you next started Cumulus.
Cumulus produces a diagnostic output that can be checked to prove/disprove my theory.

As I said once before, my fine-offset produces a stupid figure in some parameter approximately once a year, so it is an annoying although reasonably rare feature of the make.

User avatar
steve
Cumulus Author
Posts: 26423
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Problems with Wind-Gust-Spike

Postby steve » Tue Dec 26, 2017 6:21 pm

Your spike was lower than your setting, 20 m/s is 72 kph and it looks like your spike is a jump of about 70 kph or less. You believe that is an invalid reading, so the conclusion is that your setting is too high.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

wetterfrosch1971
Posts: 89
Joined: Sun Apr 06, 2014 1:15 pm
Weather Station: wh1080
Operating System: windows7
Location: south-west-germany

Re: Problems with Wind-Gust-Spike

Postby wetterfrosch1971 » Tue Dec 26, 2017 6:24 pm

Hi,

cumulus was not stopped.
Where can I finde the "diagnostic Output"?
In the logger from the console, is this wrong value does not exist.

@Steve
wich settings for gust-spike removal is useful?

User avatar
steve
Cumulus Author
Posts: 26423
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Problems with Wind-Gust-Spike

Postby steve » Tue Dec 26, 2017 6:44 pm

You could try 15 m/s or a little less, and see if you still get spikes.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job


Return to “Fine Offset/EasyWeather”

Who is online

Users browsing this forum: No registered users and 2 guests