Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Cumulus Realtime.txt Dashboard Template

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderators: daj, TNETWeather

User avatar
laulau
Posts: 525
Joined: Tue Oct 13, 2009 10:52 pm
Weather Station: WeatherDuino Pro2
Operating System: Win 7
Location: Meyenheim, Alsace, FR
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby laulau » Tue Jul 11, 2017 7:44 pm

Thanks,

I'd kept my Setting1.php from my previous configuration and it seems that with the original setting1.ini it works properly.
I have to edit the file again occordingly with my previous setting.
Laurent

Image

Steepleian
Posts: 42
Joined: Sat Mar 29, 2014 7:33 am
Weather Station: Ambient WS-1001
Operating System: Raspbian Stretch
Location: Steeple Claydon
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Steepleian » Tue Jul 11, 2017 8:00 pm

laulau wrote:Thanks,

I'd kept my Setting1.php from my previous configuration and it seems that with the original setting1.ini it works properly.
I have to edit the file again occordingly with my previous setting.


I thought it might be the settings1.php file. I made the same mistake a few months back until Brian put me on the right track. I now always do a clean install when updating then adjust settings1.php and menu.php to my requirements.

I can see all is working well and the forecast tiles waiting for the next update.

Regards,
Ian

User avatar
laulau
Posts: 525
Joined: Tue Oct 13, 2009 10:52 pm
Weather Station: WeatherDuino Pro2
Operating System: Win 7
Location: Meyenheim, Alsace, FR
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby laulau » Tue Jul 11, 2017 8:15 pm

Working fine now!
Thank's again Ian
Laurent

Image

Steepleian
Posts: 42
Joined: Sat Mar 29, 2014 7:33 am
Weather Station: Ambient WS-1001
Operating System: Raspbian Stretch
Location: Steeple Claydon
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Steepleian » Fri Jul 21, 2017 5:41 pm

Latest Update, 21 July 2017

Brian,

Thanks for today's update. Your never cease to amaze me. :clap: :clap: :clap: :clap: :clap: :clap:

Cheers,
Ian

User avatar
Toxic17
Posts: 542
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.1 Stretch
Location: Bangor, NI
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Toxic17 » Sat Jul 22, 2017 9:08 am

Steepleian wrote:Latest Update, 21 July 2017

Brian,

Thanks for today's update. Your never cease to amaze me. :clap: :clap: :clap: :clap: :clap: :clap:

Cheers,
Ian


Yep, Love the new Cloudbase.php too!
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

weatherist34
Posts: 395
Joined: Wed Apr 13, 2016 11:09 am
Weather Station: Fine Offset HP1000/2000
Operating System: OS X Sierra
Location: Istanbul
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby weatherist34 » Sat Jul 22, 2017 10:14 am

good afternoon

as always many thanks for the compliments

unfortunately there was a minor bug nothing serious that would make it stop working and you would not have noticed until you hit a real low value. but often you release something then sit back and wait 24 hours to see what is wrong and its not always possible to go through every scenario, so no news is good news !.. so there is a fix and if you are on version 34-X5c then you can just replace the files (6) without any changing of easysetup.

VERSION 3.4-X5c (Saturday 22nd July 2017) Updated
- "Its never perfect but we try " without the feedback you send in I would never see half of the issues.More eyes the better !
- New Cloudbase "Relative" Indicator" minor fixes added to css output and alignment. main.dark.css, main.color.css, main.light.css
- New Cloudbase "Relative" Indicator" three files updated cloudbase.php, solar1.php, solar2.php . improved positioning of height value
- You can simply replace the six files mentioned above no need to do full update if on version 34-X5c .
- Download the six files from http://www.mediafire.com/file/mkqf3rwq5 ... update.zip *please note they are only valid for Version 34-X5c !! .

https://weather34.com/homeweatherstation/

Image


brian

BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Cumulus Realtime.txt Dashboard Template

Postby BigOkie » Sat Jul 22, 2017 12:31 pm

I would really love to use this template, but no matter how I install it, the pages never render for me. Ever. I've tried it several times and the last version I got working was sometime early last year. I can never find an error messages in my logs, it just renders a blank page. Oh well, guess I'll stop trying.

Edit: Last version I was able to successfully run on my Pi webserver running Apache2 was 4.38d. Most of the files were dated July 2016. I still have that version and it runs.

User avatar
vaggos
Posts: 232
Joined: Sat Feb 06, 2010 7:00 pm
Weather Station: PROWEATHER STATION 1080
Operating System: XP SP3, win7, Win10
Location: Acharnes Athens Greece
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby vaggos » Sat Jul 22, 2017 1:04 pm

Hello Brian
Yes till now cloud base is ok. Before i had problem with height. And i was looking of i have dan something rong.
Regards
Vaggelis
https://weather.meteoacharnes.gr/
Image
Acharnes Athens Greece Meteo station
http://www.meteoacharnes.gr
https://weather.meteoacharnes.gr/
Thanks Sandaysoft

weatherist34
Posts: 395
Joined: Wed Apr 13, 2016 11:09 am
Weather Station: Fine Offset HP1000/2000
Operating System: OS X Sierra
Location: Istanbul
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby weatherist34 » Sat Jul 22, 2017 1:41 pm

BigOkie wrote:I would really love to use this template, but no matter how I install it, the pages never render for me. Ever. I've tried it several times and the last version I got working was sometime early last year. I can never find an error messages in my logs, it just renders a blank page. Oh well, guess I'll stop trying.

Edit: Last version I was able to successfully run on my Pi webserver running Apache2 was 4.38d. Most of the files were dated July 2016. I still have that version and it runs.


im sorry you are not able to run it , i have 1 home made server built from an old mac mini 2gb memory with PHP 7.1 , 1 local server ON MY Desktop Mac 16gb with xampp 7.1.1 and a hosted webserver at ICDSOFT with 7.1 it runs on all of those flawlessly everything is put together locally and then uploaded to the hosted server last. there are numerous users i know running a Pi based server with it if I can work out who they are from my emails i will forwarded them on to you . I have zero experience with anything Pi based i did look at making a lightning sensor but could not find a company to deliver here to Turkey. so I never have managed to use anything Pi and I dont want to start throwing assumed theory solutions has I have zero experience.

Vaggos at 8000ft your going to max it out :-) big fire risk ? update with the new 6 files mentioned above http://www.mediafire.com/file/mkqf3rwq5 ... update.zip

Kos earthquake this week really bad , my relatives live in Bodrum there house now has a crack/split down the middle :-(

for those interested you would be amazed at what damage a 30cm height tsunami can do , boats and cars were washed up into the streets of Bodrum shortly after the 6.6 earthquake this week .so god forbid hope a larger tsunami never occurs here...

brian

Steepleian
Posts: 42
Joined: Sat Mar 29, 2014 7:33 am
Weather Station: Ambient WS-1001
Operating System: Raspbian Stretch
Location: Steeple Claydon
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Steepleian » Sat Jul 22, 2017 2:57 pm

weatherist34 wrote:
BigOkie wrote:I would really love to use this template, but no matter how I install it, the pages never render for me. Ever. I've tried it several times and the last version I got working was sometime early last year. I can never find an error messages in my logs, it just renders a blank page. Oh well, guess I'll stop trying.

Edit: Last version I was able to successfully run on my Pi webserver running Apache2 was 4.38d. Most of the files were dated July 2016. I still have that version and it runs.


im sorry you are not able to run it , i have 1 home made server built from an old mac mini 2gb memory with PHP 7.1 , 1 local server ON MY Desktop Mac 16gb with xampp 7.1.1 and a hosted webserver at ICDSOFT with 7.1 it runs on all of those flawlessly everything is put together locally and then uploaded to the hosted server last. there are numerous users i know running a Pi based server with it if I can work out who they are from my emails i will forwarded them on to you . I have zero experience with anything Pi based i did look at making a lightning sensor but could not find a company to deliver here to Turkey. so I never have managed to use anything Pi and I dont want to start throwing assumed theory solutions has I have zero experience.

Vaggos at 8000ft your going to max it out :-) big fire risk ? update with the new 6 files mentioned above http://www.mediafire.com/file/mkqf3rwq5 ... update.zip

Kos earthquake this week really bad , my relatives live in Bodrum there house now has a crack/split down the middle :-(

for those interested you would be amazed at what damage a 30cm height tsunami can do , boats and cars were washed up into the streets of Bodrum shortly after the 6.6 earthquake this week .so god forbid hope a larger tsunami never occurs here...

brian


I have been serving my website using this template for well over a year now using a Pi3 and external SSD, Raspbian Jessie, Apache 2.4, PHP 7, Webmin et al. I always do a clean install when updating the template as it saves time in the long run. I also set file permissions recursively to 775, ownership to my default (login) username and group to www-data, again recursively. Blank pages have long since been a thing of the past.

Just to show how rock solid the Pi is, I am also running a remote Minecraft server (for my granddaughter), Weewx and a weather webcam from the same machine simultaneously and it never lets me down. Anyone who is familiar with MacOS cli will find a Raspberry Pi a doddle to set up as a server.

BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Cumulus Realtime.txt Dashboard Template

Postby BigOkie » Sat Jul 22, 2017 3:41 pm

Steepleian wrote:
weatherist34 wrote:
BigOkie wrote:I would really love to use this template, but no matter how I install it, the pages never render for me. Ever. I've tried it several times and the last version I got working was sometime early last year. I can never find an error messages in my logs, it just renders a blank page. Oh well, guess I'll stop trying.

Edit: Last version I was able to successfully run on my Pi webserver running Apache2 was 4.38d. Most of the files were dated July 2016. I still have that version and it runs.


im sorry you are not able to run it , i have 1 home made server built from an old mac mini 2gb memory with PHP 7.1 , 1 local server ON MY Desktop Mac 16gb with xampp 7.1.1 and a hosted webserver at ICDSOFT with 7.1 it runs on all of those flawlessly everything is put together locally and then uploaded to the hosted server last. there are numerous users i know running a Pi based server with it if I can work out who they are from my emails i will forwarded them on to you . I have zero experience with anything Pi based i did look at making a lightning sensor but could not find a company to deliver here to Turkey. so I never have managed to use anything Pi and I dont want to start throwing assumed theory solutions has I have zero experience.

Vaggos at 8000ft your going to max it out :-) big fire risk ? update with the new 6 files mentioned above http://www.mediafire.com/file/mkqf3rwq5 ... update.zip

Kos earthquake this week really bad , my relatives live in Bodrum there house now has a crack/split down the middle :-(

for those interested you would be amazed at what damage a 30cm height tsunami can do , boats and cars were washed up into the streets of Bodrum shortly after the 6.6 earthquake this week .so god forbid hope a larger tsunami never occurs here...

brian


I have been serving my website using this template for well over a year now using a Pi3 and external SSD, Raspbian Jessie, Apache 2.4, PHP 7, Webmin et al. I always do a clean install when updating the template as it saves time in the long run. I also set file permissions recursively to 775, ownership to my default (login) username and group to www-data, again recursively. Blank pages have long since been a thing of the past.

Just to show how rock solid the Pi is, I am also running a remote Minecraft server (for my granddaughter), Weewx and a weather webcam from the same machine simultaneously and it never lets me down. Anyone who is familiar with MacOS cli will find a Raspberry Pi a doddle to set up as a server.


And that is actually what I am doing...clean install but I have the older version of the template in a different directory. Could that be doing something. I'm pretty versed in all things Apache/Linux but this is baffling. If it were giving me some errors to go on that's one thing, but the output is completely blank. Even when I have error reporting in PHP set to E_ALL.

I have a lot of packages on the Pi running (and actually I'm not running Raspian on the Pi I'm serving from, I'm running Ubuntu Mate). I also see I have around 100 packages that need updating, so I'll give that a whirl first and see if maybe it fixes it. I'm running PHP 7.0.1 alongside Apache 2.4.

User avatar
vaggos
Posts: 232
Joined: Sat Feb 06, 2010 7:00 pm
Weather Station: PROWEATHER STATION 1080
Operating System: XP SP3, win7, Win10
Location: Acharnes Athens Greece
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby vaggos » Sat Jul 22, 2017 6:06 pm

Bian hello. Thanks for your reply.
I Have done already the update (since i wrote before) and everything seems to be ok.
Yes big fire risk because of the wind. An near to me is a big mountan Parnis.
In Kos earthquakes continue. The said that waiting again an earthquake about six R.
Regards
Vaggelis
Image
Acharnes Athens Greece Meteo station
http://www.meteoacharnes.gr
https://weather.meteoacharnes.gr/
Thanks Sandaysoft

Steepleian
Posts: 42
Joined: Sat Mar 29, 2014 7:33 am
Weather Station: Ambient WS-1001
Operating System: Raspbian Stretch
Location: Steeple Claydon
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Steepleian » Sat Jul 22, 2017 7:05 pm

BigOkie wrote:
Steepleian wrote:
weatherist34 wrote:
im sorry you are not able to run it , i have 1 home made server built from an old mac mini 2gb memory with PHP 7.1 , 1 local server ON MY Desktop Mac 16gb with xampp 7.1.1 and a hosted webserver at ICDSOFT with 7.1 it runs on all of those flawlessly everything is put together locally and then uploaded to the hosted server last. there are numerous users i know running a Pi based server with it if I can work out who they are from my emails i will forwarded them on to you . I have zero experience with anything Pi based i did look at making a lightning sensor but could not find a company to deliver here to Turkey. so I never have managed to use anything Pi and I dont want to start throwing assumed theory solutions has I have zero experience.

Vaggos at 8000ft your going to max it out :-) big fire risk ? update with the new 6 files mentioned above http://www.mediafire.com/file/mkqf3rwq5 ... update.zip

Kos earthquake this week really bad , my relatives live in Bodrum there house now has a crack/split down the middle :-(

for those interested you would be amazed at what damage a 30cm height tsunami can do , boats and cars were washed up into the streets of Bodrum shortly after the 6.6 earthquake this week .so god forbid hope a larger tsunami never occurs here...

brian


I have been serving my website using this template for well over a year now using a Pi3 and external SSD, Raspbian Jessie, Apache 2.4, PHP 7, Webmin et al. I always do a clean install when updating the template as it saves time in the long run. I also set file permissions recursively to 775, ownership to my default (login) username and group to www-data, again recursively. Blank pages have long since been a thing of the past.

Just to show how rock solid the Pi is, I am also running a remote Minecraft server (for my granddaughter), Weewx and a weather webcam from the same machine simultaneously and it never lets me down. Anyone who is familiar with MacOS cli will find a Raspberry Pi a doddle to set up as a server.


And that is actually what I am doing...clean install but I have the older version of the template in a different directory. Could that be doing something. I'm pretty versed in all things Apache/Linux but this is baffling. If it were giving me some errors to go on that's one thing, but the output is completely blank. Even when I have error reporting in PHP set to E_ALL.

I have a lot of packages on the Pi running (and actually I'm not running Raspian on the Pi I'm serving from, I'm running Ubuntu Mate). I also see I have around 100 packages that need updating, so I'll give that a whirl first and see if maybe it fixes it. I'm running PHP 7.0.1 alongside Apache 2.4.


Which PHP7 Modules/dependancies have you installed? Here is a useful guide, its in German but fairly straightforward.

BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Cumulus Realtime.txt Dashboard Template

Postby BigOkie » Sat Jul 22, 2017 9:22 pm

Steepleian wrote:
BigOkie wrote:
Steepleian wrote:
I have been serving my website using this template for well over a year now using a Pi3 and external SSD, Raspbian Jessie, Apache 2.4, PHP 7, Webmin et al. I always do a clean install when updating the template as it saves time in the long run. I also set file permissions recursively to 775, ownership to my default (login) username and group to www-data, again recursively. Blank pages have long since been a thing of the past.

Just to show how rock solid the Pi is, I am also running a remote Minecraft server (for my granddaughter), Weewx and a weather webcam from the same machine simultaneously and it never lets me down. Anyone who is familiar with MacOS cli will find a Raspberry Pi a doddle to set up as a server.


And that is actually what I am doing...clean install but I have the older version of the template in a different directory. Could that be doing something. I'm pretty versed in all things Apache/Linux but this is baffling. If it were giving me some errors to go on that's one thing, but the output is completely blank. Even when I have error reporting in PHP set to E_ALL.

I have a lot of packages on the Pi running (and actually I'm not running Raspian on the Pi I'm serving from, I'm running Ubuntu Mate). I also see I have around 100 packages that need updating, so I'll give that a whirl first and see if maybe it fixes it. I'm running PHP 7.0.1 alongside Apache 2.4.


Which PHP7 Modules/dependancies have you installed? Here is a useful guide, its in German but fairly straightforward.


I'm attaching the phpinfo.php page I generated in hopes you can see something I'm not. (Edit: I tried attaching the html and it rejected it...i put in a zip container).
You do not have the required permissions to view the files attached to this post.

Steepleian
Posts: 42
Joined: Sat Mar 29, 2014 7:33 am
Weather Station: Ambient WS-1001
Operating System: Raspbian Stretch
Location: Steeple Claydon
Contact:

Re: Cumulus Realtime.txt Dashboard Template

Postby Steepleian » Sat Jul 22, 2017 10:24 pm

BigOkie wrote:
Steepleian wrote:
BigOkie wrote:
And that is actually what I am doing...clean install but I have the older version of the template in a different directory. Could that be doing something. I'm pretty versed in all things Apache/Linux but this is baffling. If it were giving me some errors to go on that's one thing, but the output is completely blank. Even when I have error reporting in PHP set to E_ALL.

I have a lot of packages on the Pi running (and actually I'm not running Raspian on the Pi I'm serving from, I'm running Ubuntu Mate). I also see I have around 100 packages that need updating, so I'll give that a whirl first and see if maybe it fixes it. I'm running PHP 7.0.1 alongside Apache 2.4.


Which PHP7 Modules/dependancies have you installed? Here is a useful guide, its in German but fairly straightforward.


I'm attaching the phpinfo.php page I generated in hopes you can see something I'm not. (Edit: I tried attaching the html and it rejected it...i put in a zip container).


There are some differences from my installation but I don't know how significant they are. I am attaching mine below for comparison.

As a last resort may I suggest the following: -

If you have a spare memory card (or are using Berry Boot), install Raspbian Jessie and update it. Install PHP 7 using the German link that I previously indicated, a clean installation of the template and also the permissions, user and group also previously indicated and see what happens. I have no reason to doubt Ubuntu Mate but there could be a subtle difference which is causing the problem.

One final thought, have you tried running using your internal IP address? If this works, are your running a secure (https://) site. It could be that you have a corrupt or outdated SSL certificate.
You do not have the required permissions to view the files attached to this post.


Return to “Web site - General”

Who is online

Users browsing this forum: No registered users and 2 guests