Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Help I'm being a numpty!

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderators: daj, TNETWeather

User avatar
MickinMoulden
Posts: 498
Joined: Mon Dec 20, 2010 12:12 pm
Weather Station: WS-1081 with rain gauge mod
Operating System: Windows 7 & 1.9.3 b1059
Location: Palmerston, NT, Australia
Contact:

Re: Help I'm being a numpty!

Postby MickinMoulden » Tue Jan 20, 2015 10:25 pm

water01 wrote:Gauges and trends are not working which would infer that you have not enabled the Internet upload of standard files in Configuration / Internet, or perhaps you have uploaded the images directory in the webfiles directory.


Not correct. If you hadn't uploaded the standard files, you wouldn't see anything updated/uploaded, for which we do. He hasn't uploaded the images directory in the webfile directory either. That would be difficult, especially for a begginer. As it would mean you have cut the image directory and paste within the webfile directory......what a hassle! No. It is being all uploaded as it is meant to be (see picture).

See my later post, the files are uploaded into the wrong folder so the pages won't find them when calling on pictures or javascripts which is why the pictures in gauges and trends won't show.

Code: Select all

EDIT (woops, hit submit instead of preview Bahahaha)
Anyway, what it could mean is that the website host has restrictions on what can be put on there, as in, it will not display .gif and .png formats even though they are uploaded ORRRR, that it won't LET them be displayed?  I see that [url]http://photosbygeorge.co.uk/weather/wz_jsgraphics.js[/url] is uploaded, which is required to run the guages page which doesn't work, so perhaps it won't let Javascript run.  I see the trends page also doesn't work, which has Javascript within the page (and the pic shows that the trend images have been uploaded). EDIT: As in the "further check" below, it is the host not allowing .png, .gif and .txt files and not the JS script.

I would check that the host allows the use of Javascript (most likely issue EDIT: It isn't) and/or the display of .gif, .png and .txt files (no .txt files showed on the site where I looked, which is required to run the "realtime wind data" in the "gauges" page (and much more stuff).
I had a website that wouldn't allow .txt!  (which meant no realtime.txt upload!).

FURTHER CHECK:  This comeback from the website when I "right click" on the website and selcect "Inspect Element" (in Crome):
[code]Failed to load resource: the server responded with a status of 403 (Forbidden)[/code] for all the .png and .gif files!  AND
I think I know why I can't find your realtime.txt file: [quote]301 Moved Permanently[/quote].

Sorry. :(
You do not have the required permissions to view the files attached to this post.
Last edited by MickinMoulden on Wed Jan 21, 2015 1:11 am, edited 2 times in total.
Michael, Palmerston, NT Australia www.Palmerston-WeatherImageNo image? I'm offline!
ImageImage

User avatar
MickinMoulden
Posts: 498
Joined: Mon Dec 20, 2010 12:12 pm
Weather Station: WS-1081 with rain gauge mod
Operating System: Windows 7 & 1.9.3 b1059
Location: Palmerston, NT, Australia
Contact:

Re: Help I'm being a numpty!

Postby MickinMoulden » Tue Jan 20, 2015 11:01 pm

No need to do the below, it was an error in file upload placement. Remember I asked you George if you could supply a picture of your internet and files tab settings? :groan:

Code: Select all

If this doesn't get resolved by the host, we may have to move the host [b]http://www.toucan.pw/[/b] to the "[b]Not compatible with Cumulus[/b]" list in the Wiki [url]http://wiki.sandaysoft.com/a/Webspace[/url]
Last edited by MickinMoulden on Wed Jan 21, 2015 1:14 am, edited 1 time in total.
Michael, Palmerston, NT Australia www.Palmerston-WeatherImageNo image? I'm offline!
ImageImage

User avatar
MickinMoulden
Posts: 498
Joined: Mon Dec 20, 2010 12:12 pm
Weather Station: WS-1081 with rain gauge mod
Operating System: Windows 7 & 1.9.3 b1059
Location: Palmerston, NT, Australia
Contact:

Re: Help I'm being a numpty!

Postby MickinMoulden » Wed Jan 21, 2015 1:01 am

Thank you for clearing that up water01, that it is obviously not the javascipt at fault :D .
I also see that, even the the files are in the right spot that they haven't updated since 2200hr GMT, which I believe is the same as George's local time, so either he has switched it off to stop updating (probably) or manually FTPed the file and has not set up the internet settings (not entirely sure yet). It is also not that the host not allowing photo files :roll: . Silly me.

However, due to the nature of his website being predominantly for his photography, the set up is different to a weather only site.
George, your folder set up is

Code: Select all

http://photosbygeorge.co.uk/weather/gauges.htm
, but you will find that a lot of the web templates refer to positions such as (taken from your "gauges.htm" page)

Code: Select all

<img src="images/compass.png"
, which will then look for the compass.png image here:

Code: Select all

http://photosbygeorge.co.uk/images/compass.png
which just isn't there, because it is actually here:

Code: Select all

http://photosbygeorge.co.uk/weather/images/compass.png
.
2 things you can do. Change all the webpages to include the "weather" folder :bash:
or :o change your internet settings in Cumulus so it doesn't send them to

Code: Select all

http://photosbygeorge.co.uk/weather/
:evil:
but instead sends them to

Code: Select all

http://photosbygeorge.co.uk/
:clap: .
Michael, Palmerston, NT Australia www.Palmerston-WeatherImageNo image? I'm offline!
ImageImage

otooleg@aol.com
Posts: 9
Joined: Mon Jan 19, 2015 1:46 pm
Weather Station: WH1080 - Professional touch scre
Operating System: Windows 7
Location: Mid Calder

Re: Help I'm being a numpty!

Postby otooleg@aol.com » Wed Jan 21, 2015 9:21 am

:clap: Guys can I thank you for all your positive comments and assistance and yes this isn't the primary reason for my web site as an ex pro photographer but I have always had an interest in the weather. I will try loading the files to www.photosbygeorge.co.uk and not to www.photosbygeorge.co.uk/weather and see if that makes any difference to whether the gauges appear or not. Then I have to get my head round editing the default pages to incorporate my logo?
Kindest Regards and thank you so much....
George

User avatar
steve
Cumulus Author
Posts: 26467
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Help I'm being a numpty!

Postby steve » Wed Jan 21, 2015 9:36 am

MickinMoulden wrote:George, your folder set up is

Code: Select all

http://photosbygeorge.co.uk/weather/gauges.htm
, but you will find that a lot of the web templates refer to positions such as (taken from your "gauges.htm" page)

Code: Select all

<img src="images/compass.png"
, which will then look for the compass.png image here:

Code: Select all

http://photosbygeorge.co.uk/images/compass.png
which just isn't there, because it is actually here:

Code: Select all

http://photosbygeorge.co.uk/weather/images/compass.png
.


The relative link images/compass.png in http://photosbygeorge.co.uk/weather/gauges.htm will NOT look for the image in http://photosbygeorge.co.uk/images/compass.png, it will look for it in http://photosbygeorge.co.uk/weather/images/compass.png, which is the correct place. Lots of people have their Cumulus site in a subdirectory called 'weather' or whatever (including me), and the pages are set up to work wherever you put them, as they use relative links. There is absolutely no need to move the Cumulus pages to the root directory, or change the links in any of the pages.

The site seem to be working fine to me, except that the gauges aren't centered in their boxes for some reason, and the realtime flash wind gauges can't find the realtime.txt file, which is expected to be at http://www.photosbygeorge.co.uk/weather/realtime.txt, but that gives a 404. Perhaps you haven't ticked the three realtime options. Or perhaps the hosting doesn't allow txt files?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

otooleg@aol.com
Posts: 9
Joined: Mon Jan 19, 2015 1:46 pm
Weather Station: WH1080 - Professional touch scre
Operating System: Windows 7
Location: Mid Calder

Re: Help I'm being a numpty!

Postby otooleg@aol.com » Wed Jan 21, 2015 5:12 pm

I can confirm all working now.

water01
Posts: 1434
Joined: Sat Aug 13, 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Help I'm being a numpty!

Postby water01 » Wed Jan 21, 2015 5:51 pm

My your house is hot 25.5C inside, that's a sauna!!

I think you have a spike in the wind speed bumbling along and then 90MPH!!

otooleg@aol.com
Posts: 9
Joined: Mon Jan 19, 2015 1:46 pm
Weather Station: WH1080 - Professional touch scre
Operating System: Windows 7
Location: Mid Calder

Re: Help I'm being a numpty!

Postby otooleg@aol.com » Wed Jan 21, 2015 7:25 pm

Thanks guys again great support. Steve thanks in particular. I don't think I have the realtime switched on yet but I will check with my host that. txt is available. Struggling to get my head around how to customise my site as taking in information these days is getting more and more difficult. Thanks again.
George.


Return to “Web site - General”

Who is online

Users browsing this forum: No registered users and 6 guests