IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

I strongly advise all users using my server for their web site to make alternative arrangements.

Outgoing mail is disabled because of the malware on the server. No new forum registrations are currently possible, and mail to the forum administrator will not work.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Website newbie question

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderators: daj, TNETWeather

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 6:21 am

beteljuice wrote:Local filename:

.Cumulus/data/ ... ?

So how is it getting processed at all ?

I think it just looks like that because we're only seeing the end of the file name. It hink the '.' is actually the last bit of a '\'. It might be easier if Stig pastes the files section from cumulus.ini here - without the corruption that seems to have been introduced into the ftp log.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
Stig
Posts: 48
Joined: Thu Jan 14, 2010 6:24 pm
Weather Station: WMR928NX
Operating System: Windows 7
Location: Hareskov near Copenhagen
Contact:

Re: Website newbie question

Postby Stig » Sat Sep 11, 2010 8:51 am

you are right Steve the dot is a bit of the slash, here are the full length of the two lines

C:\Cumulus\data\awekas_wl.htm.htm

http://www.hareskovvejr.dk\awekas_wl.htm


I am also also sending the file Cumulus configuration, with my different paswords deleted, I hope it will show something, thanks :)
You do not have the required permissions to view the files attached to this post.

User avatar
beteljuice
Posts: 2483
Joined: Tue Dec 09, 2008 1:37 pm
Weather Station: None !
Operating System: XP SP3 - honest
Location: Dudley, West Midlands, UK

Re: Website newbie question

Postby beteljuice » Sat Sep 11, 2010 9:03 am

Hmmm ........

Web (server) files are using MS style path delimiters \ instead of 'Unix' / .

Be better to correct that just in case thats causing any problems.
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 9:54 am

beteljuice wrote:Hmmm ........

Web (server) files are using MS style path delimiters \ instead of 'Unix' / .

Be better to correct that just in case thats causing any problems.


Well spotted - I'm certain that's the problem. That's probably why the backslash appears twice in the error message, it's being escaped.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
Stig
Posts: 48
Joined: Thu Jan 14, 2010 6:24 pm
Weather Station: WMR928NX
Operating System: Windows 7
Location: Hareskov near Copenhagen
Contact:

Re: Website newbie question

Postby Stig » Sat Sep 11, 2010 10:32 am

I am sorry :( , I have now changed all delimiters as you can see from the ini file, but still nothing appears on web server

when I call http://www.hareskovvejr.dk/awekas_wl.htm it only shows this
AWEKAS_Template_start
<#temp>
<#hum>
<#press>
<#rfall>
<#wspeed>
<#bearing>
<#hour>:<#minute>
<#day>/<#month>/<#year>
<#presstrend>
-
-
-
-
-
-
-
<#wgust>


<#rrate>
---
°c
%
m/s
hPa
mm
W/m²
mm/hr
index
Template_V1.5

and my awekas profile shows offline :?
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 11:11 am

Delete realtimeftplog.txt, turn on ftp logging, wait until a realtime ftp attempt has occurred, then attach the entire realtimeftplog.txt file here.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
Stig
Posts: 48
Joined: Thu Jan 14, 2010 6:24 pm
Weather Station: WMR928NX
Operating System: Windows 7
Location: Hareskov near Copenhagen
Contact:

Re: Website newbie question

Postby Stig » Sat Sep 11, 2010 11:31 am

the realtimeftplog.txt is now added, I can see some lines with failure, but don`t know what it means :oops:

13:23:55:038 ! HighLevelAsync 0
13:23:55:038 TWSocket will connect to 193.202.110.154:63725
13:23:55:043 ! Data Session opened (Put)
13:23:55:044 01D82A90 TriggerDataSent 828
13:23:55:045 01D82380 TriggerDataSent 1132
13:23:55:048 >|553-Can't open that file: No such file or directory|

13:23:55:048 >|553 Rename/move failure: No such file or directory|
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 11:37 am

Having corrected the remote file names for the ftp server, for some reason you also changed the local file names and have now made them invalid for Windows.

C:/Cumulus/data/awekas_wl.htm.htm

On Windows, you have to use a backslash.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
Stig
Posts: 48
Joined: Thu Jan 14, 2010 6:24 pm
Weather Station: WMR928NX
Operating System: Windows 7
Location: Hareskov near Copenhagen
Contact:

Re: Website newbie question

Postby Stig » Sat Sep 11, 2010 12:43 pm

ok corrected now, I did not know that it should be \ for windows :oops:

but as you can see from the file added I get the same result with no upload :(


14:34:31:421 ! HighLevelAsync 0
14:34:31:422 TWSocket will connect to 193.202.110.154:63518
14:34:31:428 ! Data Session opened (Put)
14:34:31:429 01DF2A90 TriggerDataSent 1252
14:34:31:429 01DF2380 TriggerDataSent 1136
14:34:31:433 >|553-Can't open that file: No such file or directory|
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 12:59 pm

Stig wrote:14:34:31:433 >|553-Can't open that file: No such file or directory|

This is coming back from your ftp server, so the path/file you are specifying must be incorrect.

Why have you got "www.hareskovvejr.dk\awekas_wl.htm" for the path anyway? For your normal realtime.txt upload, you have specified

Directory=

and that seems to be working. So why have you put www.hareskovvejr.dk on the front of your awekas file, when it looks like all you need is awekas_wl.htm? You've managed to get the correct directory path (i.e. nothing) for the standard uploads, why haven't you used the same path for your extra uploads?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
Stig
Posts: 48
Joined: Thu Jan 14, 2010 6:24 pm
Weather Station: WMR928NX
Operating System: Windows 7
Location: Hareskov near Copenhagen
Contact:

Re: Website newbie question

Postby Stig » Sat Sep 11, 2010 1:59 pm

I have changed the path to the following

C:\Cumulus\data\awekas_wl
http://www.hareskovvejr.dk/awekas_wl

and am not getting the connection error, but still no upload to the web server :(
You do not have the required permissions to view the files attached to this post.

User avatar
beteljuice
Posts: 2483
Joined: Tue Dec 09, 2008 1:37 pm
Weather Station: None !
Operating System: XP SP3 - honest
Location: Dudley, West Midlands, UK

Re: Website newbie question

Postby beteljuice » Sat Sep 11, 2010 2:10 pm

To recap:

local filename: C:\Cumulus\data\awekas_wl.htm

remote filename: awekas_wl.htm process [checked] ftp [checked]

Don't forget you can 'force' the process / ftp by Cumulus console => File => Web update ;) , which you need to make sure has happened before you browse to your hopefully updated page.
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Website newbie question

Postby steve » Sat Sep 11, 2010 2:22 pm

Stig wrote:I have changed the path to the following

C:\Cumulus\data\awekas_wl
http://www.hareskovvejr.dk/awekas_wl

and am not getting the connection error, but still no upload to the web server :(

You're not getting the error now because Cumulus isn't trying to ftp the file because it can't find it, you've taken the .htm off the end for some reason? And you definitely don't want any http:// nonsense on the front of an ftp path, this is FTP not HTTP. Did you read my previous message? I may have been editing it while you were reading it.

The settings beteljuice has suggested look right to me, given what I said in my previous message. I don't understand why you're finding this so difficult and why you keep changing things which are only introducing new problems and complicating things!

I think I am going to have to have a rule from now one where anyone who wants help with getting their files in the right place on their ftp server is just going to have to send me their login details, it's just too much hard work doing it like this.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

gemini06720
Posts: 1700
Joined: Mon Aug 10, 2009 10:16 pm
Weather Station: No weather station
Operating System: No operating system
Location: World...

Re: Website newbie question

Postby gemini06720 » Sun Sep 12, 2010 9:53 am

I think I am going to have to have a rule from now one where anyone who wants help with getting their files in the right place on their ftp server is just going to have to send me their login details, it's just too much hard work doing it like this.
...Or Steve, you might insist, from now on, before you loose you (precious) time at answering questions, that the user reads the documentation that is posted on the Wiki... :evil:

I am not complaining about your presence in the forums ... but you seem to spend too much time answering already answered questions ... whereas you should spend more of your time on your personal family life and on the design of Cumulus... ;)

Austin
Posts: 22
Joined: Sun Aug 08, 2010 6:42 pm
Weather Station: WS-1080
Operating System: Windows Vista
Location: North Bend, WA, USA
Contact:

Re: Website newbie question

Postby Austin » Sun Sep 19, 2010 8:48 am

Bookmarked your site, nice to see a local member on here.
Image
N 47° 27' 20"|W 121° 44' 23"|945 ft ASL
www.weather.austingratzer.com


Return to “Web site - General”

Who is online

Users browsing this forum: No registered users and 5 guests