IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

WH3081 and Pi Maybe

For discussion of DIY weather equipment - sensors, accessories, improvements to existing kit etc
Posts: 2
Joined: Mon Jul 04, 2016 7:01 am
Weather Station: Fine Offset WH3081
Operating System: Windows 8.1
Location: Victoria, Australia

WH3081 and Pi Maybe

Postby wimmera » Thu Nov 03, 2016 12:00 pm

I got my Fine Offset WH3081 before realizing the issue of the USB connection.

But hopefully I have found a easy fix by plugging a passive device beside the USB connection on the Raspberry Pi.

Just wondering if others have had similar results and or have a technical response as to how this has helped.

My weather station is the FineOffset WH3081 with the solar charging, I have it connected to Raspberry Pi III (jessie) loaded with CumulusMX and is running headless. This is powered through a power bank although I have left the batteries in the weather station. It has been reliable uploading to Weather Underground for 10 days now touch wood all's well.
I tried the many combinations of things with different settings,locations, USB cables and Ferrite Filters. All to no a vale until I plunged a cheap wired mouse into the Pi in the socket above the weather stations connection which has brought about a reliable connection. The Mouse has a permanent Led on which annoyed me so I tried an old Web cam (not even configured to work) and the reliable connect remains.
Also I am using the original USB cable with a added Ferrite filter each end and have set CumulusMX to not sync Fineoffset reads (SyncFOReads=0).

Maybe this is just a solution for my specific station.

Anyway thanks Sandy for Cumulus and I put this post up in the hope it may help others sort there Fineoffset USB issues.

Posts: 7
Joined: Wed Sep 07, 2016 8:24 pm
Weather Station: WH3080
Operating System: Raspberry B+, Noobs, CumulusMX
Location: Rijssen, Netherlands

Re: WH3081 and Pi Maybe

Postby WimT » Fri Nov 04, 2016 10:23 pm

Hi Wimmera,

Like to give you response, it is also my first message on this interesting website.

My old colleague and i we bought (July 2016) 2 sets of the Fineoffset WH3080 also with solar-charging, both sets
are working in combination with Raspberry B+ using wifi and CumulusMX.
Both sets WH3080 are installed on different locations in the same city, both sets had USB-lock problems.
Despite our installed ferrite coils, change power supplys, this did not solve the USB-lock.

Our solution until now :roll:
We found out (very important) the original USB-cable from supplier (both sets) the usb-cable it contains no
shielding!, this can be tested simple with multi-meter (ohm) measuring the shielding!
We both use now other USB-cables with correct shielding.
Also the latest Raspberry update seems to be very important, since we both did the latest update the USB-lock did not
came back for 3 weeks.

With kind regards,

Dear Wimmera and readers,
Unfortunately on sunday 06/11/16 the USB-lockup came back into my WH8030 :( , the set of my colleague WH8030 is still working (fingers crossed), My WH8030 had a lockup checked by the Easyweather plus software, the easyweather good not connect with the faulty baseset WH8030 and also reset off/on/off/on the application on the windows10 desktop pc.

Only a hard reset (disconnect USB and battery) could restart the USB connection.
For me this WH8030 is still not reliable, we have to find another solution.

With kind regards,

Posts: 2
Joined: Mon Jul 04, 2016 7:01 am
Weather Station: Fine Offset WH3081
Operating System: Windows 8.1
Location: Victoria, Australia

Re: WH3081 and Pi Maybe

Postby wimmera » Mon Nov 07, 2016 8:41 am

Thanks for your response
I have also had a recent USB lock up. Reset with Up Arrow for 20 Sec got it gong again.

My Next plan assuming a lock up occurs while keeping my original passive device attached is :-

"sync Fineoffset reads" again
Different cable again
Raspberry Pi update

This all takes a long time to prove anything waiting a couple of weeks for a USB lock up. Prior to attaching a passive device I was only getting about 2 days.
I started this as a useful project to get to know the Raspberry Pi at times I have questioned my abilities it certainly has been a challenge but then to be fair from what I can see no one has a definitive answer to the USB lockup issue short of a tricky work around to have an auto restart which for me would create other issues.


Return to “Homebuilt”

Who is online

Users browsing this forum: No registered users and 4 guests