If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3041 Aug 17 2016

Automating the upload of dayfile.txt

Discussion and support for 3rd-party (non-Sandaysoft) tools for Cumulus
User avatar
Super-T
Posts: 767
Joined: Tue Sep 09, 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Automating the upload of dayfile.txt

Postby Super-T » Fri Mar 11, 2011 10:02 am

I get stuck at a point where the file has been created and then it just sits there without uploading the data and then times out with 0 bytes sent.
Your error may be specific to your host as I don't get that problem.

My result:- This is using "moveItFreely" ftp prog.
C:\WeatherAnalysis>ftps -s:c:\weatheranalysis\daily.ftp linux11.digiweb.net.nz
220 (vsFTPd 2.0.5)
Connected to linux11.digiweb.net.nz.
User: 331 Please specify the password.
Password: 230 Login successful.
ftp> Debugging On .
ftp> Local directory now C:\WeatherAnalysis.
ftp> ---> PASV
227 Entering Passive Mode (202,174,112,121,226,207)
ftp> ---> TYPE I
200 Switching to Binary mode.
ftp> ---> CWD www/weather/data
250 Directory successfully changed.
ftp> ---> PORT 10,1,1,200,192,164
200 PORT command successful. Consider using PASV.
---> STOR test.txt
150 Ok to send data.
ftp: 0 bytes sent in 5.07Seconds 0.00Kbytes/sec.
ftp> ---> QUIT
221 Goodbye.

Also a MS note here:-
http://support.microsoft.com/kb/271078/en-us

tjaliwalpa
Posts: 290
Joined: Sun Apr 18, 2010 9:47 am
Weather Station: Davis VP2
Operating System: Linux Lite Ubuntu 16.04
Location: Karoonda, SA
Contact:

Re: Automating the upload of dayfile.txt

Postby tjaliwalpa » Fri Mar 11, 2011 10:10 am

Super-T wrote:I get stuck at a point where the file has been created and then it just sits there without uploading the data and then times out with 0 bytes sent.
Your error may be specific to your host as I don't get that problem.

My result:- This is using "moveItFreely" ftp prog.
C:\WeatherAnalysis>ftps -s:c:\weatheranalysis\daily.ftp linux11.digiweb.net.nz
220 (vsFTPd 2.0.5)
Connected to linux11.digiweb.net.nz.
User: 331 Please specify the password.
Password: 230 Login successful.
ftp> Debugging On .
ftp> Local directory now C:\WeatherAnalysis.
ftp> ---> PASV
227 Entering Passive Mode (202,174,112,121,226,207)
ftp> ---> TYPE I
200 Switching to Binary mode.
ftp> ---> CWD www/weather/data
250 Directory successfully changed.
ftp> ---> PORT 10,1,1,200,192,164
200 PORT command successful. Consider using PASV.
---> STOR test.txt
150 Ok to send data.
ftp: 0 bytes sent in 5.07Seconds 0.00Kbytes/sec.
ftp> ---> QUIT
221 Goodbye.

Also a MS note here:-
http://support.microsoft.com/kb/271078/en-us


Actually, my issue very similar. When I have the firewall enabled, to dayfile.txt is deleted and created as a blank file. The process hangs for a time and the replacement file is not transferred. Eventually, it gives up and the following is displayed:

425 Could not open data connection to port 53496: Operation timed out
ftp> quit
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.

The port number is not always the same, so I can't figure out the rule to create.

Edit:
Don't know if I've done the right thing, but if I allow Outbound and Inbound for the the File Transfer Program in my Firewall, everything works beautifully.
Bob

User avatar
mcrossley
Posts: 4615
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Automating the upload of dayfile.txt

Postby mcrossley » Fri Mar 11, 2011 12:13 pm

Super-T wrote:I get stuck at a point where the file has been created and then it just sits there without uploading the data and then times out with 0 bytes sent.
...
200 PORT command successful. Consider using PASV.
...
Also a MS note here:-
http://support.microsoft.com/kb/271078/en-us

So the MS FTP does not support PASV mode, you may have to use something like WinSCP - it's nice to have it around anyway!

Or as Bob has done, open up your firewall for two way sessions with the FTP client (computer and possibly router).
Last edited by mcrossley on Fri Mar 11, 2011 1:27 pm, edited 1 time in total.

User avatar
daj
Posts: 2040
Joined: Tue Jul 29, 2008 8:00 pm
Weather Station: WH1081
Operating System: Pi & MX
Location: SW Scotland
Contact:

Re: Automating the upload of dayfile.txt

Postby daj » Fri Mar 11, 2011 12:56 pm

Yeah, the MS FTP tool is a very simple implementation, but it is one that everyone has on their system so is a good starting point.

Some useful reading in this topic, so I will add a link from the Wiki article to this for other who may have problems.
David
kippfordweather.uk
Cumulus MX & Raspberry Pi

User avatar
Super-T
Posts: 767
Joined: Tue Sep 09, 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Automating the upload of dayfile.txt

Postby Super-T » Fri Mar 11, 2011 7:52 pm

Bob
I did try turning off firewall at one time but your experience means I will re-visit that today.
My Host support seemed to think it was all to do with them requiring PASV as that is meant to avoid the firewall problem but in my case, there is something else involved.

User avatar
mcrossley
Posts: 4615
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Automating the upload of dayfile.txt

Postby mcrossley » Sat Mar 12, 2011 11:16 am

Terry, if your host requires PASV mode, then you cannot use the MS command line FTP client, you will have use to use something else.

User avatar
Super-T
Posts: 767
Joined: Tue Sep 09, 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Automating the upload of dayfile.txt

Postby Super-T » Sat Mar 12, 2011 7:52 pm

They suggested MoveItFreely.....with the same result :-/

User avatar
Super-T
Posts: 767
Joined: Tue Sep 09, 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Automating the upload of dayfile.txt

Postby Super-T » Sun Mar 13, 2011 11:19 pm

I have found the problem, with the help of my hosting service.
The host requires passive mode so you need to put a -a in the bat file.
Microsoft FTP doesn't support passive mode.

ftp.bat
ftps -a -s:daily.ftp

(ftps is from the "moveItFreely" ftp programme) http://www.brothersoft.com/moveit-freely-89144.html Or some other.

Then the daily.ftp would be:-
open linux11.digiweb.net.nz
mylogin
mypwxxxxxx
put test.txt
bye

Change your settings to suit.


Return to “3rd Party Tools”

Who is online

Users browsing this forum: No registered users and 1 guest