Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Barometer face colour problem

Discussion of Mark Crossley's HTML5/Javascript gauges

Moderator: mcrossley

User avatar
Watts Bridge
Posts: 8
Joined: Fri Mar 10, 2017 8:23 pm
Weather Station: Davis Pro2
Operating System: Windows 7 Professional
Location: Brisbane, Australia

Barometer face colour problem

Postby Watts Bridge » Wed Mar 29, 2017 10:25 pm

Hello Everyone,

First time post for me.
I am in the process of setting up a weather station for our local airfield.
The station is a Davis Vantage Pro 2 (Only arrived last night), software is Cumulus MX with Steel Series Gauges.

The problem is the Barometer has a red face when displaying in hPa, mb and kPa but normal background colour for inHg. See screen captures below.
The gauges page is currently at http://www.wattsbridge.com.au/weatherstation/gauges.php but will be on and off as the development continues, prior to it going online full time.

Can anyone help me with the barometer background colour issue please??
All help appreciated, Thanks.



IMG_2124.jpg

inHg.PNG

hPa.PNG
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 4979
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Barometer face colour problem

Postby mcrossley » Thu Mar 30, 2017 9:14 am

It's actually the inHg gauge that is wrong! The red sectors indicate the area of the gauge above and below your all-time high and low pressure readings. As you have just installed the station these all-time records will only be your daily range on day one, possibly a bit wider on day two etc.

So once you have acquired a reasonable amount of historic data those red sectors will be pushed to ends of the gauge range and give you an indication of whether the current reading is "really high or low" for your area.

I should look into why they are not showing on the inHg gauge, but a I'm a bit busy at the mo...

User avatar
mcrossley
Posts: 4979
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Barometer face colour problem

Postby mcrossley » Thu Mar 30, 2017 9:21 am

I see there is a problem with the rain gauge too, it shouldn't redraw like that at every update.

186 mm of rain in a day!!! That has thrown the gauge into new territory and highlighted a deficiency in the code to do with the "niceScale" setting. I put that on the to-do list to fix... expect version 2.5.19 soon.

You are running a relatively old version of the script too - 2.5.5 - I'd suggest you update before I look in the inHg problem, I think I may have fixed that at some point. Also the gauges page still has version 2.5.0 text hardcoded.

User avatar
Watts Bridge
Posts: 8
Joined: Fri Mar 10, 2017 8:23 pm
Weather Station: Davis Pro2
Operating System: Windows 7 Professional
Location: Brisbane, Australia

Re: Barometer face colour problem

Postby Watts Bridge » Thu Mar 30, 2017 9:53 am

Hi Mark,

Thank you for getting back to me with an answer so quickly. Also, even more so, thanks for the wonderful work you do supporting the gauges.

As it happened, the day we received our station, (yesterday) a deep rain depression, the remnants of a tropical cyclone came down the coast, pretty much overhead. Amazingly, there has been almost no surface wind at all!! It sure has provided an interesting set of circumstances for testing the hardware and software :)

Can you please point me to the latest version of Steel Series?
I followed the WIki, at least I think I did, and downloaded from GIT Hub?

Once again - Thanks Mate!

User avatar
mcrossley
Posts: 4979
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Barometer face colour problem

Postby mcrossley » Thu Mar 30, 2017 5:51 pm


User avatar
Watts Bridge
Posts: 8
Joined: Fri Mar 10, 2017 8:23 pm
Weather Station: Davis Pro2
Operating System: Windows 7 Professional
Location: Brisbane, Australia

Re: Barometer face colour problem

Postby Watts Bridge » Sun Apr 02, 2017 8:55 pm

Updated to 2.5.19 - All good ;)
That eye is spoookyyy!!!


Return to “SteelSeries Gauges”

Who is online

Users browsing this forum: No registered users and 1 guest