Page 1 of 1

Updating old version of steel gauges

Posted: Sat Jun 02, 2018 3:30 pm
by The PIT
I'm trying to update an old version of Steel gauges to the latest version.

In theory I need to edit gauges.ssT and gauges.js

I used notepad++ and compared the files and then made the changes

I then copy gauges.sst and realtimegaugesT to the cumulus folder after backing it up.

Copy the new script and css folder to the web server removing the old versions and backing them up.

I then get a screen without any gauges so I'm missing something. The realtimegauges.txt file is populated so that isn't the problem.

I've moved back to the old version for now any have I missed a step?

Re: Updating old version of steel gauges

Posted: Sat Jun 02, 2018 4:14 pm
by water01
I am not sure what gauges.sst is but if it the HTML file that is used to load the gauges it ought to be renamed as gauges.htm and you do not mention that you copied the gauges.js to your server either. They must match versions.

Re: Updating old version of steel gauges

Posted: Sat Jun 02, 2018 4:46 pm
by The PIT
Gauges-ssT is the file just accidentally used . rather than a - when posting.

gauges.js is a script file so yes that is on the web servera s I copied that across when I copied the script folder.

Re: Updating old version of steel gauges

Posted: Sun Jun 03, 2018 9:29 am
by The PIT
Fixed it.
Simply restarted from scratch and did the same as did previously and it worked. So somewhere a invalid character got inserted either into the script file or the htm file.

Re: Updating old version of steel gauges

Posted: Sun Jun 03, 2018 9:41 am
by The PIT
I've noticed that the cumulus wiki is out of date and says version 2.6.1 is the latest the latest is 2.6.4. Could cause problems for users updating if something has changed and isn't mentioned.

Re: Updating old version of steel gauges

Posted: Sun Jun 03, 2018 1:50 pm
by mcrossley
Glad you got it working.

The PIT wrote:I've noticed that the cumulus wiki is out of date and says version 2.6.1 is the latest the latest is 2.6.4.

Thanks, wiki now updated.