Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Connecting the Hydreon RG11 digital rain sensor.

Discussion of this sensor and its uses
User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby steve » Wed Jun 20, 2012 3:20 pm

apenwith wrote:Will the RG log data be at the end of the MMMyylog record.

It will, yes. I'll be uploading the new build shortly.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
duke
Posts: 845
Joined: Sun Jul 03, 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby duke » Wed Jun 20, 2012 4:52 pm

steve wrote:
apenwith wrote:Will the RG log data be at the end of the MMMyylog record.

It will, yes. I'll be uploading the new build shortly.


Steve, thanks for all the work you've put into this this week. :)

Now we have confirmation that it works, would it be possible to set the comm ports individually?

For example: one for "tipping bucket" mode and one for "it's raining"?

As a few of us have taken advantage of the "free one" it would be good to both to good use.

Duke
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby steve » Wed Jun 20, 2012 5:23 pm

duke wrote:would it be possible to set the comm ports individually?

For example: one for "tipping bucket" mode and one for "it's raining"?

Allowing two would be fairly easy, yes. I can add a second set of settings. The code would assume that you'd set them sensibly.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
duke
Posts: 845
Joined: Sun Jul 03, 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby duke » Wed Jun 20, 2012 6:10 pm

Thank you. But excuse my ignorance :? could you elaborate:
The code would assume that you'd set them sensibly.


Duke
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby steve » Wed Jun 20, 2012 6:17 pm

It would assume (by not doing any checking) that if you have two, you had set one to "It's raining" and one to "tipping bucket". Any other combination would not give sensible results.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
duke
Posts: 845
Joined: Sun Jul 03, 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby duke » Wed Jun 20, 2012 6:28 pm

steve wrote:It would assume (by not doing any checking) that if you have two, you had set one to "It's raining" and one to "tipping bucket". Any other combination would not give sensible results.


That seems perfect to me. :)

At the start of the other thread you said "if enough people were interested you would look at adding support". I think it will be the other way now. Now you've made it so easy for anyone to use the RG11 in I think there sales will improve.

Looks like I got a busy weekend now. :lol:

Thank you for your work.

Duke
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

User avatar
pete_c
Posts: 228
Joined: Wed Oct 12, 2011 11:22 pm
Weather Station: Davis Vue-Pro2 - Fine Offset
Operating System: W2003-XPSP3-Linux
Location: Time Traveler

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby pete_c » Sat Jun 23, 2012 1:29 pm

I've installed and ran cable inside of the house for Hydreon RG-11 #2. This morning setting up the RS-232 interface (no capacitor yet though).

Here is a picture (through a window; so not really that sharp).

Trying something different here. My current Cumulus / Davis Vantage Vue serial connection is via a serial to IP box (Quatech). I am hooking this RS-232 connection to another Quatech box (#2); guessing it will work just fine.
You do not have the required permissions to view the files attached to this post.
- Pete

http://longboatkey.golffan.us/ - Fine Offset

http://BrokenArrow.golffan.us/ - Davis Vantage Vue / Pro2 - Cumulus MX

User avatar
pete_c
Posts: 228
Joined: Wed Oct 12, 2011 11:22 pm
Weather Station: Davis Vue-Pro2 - Fine Offset
Operating System: W2003-XPSP3-Linux
Location: Time Traveler

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby pete_c » Sun Jun 24, 2012 1:19 pm

Yesterday in the PM I hit the digital rain guage with the garden sprinkler to validate its function with Cumulus. The numbers did increment. I didn't turn on the debug logging until later. That said we have had no rain in this area; so just waiting. While the two instruments are adjacent to each other one is set to a .001 bucket tipping count and I may change that such that the two are configured identically.
- Pete

http://longboatkey.golffan.us/ - Fine Offset

http://BrokenArrow.golffan.us/ - Davis Vantage Vue / Pro2 - Cumulus MX

apenwith
Posts: 418
Joined: Sun Apr 26, 2009 7:30 pm
Weather Station: w8681 BlakeLarsen Sun Recorder
Operating System: Windows 7 SP1
Location: West Cornwall UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby apenwith » Fri Jun 29, 2012 8:34 am

Hi Steve
I've noticed that if I have to restart Cumulus it adds one 'tip' to the RG11 count. Would it be possible to ignore the message on start.
Regards
Alan

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby steve » Fri Jun 29, 2012 8:43 am

I could put in an option to ignore the first "tip", I suppose. Things are never simple, are they? Oh well, lesson learned.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
duke
Posts: 845
Joined: Sun Jul 03, 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby duke » Fri Jun 29, 2012 12:30 pm

Is this not the same issue Bruce was having in the double tips thread?
bruce45 wrote:no rain over night in oban

the issue of clearing the recorded rain in the today file. as there had been no rain i was able to move the notebook and cables to make it a bit neater as its set up in the bedroom. i cleared the log and started cumulus and both the today and yesturday figures were as expected 0.00 in both. the found i had not connected the rs232 port. so pluged it in and got a reading in the today rate 0.3

shut down cumulus cleared the log and restarted with the cable connected and still got 0.3

so shut down again got meter out to check for a short on the reed nothing. restarted reading of 0.3 again so restarted reading 0.6 tried a few more time each time on restarting the rate increased by 0.3

anyone any ideas as to what could be causing the false readings on start up?


Duke
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby steve » Fri Jun 29, 2012 1:24 pm

duke wrote:Is this not the same issue Bruce was having in the double tips thread?

Quite possibly.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

bruce45
Posts: 363
Joined: Wed Jan 07, 2009 10:36 pm
Weather Station: wh1081
Operating System: windows 10
Location: Oban Scotland

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby bruce45 » Fri Jun 29, 2012 1:34 pm

the issue i was having with the tip bucket connected to the rs232 port was each time cumulus started there was a dsr on which indicated as one rain unit.

this was i think done to the fact the tip bucket state changes to open circuit on tip.

the older tip bucket gauges change to closed circuit on tip.

one possable answer could be if the rg11 is wet or it is raining when cumulus starts then the contacts could be closed and indicate one rain unit. my rg11 has not arrived yet so i have not been doing anymore tests on the direct rs232 port.

AllyCat
Posts: 997
Joined: Sat Feb 26, 2011 1:58 pm
Weather Station: Fine Offset 1080/1 & 3080
Operating System: Windows XP SP3
Location: SE London

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby AllyCat » Fri Jun 29, 2012 1:42 pm

Hi,

There are potentially two (at least) different issues here which might be related.

Firstly, when Cumulus (and other software such as Hyperteminal) starts up it asserts the DTR line. If the "switch" is closed and/or the handshake lines are buffered in hardware, there is a risk that Cumulus will see a pulse on the "rain" (DSR) line.

The "old" FO rain sensors have "Normally Open" reed switches (which close during a tip) but I believe it was Bruce who reported that with his recent Maplin FO kit, the switch is "Normally Closed". It would be interesting to know if Alan (Blake's) new Clas Ohlson FO rain sensor is Normally Open or Normally Closed.

The Hydreon has a "monostable" output so it should close for only a brief time (~50 - 200 ms) but there is also the possibility of somebody mistakenly wiring the NC relay contact. So IMHO Steve should bide his time until there is more of a consensus into what's happening.

BTW, I thought I had seen the "Double Tips" in my own tests, but I was unable to reproduce the effect when I was very careful to avoid "Contact Bounce" of my test switch.

Cheers, Alan.

PS: Ah, I see Bruce has just posted much the same.

apenwith
Posts: 418
Joined: Sun Apr 26, 2009 7:30 pm
Weather Station: w8681 BlakeLarsen Sun Recorder
Operating System: Windows 7 SP1
Location: West Cornwall UK
Contact:

Re: Connecting the Hydreon RG11 digital rain sensor.

Postby apenwith » Fri Jun 29, 2012 3:03 pm

Hi
I checked the Clas new FO bucket and it is NO. Could it simply be that as Cumulus starts the message is, in effect, a change from 'don't know' to either open or closed.
I think Steve thought an OPTION to ignore the first tip would be possible so that would cover whatever happens to occur - certainly my extra tip is very consistant though I don't often have to restart Cumulus - it was only because I had to use Easyweather to set up units etc (and forgot some) that I did several restarts.
Regards
Alan
Last edited by apenwith on Fri Jun 29, 2012 3:10 pm, edited 1 time in total.


Return to “Hydreon RG-11 Rain Sensor”

Who is online

Users browsing this forum: No registered users and 1 guest