If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3042 Jan 14 2017. See this post for download

Saratoga Templates with PHP 7

Discussion of Ken True's web site templates

Moderator: saratogaWX

Toxic17
Posts: 193
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VP2 Plus
Operating System: Debian 8.6
Location: Bangor, NI
Contact:

Saratoga Templates with PHP 7

Postby Toxic17 » Wed Jan 11, 2017 3:37 pm

Hi there.

Is anyone running Saratoga Templates with PHP 7? I am thinking of upgrading the PHP from 5.6.29 and was wondering does anyone have php7 running without any severe issues?

any Deprecated commands need changed?
Regards Simon
http://www.conligwx.org
Intel NUC - Debian 8.6 - Davis Vantage Pro2 Plus - Cumulus MX v3.0.0 (build 3042)
Image

BigOkie
Posts: 171
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Saratoga Templates with PHP 7

Postby BigOkie » Wed Jan 11, 2017 4:03 pm

My Saratoga website isn't WAN accessible (without firewall modifications as I can access my network from the WAN) but I put 7.0.1 on the Pi I'm running the webserver on and it seems ok. I don't access it a lot, but the only deprecated message I could find was related to Cumulus server side graphs and having to change jpgraphs to 4.0.2 in order for it to work. 3.5.1 won't work on PHP7 as far as I can tell.
Image

Toxic17
Posts: 193
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VP2 Plus
Operating System: Debian 8.6
Location: Bangor, NI
Contact:

Re: Saratoga Templates with PHP 7

Postby Toxic17 » Wed Jan 11, 2017 4:11 pm

Thank for the info. Just looked at my jpgraphs they are 4.0.1 but http://jpgraph.net shows php7 was supported from 4.0.0
Regards Simon
http://www.conligwx.org
Intel NUC - Debian 8.6 - Davis Vantage Pro2 Plus - Cumulus MX v3.0.0 (build 3042)
Image

User avatar
saratogaWX
Posts: 772
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows XP SP3
Location: Saratoga, CA, USA
Contact:

Re: Saratoga Templates with PHP 7

Postby saratogaWX » Wed Jan 11, 2017 6:46 pm

I'm running PHP Version 7.0.14 on saratoga-weather.org and all the current release (stock) scripts are working fine with no errors. Some 3-rd party scripts may need updates which would be provided by those authors. The USA nws-alerts.php script does need a couple of variable initialization tweaks (to initialize as array() instead of '' (a null string)). PHP 7.1 stops doing auto-recasting of string-to-array and posts warning messages instead.

I'll be testing with PHP 7.1 a bit later when I have it available on my VPS.

BCJKiwi
Posts: 817
Joined: Mon Jul 09, 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Saratoga Templates with PHP 7

Postby BCJKiwi » Wed Jan 11, 2017 7:39 pm

Saratoga templates have worked / are working OK with 7.0.10, 7.0.11, 7.0.12, 7.0.13 and 7.0.14 but not with 7.1.0 because of changes to array handling.
Last edited by BCJKiwi on Thu Jan 12, 2017 6:54 am, edited 2 times in total.

User avatar
saratogaWX
Posts: 772
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows XP SP3
Location: Saratoga, CA, USA
Contact:

Re: Saratoga Templates with PHP 7

Postby saratogaWX » Wed Jan 11, 2017 8:25 pm

Other than the nws-alerts.php issues with PHP 7.1, did you find any other scripts that were having issues??

BCJKiwi
Posts: 817
Joined: Mon Jul 09, 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Saratoga Templates with PHP 7

Postby BCJKiwi » Thu Jan 12, 2017 2:05 am

Ken,
Don't actually use NWS Alerts (in New Zealand!!)
The only one I have found so far is the datasummary scripts (creates arrays with [] but could be something else?) by beteljuice.

You can check out the scripts I am using at the link in my sig below BUT the public site is running php 7.0.13. Have various versions on my internal WAMP server for development/testing.

PM or email me if you want any further info ;)

Toxic17
Posts: 193
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VP2 Plus
Operating System: Debian 8.6
Location: Bangor, NI
Contact:

Re: Saratoga Templates with PHP 7

Postby Toxic17 » Thu Jan 12, 2017 2:04 pm

Thanks for the responses guys, I've just installed a new package for my NAS (QApache - Apache 2.4.25/ PHP 7.1.0 +PECL) and setup a new Web share.

So far so good, had to change a few paths etc, but will keep an eye out for any issues and let you know what I find.
Regards Simon
http://www.conligwx.org
Intel NUC - Debian 8.6 - Davis Vantage Pro2 Plus - Cumulus MX v3.0.0 (build 3042)
Image


Return to “Saratoga Templates”

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests