Page 2 of 2

Re: Regional network mesonet-map updated V3.08

Posted: Wed Feb 14, 2018 9:28 am
by Toxic17
HRVistaWeather wrote:Hi,
Seems the Mesonet Maps are not displaying, emailed Ken.

http://www.australiawx.net/forum/index.php?topic=61.msg123#msg123

Kind regards,



same here, the map is not being shown. maybe google maps has changed something.

saratogaWX wrote:I see fix is on the wxforum discussion:

Code: Select all

<script src="https://maps.google.com/maps/api/js?key=<?php echo $googleAPI; ?>&amp;language=<?php print $Lang; ?>" type="text/javascript"></script>

with

Code: Select all

<script src="https://maps.google.com/maps/api/js?key=<?php echo $googleAPI; ?>&amp;language=<?php print $Lang; ?>&v=3.30" type="text/javascript"></script>


to force the older version API to work.

I'll look at a 'real' fix for V3.31 Google API tomorrow...

Re: Regional network mesonet-map updated V3.08

Posted: Wed Feb 14, 2018 4:12 pm
by Mapantz
It may be something to do with a new map?! The UK rain radar that I have on my site has had it's map updated - it uses Google maps.

Re: Regional network mesonet-map updated V3.08

Posted: Wed Feb 14, 2018 4:13 pm
by Toxic17
Mapantz wrote:It may be something to do with a new map?! The UK rain radar that I have on my site has had it's map updated - it uses Google maps.


google moved to a new version of api so it may affect other maps we use too.

Re: Regional network mesonet-map updated V3.08

Posted: Wed Feb 14, 2018 7:21 pm
by saratogaWX
It appears to be a JavaScript error from the Google Maps API code.
In Firefox it says:

TypeError: g.b is undefined js:120:483
trigger https://maps.google.com/maps/api/js:120:483
Tc https://maps.google.com/maps/api/js:50:406
_.J.prototype.bindTo https://maps.google.com/maps/api/js:123:328
_.Uv https://maps.google.com/maps-api-v3/api ... js:152:456
xz.prototype.f https://maps.google.com/maps-api-v3/api ... p.js:84:84
Ug/< https://maps.google.com/maps/api/js:92:4
Zd.prototype.za/</d[a]< https://maps.google.com/maps/api/js:125:2517
_.Ud/< https://maps.google.com/maps/api/js:60:195
Zd.prototype.za/< https://maps.google.com/maps/api/js:125:2627
$d https://maps.google.com/maps/api/js:62:209
Zd.prototype.za https://maps.google.com/maps/api/js:125:2369
<anonymous> self-hosted:952:17
<anonymous> https://maps.google.com/maps-api-v3/api ... map.js:1:1

in Google Chrome it says:

Uncaught TypeError: Cannot read property 'apply' of undefined
at Object.trigger (js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:120)
at Tc (js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:50)
at Ug._.J.bindTo (js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:123)
at new _.Uv (common.js:152)
at Object.xz.f (map.js:84)
at Array.<anonymous> (js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:92)
at js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:125
at Object.<anonymous> (js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:60)
at js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:125
at js?key=AIzaSyA499ykaoUpr3YquZtJUtOcFFMgdjNKniU&language=en:60

in Microsoft Edge it says:

SCRIPT5007: SCRIPT5007: Unable to get property 'apply' of undefined or null reference js (120,483)

Looks like their V3.32 broke it.. you can do a quick fix by replacing (in mesonet-map.php or wxmesonetmap.php depending on which you use)

Code: Select all

<script src="https://maps.google.com/maps/api/js?key=<?php echo $googleAPI; ?>&amp;language=<?php print $Lang; ?>" type="text/javascript"></script>


with

Code: Select all

<script src="https://maps.google.com/maps/api/js?key=<?php echo $googleAPI; ?>&amp;language=<?php print $Lang; ?>&v=3.31" type="text/javascript"></script>


to force the older version API to work.