Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Getting wxssgauges.php to Work

Discussion of Ken True's web site templates

Moderator: saratogaWX

User avatar
Toxic17
Posts: 711
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Deb 9.3 Stretch
Location: Bangor, NI
Contact:

Re: Getting wxssgauges.php to Work

Postby Toxic17 » Tue Jan 09, 2018 10:08 pm

when gauges are working, you make a copy of that folder, so you can revert back to the working one again, if needed. I usually check certain files before uploading them and compare them using notepad++ and compare plugin (new and old files)

usually i only have to edit the gauges.js again. the rest of the files within /lib/steelseries/ are fine. I can only suggest you try getting it back to where it was working, before trying to fix the windrose issue.

adding an upgrade in the middle of it is not the best way forward when trying to learn how it all goes together.

the morale of the story, if it aint broken, dont fix it. :roll:

let us know when you get the gauges back up and running first.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

acatalano
Posts: 87
Joined: Tue Jun 16, 2015 2:07 pm
Weather Station: Davis VP2
Operating System: Raspian, Win7 Pro
Location: Boulder, CO
Contact:

Re: Getting wxssgauges.php to Work

Postby acatalano » Wed Jan 10, 2018 5:39 pm

I have gotten the gauges page going in both apcat.org and boulderwx.com Overall, I would say the problem originated from having installed the SS gauges long ago, in 2015, and then again in a different folder in 2016 or 17 having forgotten about the original. Although it seems as though setting the paths would exclude one folder or the other where the files are located, that was further confused I feel, by having recently updated all the other files too. I do retain backups of everything so it was a matter of swallowing my pride and going back to an earlier version. That said I cannot be certain as to what the real problem was, and of course I can't get the windrose to work. I never could find a windrose.js to put in the scripts folder, even after having downloaded the latest files.

What I need to do, I believe is rip it all out and start over from scratch (with regards to the gauges). I have another domain which is aliased and I should be able to use that as a scratchpad of sorts...when I feel like putting toothpicks under my fingernails it might be a good alternative :bash:
Best Regards,
Anthony Catalano
Boulder, Colorado, USA
Webcam & Weather at:
http://www.boulderwx.com, http://www.apcat.org, http://www.boulderweather.org
Blitzortung Lightning Detector Station 1965

User avatar
Toxic17
Posts: 711
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Deb 9.3 Stretch
Location: Bangor, NI
Contact:

Re: Getting wxssgauges.php to Work

Postby Toxic17 » Wed Jan 10, 2018 9:37 pm

acatalano wrote:What I need to do, I believe is rip it all out and start over from scratch (with regards to the gauges). I have another domain which is aliased and I should be able to use that as a scratchpad of sorts...when I feel like putting toothpicks under my fingernails it might be a good alternative :bash:


I updated my js files from here: https://github.com/mcrossley/SteelSeries-Weather-Gauges

v2.6.4 is the latest at time of writing.

as to discussion it can be taken here: viewforum.php?f=21

Mark(mcrossley) should be able to help it the stranger issues.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image


Return to “Saratoga Templates”

Who is online

Users browsing this forum: No registered users and 1 guest