If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Wind problems

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Wind problems

Postby ClegganBayStation » Wed Jan 11, 2017 5:50 pm

Hi,

I just did a new build with a raspi and cmx two days ago, and while the new system is great, I'm having some issue with the wind. I'm aware of ground loops, and that there might be anemometer problems. But what has me concerned is that after my wind dropping to zero(while blowing a gale outside) for half an hour, a restart fixed the problem hinting towards a software issue. I also had an issue with wind direction where it kept going to 360 intermittently but on disconnecting the VP2 console for a few minutes and then reconnecting and restarting the issue seems to have resolved itself.

Does this make sense to anyone? Any tips or pointers to get me going in the right direction?

Thanks for any help available.

User avatar
steve
Cumulus Author
Posts: 26070
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Wind problems

Postby steve » Wed Jan 11, 2017 6:10 pm

ClegganBayStation wrote:But what has me concerned is that after my wind dropping to zero(while blowing a gale outside) for half an hour, a restart fixed the problem hinting towards a software issue
What was the console showing for wind speed at this time? Which speeds in Cumulus dropped to zero - gust/average etc, or all of them?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Wed Jan 11, 2017 6:13 pm

steve wrote:
ClegganBayStation wrote:But what has me concerned is that after my wind dropping to zero(while blowing a gale outside) for half an hour, a restart fixed the problem hinting towards a software issue
What was the console showing for wind speed at this time? Which speeds in Cumulus dropped to zero - gust/average etc, or all of them?


Zero also. But that leaves me scratching my head as to why a restart of cmx fixed it :?

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Wed Jan 11, 2017 6:14 pm

Just to note this from the logs as well:

Code: Select all

2017-01-11 18:03:36.889 !!! No ack received in response to LPS 2 1

User avatar
steve
Cumulus Author
Posts: 26070
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Wind problems

Postby steve » Wed Jan 11, 2017 6:23 pm

Just the one, or every time it tries to read LOOP2 data? Does your firmware support LOOP2 - what version are you using?

I can't think of any way that Cumulus could cause your console wind speed reading to be zero. It is the case, however, that certain actions by software - in particular reading archive data - can cause the console to freeze briefly. But then it would normally continue to display the last reading rather than zero.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Wed Jan 11, 2017 6:35 pm

Code: Select all

2017-01-11 18:28:52.267  ========================== Cumulus MX starting ==========================
2017-01-11 18:28:52.281 Command line: /opt/CumulusMX/CumulusMX.exe -port 8998
2017-01-11 18:28:52.282 Cumulus MX v.3.0.0 build 3041
2017-01-11 18:28:52.290 Platform: Unix
2017-01-11 18:28:52.292 OS version: Unix 4.4.38.7
2017-01-11 18:28:52.292 Current culture: English (United Kingdom)
2017-01-11 18:28:52.294 Directory separator=/ Decimal separator=. List separator=,
2017-01-11 18:28:52.295 Date separator=/ Time separator=:
2017-01-11 18:28:52.295 Standard time zone name:   GMT
2017-01-11 18:28:52.295 Daylight saving time name: IST
2017-01-11 18:28:52.296 Daylight saving time? False
2017-01-11 18:28:52.298 11/01/2017 18:28:52
2017-01-11 18:28:52.300 Data path = data/
2017-01-11 18:28:52.472 Creating backup folder backup/20170111182852/
2017-01-11 18:28:52.494 Created backup folder backup/20170111182852/
2017-01-11 18:28:52.560 Reading Cumulus.ini file
2017-01-11 18:28:52.653 ASM=10 AST=00:10:00
2017-01-11 18:28:52.660 Cumulus start date: 09 January 2017
2017-01-11 18:28:52.686 Debug logging is disabled
2017-01-11 18:28:52.686 Data logging is disabled
2017-01-11 18:28:52.686 Logging interval = 1
2017-01-11 18:28:52.889 Calculating sunrise and sunset times
2017-01-11 18:28:52.931 Sunrise: 06:04:16
2017-01-11 18:28:52.931 Sunset : 18:11:32
2017-01-11 18:28:52.932 Tomorrow sunrise: 06:04:39
2017-01-11 18:28:52.933 Tomorrow sunset : 18:11:55
2017-01-11 18:28:52.971 Station type: Davis Vantage Pro2
2017-01-11 18:28:52.973 WindUnit=km/h RainUnit=in TempUnit=°C PressureUnit=mb
2017-01-11 18:28:52.977 YTDRain=0.000 Year=0
2017-01-11 18:28:52.977 RainDayThreshold=-1.000
2017-01-11 18:28:52.977 Offsets and Multipliers:
2017-01-11 18:28:52.978 PO=0.000 TO=0.000 HO=0 WDO=0 ITO=0.000 UVO=0.000
2017-01-11 18:28:52.978 WSM=1.000 WGM=1.000 TM=1.000 TM2=1.000 HM=1.000 RM=1.000 UVM=1.000
2017-01-11 18:28:52.978 Spike removal:
2017-01-11 18:28:52.979 TD=999.000 GD=999.000 WD=999.000 HD=999.000 PD=999.000
2017-01-11 18:28:52.979 MR=999.000 MH=999.000
2017-01-11 18:28:52.979 Cumulus Starting
2017-01-11 18:28:52.981 Opening station
2017-01-11 18:28:53.078 Last update time from today.ini: 11/01/2017 18:28:00
2017-01-11 18:28:53.078 Read today file: Date = 11/01/2017, LastUpdateTime = 11/01/2017 18:28:00, Month = 1
2017-01-11 18:28:53.089 ReadTodayfile: set notraininit false
2017-01-11 18:28:53.120 /opt/CumulusMX/data/alltime.ini
2017-01-11 18:28:53.132 Alltime.ini file read
2017-01-11 18:28:53.261 MonthlyAlltime.ini file read
2017-01-11 18:28:53.281 Month.ini file read
2017-01-11 18:28:53.302 Year.ini file read
2017-01-11 18:28:53.309 Finding raintoday from logfile data/Jan17log.txt
2017-01-11 18:28:53.309 Expecting listsep=, decimal=.
2017-01-11 18:28:53.672 Midnight rain found in the following entry:
2017-01-11 18:28:53.672 11/01/17,00:00,10.3,96,9.7,16.1,33.8,295,0.00,0.00,1008.91,2.15,30.1,28,19.3,10.3,10.3,0.0,0,0.000,0.000,7.2,0,0.0,325,0.00,0.00
2017-01-11 18:28:53.895 Setting raintoday from logfile = 0.01
2017-01-11 18:28:53.896 Calculating rain counter = 2.16
2017-01-11 18:28:53.896 Midnight rain found = 2.15
2017-01-11 18:28:53.902 Getting rain totals, rain season start = 1
2017-01-11 18:28:53.902 Today = 11/01/17
2017-01-11 18:28:53.906 Rainthismonth from dayfile.txt: 0.05
2017-01-11 18:28:53.907 Rainthisyear from dayfile.txt: 0.05
2017-01-11 18:28:53.915 Station type = Davis
2017-01-11 18:28:53.915 LOOP2 enabled
2017-01-11 18:28:53.915 Serial device = /dev/ttyUSB0
2017-01-11 18:28:53.933 Connected OK
2017-01-11 18:28:53.938 Reading firmware version
2017-01-11 18:28:54.256 FW version = ???
2017-01-11 18:28:54.260 Reading reception stats
2017-01-11 18:28:54.561 1238 5 0 427 0

2017-01-11 18:28:54.563 Last update time = 11/01/2017 18:28:00
2017-01-11 18:28:54.569 Setting console time
2017-01-11 18:28:54.669 Wait for ACK...
2017-01-11 18:28:54.677 ACK received
2017-01-11 18:28:54.679 Wait for ACK...
2017-01-11 18:28:54.686 ACK received
2017-01-11 18:28:54.691 Reading console time
2017-01-11 18:28:56.696 38-1C-12-0B-01-75-3F-3F
2017-01-11 18:28:56.696 Console clock: 11/01/2017 18:28:56
2017-01-11 18:28:56.697 Start reading archive data
2017-01-11 18:28:56.700 Reading archive data
2017-01-11 18:28:56.701 Loading last N hour data from data logs: 11/01/2017 18:28:00
2017-01-11 18:28:57.196 Loaded 61 entries to last hour data list
2017-01-11 18:28:57.696 Loaded 181 entries to last 3 hour data list
2017-01-11 18:28:58.323 Loaded 1421 entries to graph data list
2017-01-11 18:28:59.509 Loaded 2166 entries to recent data list
2017-01-11 18:28:59.520 Loaded 1 entries to daily data list
2017-01-11 18:28:59.577 Get Archive Data
2017-01-11 18:28:59.578 Rollover hour = 0
2017-01-11 18:28:59.579 Last Archive Date: 11/01/2017 18:28:00
2017-01-11 18:28:59.579 Date: 8747
2017-01-11 18:28:59.579 Time: 1828
2017-01-11 18:28:59.680 Sending DMPAFT
2017-01-11 18:28:59.689 Received response to DMPAFT, sending date and time
2017-01-11 18:28:59.689 2B-22-24-07-7B-32
2017-01-11 18:28:59.689 Wait for ACK...
2017-01-11 18:28:59.706 629 web tags initialised
2017-01-11 18:28:59.729 HTML root path = /opt/CumulusMX/interface
2017-01-11 18:29:00.070 Starting web socket server on port 8002
2017-01-11 18:29:00.814 Updating highs and lows
2017-01-11 18:29:00.819 Start normal reading loop
2017-01-11 18:29:00.855 Start Timers
2017-01-11 18:29:00.855 Starting 1-minute timer
2017-01-11 18:29:00.861 Realtime not enabled
2017-01-11 18:29:03.123 !!! No ack received in response to LPS 2 1
2017-01-11 18:30:00.926 New monthly record, month = 1: 2017-01-11 18:30 485.592 "High daily windrun" 2017-01-11 18:28 485.270
2017-01-11 18:30:01.033 Writing log entry for 11/01/2017 18:30:00
2017-01-11 18:30:01.039 Written log entry for 11/01/2017 18:30:00
2017-01-11 18:30:01.060 Writing today.ini, LastUpdateTime = 11/01/2017 18:30:00 raindaystart = 2.15 rain counter = 2.16


I can safely say our weatherlink has never had it's firmware updated, and the console for that matter. From the above, I'm version: MX v.3.0.0 build 3041

I'll now upgrade both and let you know.

User avatar
steve
Cumulus Author
Posts: 26070
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Wind problems

Postby steve » Wed Jan 11, 2017 6:46 pm

I can't tell from that what your console firmware version is as MX was unable to read it from the console. It needs to be 1.90 or later to support LOOP 2. If your firmware is very old, you won't be able to update anyway, without the updater hardware. If it doesn't have 1.90 or later and you can't update it, you should disable LOOP2 in MX (see instructions).
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Wed Jan 11, 2017 6:57 pm

It's a 2005 console, so I'm betting it can't be upgraded which is a pity, just missed out it seems. But I'll run without LOOP2 and see how I get on.

Thanks for your help.

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Thu Jan 12, 2017 12:10 am

Turning LOOP2 off has helped, but I'm still getting some intermittent null direction readings(360). Are there any other settings I might tweak to see if I can improve performance?

Regards.

BigOkie
Posts: 209
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Wind problems

Postby BigOkie » Thu Jan 12, 2017 4:24 am

ClegganBayStation wrote:Turning LOOP2 off has helped, but I'm still getting some intermittent null direction readings(360). Are there any other settings I might tweak to see if I can improve performance?

Regards.


You don't have the setting for 'Use bearing zero when wind calm' set do you? Are you getting those readings when the wind is 0?

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Thu Jan 12, 2017 9:13 am

BigOkie wrote:
ClegganBayStation wrote:Turning LOOP2 off has helped, but I'm still getting some intermittent null direction readings(360). Are there any other settings I might tweak to see if I can improve performance?

Regards.


You don't have the setting for 'Use bearing zero when wind calm' set do you? Are you getting those readings when the wind is 0?


No, afraid not, it's blowing a gale the whole time, and the wind is fairly changeable, so when it locks to 360, it's noticeable. It just get's stuck there for a few seconds at a time.

ClegganBayStation
Posts: 8
Joined: Mon Jan 09, 2017 9:01 pm
Weather Station: Davis VP2
Operating System: Linux/Windows

Re: Wind problems

Postby ClegganBayStation » Thu Jan 12, 2017 10:43 am

A little more testing this morning, and it's behaving this way with cmx not running, so looks like I can take my focus of the software. I've played around with the data logging interval to see if it improve it, seems to work best on the 1min setting, but otherwise looks like I'll have to focus on the wind vane at some point to see how it behaves. Also will be interesting to monitor behaviour when the wind changes away from the current NW direction it's going.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 4 guests