Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Server Generated Graphs for MX

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
f4phlyer
Posts: 31
Joined: Sun Feb 13, 2011 7:12 pm
Weather Station: Davis Vantage Pro 2
Operating System: RaspBerry Pi Win 10 OSx
Location: Gulf Breeze, Fl., USA
Contact:

Re: Server Generated Graphs for MX

Postby f4phlyer » Sun Jan 31, 2016 5:32 pm

Thanks again, I'll upload the new work.

Now I'm working on realtimelogSql.php, it fails on the DB query.
Steve
The Squeaky Sands Inn
CumulusMX on Raspberry π 3
WeatherUnderground KFLGULFB1
http://www.squeakysands-inn.net/index.php

User avatar
laulau
Posts: 525
Joined: Tue Oct 13, 2009 10:52 pm
Weather Station: WeatherDuino Pro2
Operating System: Win 7
Location: Meyenheim, Alsace, FR
Contact:

Re: Server Generated Graphs for MX

Postby laulau » Sun Jan 31, 2016 6:01 pm

Hi,
Am i right that the windrose script needs the pro version of JpGraph ?
Capture.JPG
You do not have the required permissions to view the files attached to this post.
Laurent

Image

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sun Jan 31, 2016 6:34 pm

No, it is included in the free version. Never noticed that table before, but the free download does include the windrose module, whether by accident or design?...

User avatar
HRVistaWeather
Posts: 167
Joined: Mon Apr 09, 2012 2:38 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 7 Ultimate (64bit)
Location: Franklin, Huon Valley, Tasmania
Contact:

Re: Server Generated Graphs for MX

Postby HRVistaWeather » Sat May 07, 2016 1:12 am

mcrossley wrote:OK, a new version of the Windrose scripts is now available (and associated graphSettings.php).

Most windrose settings moved to graphSettings.php
Windrose can now be configured for 8 or 16 compass points
Windows compass point now localised
Wind speed unit put into the title
Image caching enabled

I think it all works, but I'll expect I hear if it doesn't!


Hi Mark,

Installed the latest : graphWindRose.php
.json : http://hrvistaweather.com/wxshare/graphWindRose.php 48hr
SQL : http://hrvistaweather.com/wxshare/graphWindRoseSql.php 48hr

However I feel they are way off (seem flipped / rotated) or something like.

When compared to my :

.json : (Wind Direction) http://hrvistaweather.com/wxshare/graphWdir.php 48hr (I believe displays correctly).
SQL: : (Wind Direction) http://hrvistaweather.com/wxshare/graphWdirSQL.php 48hr (I believe displays correctly).

SQL: (Wind Rose) Highcharts : http://hrvistaweather.com/weather/wxwindrose.php select 48hr (I believe displays correctly).

regards,
Tony
https://southfranklinweather.com
Image
Huon River Vista - South Franklin Weather - Tasmania
Davis Vantage Pro 2 Plus - FARS, Cumulus MX, 2 Soil Temp/Moist Solar/Rad.
Back Online : 2017-11-01

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sat May 07, 2016 11:31 am

Thanks Tony, I'll have a look at this later - deep joy, debugging some else's code!

Mine does seem to roughly correspond to my Highcharts graph, so some investigation is requried.

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Mon May 09, 2016 10:17 am

Tony, I think I have found the problem with the windrose, version 1.2 is now on GitHub.

User avatar
HRVistaWeather
Posts: 167
Joined: Mon Apr 09, 2012 2:38 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 7 Ultimate (64bit)
Location: Franklin, Huon Valley, Tasmania
Contact:

Re: Server Generated Graphs for MX

Postby HRVistaWeather » Sat May 14, 2016 12:37 pm

Hi Mark,

Sorry late reply, been off the planet for a while (bad Viral Chest infection) .

Greatly appreciated, all seems to be correct now, installed both json and sql.

Kind regards,
Tony
https://southfranklinweather.com
Image
Huon River Vista - South Franklin Weather - Tasmania
Davis Vantage Pro 2 Plus - FARS, Cumulus MX, 2 Soil Temp/Moist Solar/Rad.
Back Online : 2017-11-01

User avatar
HRVistaWeather
Posts: 167
Joined: Mon Apr 09, 2012 2:38 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 7 Ultimate (64bit)
Location: Franklin, Huon Valley, Tasmania
Contact:

Re: Server Generated Graphs for MX

Postby HRVistaWeather » Fri Jul 08, 2016 11:37 pm

Hi Mark,

Sorry, having more issues with : graphWindRose.php

We have been in a near dead calm state wind wise recently 90(+)% over 48hrs, and i am wondering if all of a sudden this is the cause of the graphWindRose.php failing again.

i.e. mainly ( 0 or 0.0 ) data in the .json files. (Note same error occuring with the Sql Version which makes me think it is the 0's)
I have saved copies of the .json files as at time of post (just in case the wind increases and results in error going away).

http://hrvistaweather.com/wdirdata_calm.json
http://hrvistaweather.com/winddata_calm.json

.json : http://hrvistaweather.com/wxshare/graphWindRose.php 48hr
SQL : http://hrvistaweather.com/wxshare/graphWindRoseSql.php 48hr

Kind Regards,
You do not have the required permissions to view the files attached to this post.
Tony
https://southfranklinweather.com
Image
Huon River Vista - South Franklin Weather - Tasmania
Davis Vantage Pro 2 Plus - FARS, Cumulus MX, 2 Soil Temp/Moist Solar/Rad.
Back Online : 2017-11-01

master1986
Posts: 16
Joined: Fri Jul 08, 2016 6:14 am
Weather Station: Lacrosse 2350
Operating System: Windows 8.1
Location: Italia

Re: Server Generated Graphs for MX

Postby master1986 » Sat Jul 09, 2016 10:06 am

hello , I would be interested to save data to MySQL and read .

However, the aim should be to generate a graph of a precise period , then selecting the start and end of the period .

It's possible?

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sat Jul 09, 2016 4:03 pm

HRVistaWeather wrote:i.e. mainly ( 0 or 0.0 ) data in the .json files. (Note same error occuring with the Sql Version which makes me think it is the 0's)
I have saved copies of the .json files as at time of post (just in case the wind increases and results in error going away).

http://hrvistaweather.com/wdirdata_calm.json
http://hrvistaweather.com/winddata_calm.json

.json : http://hrvistaweather.com/wxshare/graphWindRose.php 48hr
SQL : http://hrvistaweather.com/wxshare/graphWindRoseSql.php 48hr

Kind Regards,

Tony, could you send me your graphWindRose.php and graphSettings.php files please? The line numbers in your error messages do not time up with the latest versions.

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sat Jul 09, 2016 4:17 pm

Actually, it doesn't matter, I figured it out from the 4x error messages, now to debug...

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sat Jul 09, 2016 4:18 pm

master1986 wrote:hello , I would be interested to save data to MySQL and read .

However, the aim should be to generate a graph of a precise period , then selecting the start and end of the period .

It's possible?

Sounds like it should be, once you have the data in MySQL you can extract pretty much whatever you want.

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Sun Jul 10, 2016 12:08 pm

Well, that was interesting! I think the WindRose may finally be sorted out, the 'help' and documentation on the JPGraph site leaves shall we say a little to be desired, I had to reverse engineer the classes to work some of it out. The code was not plotting calm conditions at all.

Anyway ver 1.4+ is on GitHub, give it a whirl.

BCJKiwi
Posts: 847
Joined: Mon Jul 09, 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Server Generated Graphs for MX

Postby BCJKiwi » Mon Jul 11, 2016 3:43 am

Not used the windrose graph before.

Just downloaded and updated the set from GitHub and tweaked all the ones I was already using and all are OK.
Tried to get the windrose working without success - everything else is OK.
Yes I did mod the jpgraph_windrose.php file to remove the import of 'jpgraph_glayout_vh.inc.php'.
The caching fix was already applied.

When I run the graphWindRose.php directly on the local dev server with 'errors on' I see
Undefined index: NNE in C:\wamp64\www\wxshare\graphWindRose.php on line 78 (and the corresponding errors any other directions in play) with corresponding
Invalid argument supplied for foreach() in C:\wamp64\www\wxshare\graphWindRose.php on line 82
Doing this on the public webserver only shows the foreach() errors.

The paths are all set to my particular setup and are correct.

Any suggestions?
Thanks

User avatar
mcrossley
Posts: 5017
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Server Generated Graphs for MX

Postby mcrossley » Mon Jul 11, 2016 10:31 am

Doh! OK, I see a possible issue, I'll send you a test version a bit later today...


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 9 guests