If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Installation auf raspberry

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Sun Jan 15, 2017 6:39 pm

Should not at least the display of "Sun rises", "Sun sets", Moon rises "etc, as well as the lunar picture also without recognition of the weather station? Latitude and Longitude data is entered correctly.
Dieter

User avatar
steve
Cumulus Author
Posts: 25904
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Installation auf raspberry

Postby steve » Sun Jan 15, 2017 6:46 pm

Where are you looking? There is no "lunar picture" in MX.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Tue Jan 17, 2017 9:23 am

In which directory on RaspBerry you have installed CumulusMX?
Dieter

User avatar
steve
Cumulus Author
Posts: 25904
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Installation auf raspberry

Postby steve » Tue Jan 17, 2017 3:16 pm

I don't understand why you're asking me that. I don't actually have a weather station any more and don't use Cumulus myself. I think I had it installed in /home/pi/CumulusMX
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Wed Jan 18, 2017 8:50 am

After reinstallation of the CumulusMX and settings of the station I get the message "error [object Object]"
What am I doing wrong?
What permissions do I have to set for Cumulus?
The station is now recognized.
The display shows "Dasboard", "now" and "gauges" without data, correctly "Charts", "Today/Yesterday", "Records" with data.
Please help me!
Dieter

User avatar
steve
Cumulus Author
Posts: 25904
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Installation auf raspberry

Postby steve » Wed Jan 18, 2017 10:40 am

bajowar wrote:After reinstallation of the CumulusMX and settings of the station I get the message "error [object Object]"


From the MX FAQ: "An "error [object Object]" in your browser when you try to change settings is usually caused by using a version of Mono which does not support comma decimals, but can also be caused by an invalid setting"

The display shows "Dasboard", "now" and "gauges" without data, correctly "Charts", "Today/Yesterday", "Records" with data.


From the MX FAQ: "The Dashboard, Now, and Gauges pages all get their data using web sockets (on port 8002). If they are not displaying data for you, you have some issue somewhere on your system preventing that from working - a firewall issue, or perhaps a browser issue. If you can't get web sockets working on your system, you could switch to using Ajax for the data. See the announcement for build 3032 for instructions."

Please help me!


The MX FAQ is here: http://sandaysoft.com/forum/viewtopic.php?f=27&t=12943
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Wed Jan 18, 2017 4:24 pm

Helo Steve,
thank you for your help. But i have a new question: Where can I get the images in "gauges"? And where should I install those?
In "http://www.engelrod.com/wetterbericht" you can see my Wetterstation.
Dieter

User avatar
steve
Cumulus Author
Posts: 25904
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Installation auf raspberry

Postby steve » Wed Jan 18, 2017 4:31 pm

It looks like you haven't copied the required files (the contents of the webfiles folder) to your web server. Have you read the instructions?

Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... een.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... age.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... ore.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... ose.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... /gauges.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... een.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... age.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... /gauges.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... ore.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... ose.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
http://www.engelrod.com/wetterbericht/l ... ges-ss.css Failed to load resource: the server responded with a status of 404 (Not Found)

Your graphs page doesn't work either, for the same reason.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Mon Jan 23, 2017 9:42 pm

From viewtopic.php?f=27&t=12943
If you use non-English settings, comma decimals etc, you will experience problems on Linux/OS X with Mono version 3.2.8 (e.g. on Raspberry Pi)
If you want to use your Cumulus 1 data with MX, and you use decimal commas, you will need to edit the .ini files to change the decimal commas into periods/full stops.
What do I have to register in Cumulus.ini in Latitude and Longitude? Mono-version is 3.2.8 What is meant decimal commas into periods/full stops

[Station]
Latitude=50,5761111111111
Longitude=9,25777777777778
LatTxt=N 50° 34' 34"
LonTxt=E 09° 15' 27"

Dieter

User avatar
steve
Cumulus Author
Posts: 25904
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Installation auf raspberry

Postby steve » Mon Jan 23, 2017 9:51 pm

Commas for decimals are as shown in your example:

Latitude=50,5761111111111
Longitude=9,25777777777778

For MX, these lines have to look like this:

Latitude=50.5761111111111
Longitude=9.25777777777778

This is using "full stops" for decimals, which is how the MX ini files have to be, even if your locale uses commas for decimals.

Note that this is true regardless of what operating system or version of Mono you are using. Note also the warning about 3.2.8 and locales which use commas for decimals (e.g. German), which applies even if you edit the files as shown.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Mon Jan 23, 2017 10:46 pm

Sorry, that is not possible. After finishing Cumulus MX, the cumulus.ini has:
Latitude = 0
Longitude = 0
Greetings
Dieter

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Tue Jan 24, 2017 7:57 am

My mono version is 3.2.8 (Debian 3.2.8+dfsg-10) Is this okay?

jank
Posts: 274
Joined: Sat Jun 13, 2015 5:57 pm
Weather Station: weatherstation
Operating System: Debian Wheezy
Location: Germany

Re: Installation auf raspberry

Postby jank » Tue Jan 24, 2017 2:19 pm

Hello Bajowar

why are you not installing the CumulusMX Start Stop Script from the first post and start it with option -c
this will check a lot of things on your Raspberry including the Language and mono settings and "," or "." in your files

./cumulusmx.sh -c or sudo ./cumulusmx.sh -c

Jan
Want to see your Station values on SSH? Cumulusnow http://sandaysoft.com/forum/viewtopic.php?f=27&t=14062
Want a Start|Stop|Restart Script for CumulusMX on RaspberryPi? cumulusmx.sh http://sandaysoft.com/forum/viewtopic.php?f=27&t=13767

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Tue Jan 24, 2017 8:41 pm

I get the message :
The following devices are in Read Only mode which is not good.
tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
What must I do? (I am Linux Beginner)

Dieter

bajowar
Posts: 42
Joined: Sun Jan 08, 2017 8:52 pm
Weather Station: PCE-FWS 20
Operating System: Windows 10/ RaspBerry Pi2
Contact:

Re: Installation auf raspberry

Postby bajowar » Wed Jan 25, 2017 9:54 am

Hallo Jan,
ich schreibe mal auf deutsch.
Das meiste funktioniert, ich kann so damit leben.
Hauptproblem ist halt immer noch, dass beim Aufruf von "ipadresse:8998" keine Daten in Dashboard, Now und Gauges angezeigt werden. Da kommt dann noch ein Hinweis "Connection is closed". Des weiteren kann ich über "Settings" keine Stationsdaten abspeichern. Da kommt die Meldung error[object Object]. Die FTP-Dateneingabe funktioniert. Ich bin also gezwungen, alle Einstellungen direkt in der cumulus.ini zu machen. Die Werte für Latitude und Longitude kann ich nur zweistellig machen, also für meinen Wohnort 51 und 9. Bei Erweiterungen mit z.B "50.34" wird nach Beenden von Cumulus der Wert 0 in die ini-Datei eingetragen. Das heisst, der Punkt wird nicht akzeptiert.
Vielleicht weisst Du ja Abhilfe.

Dieter


Return to “Cumulus MX”

Who is online

Users browsing this forum: igorzo and 1 guest