Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

MX 3043 Issues

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
User avatar
CBers
Posts: 24
Joined: Tue Aug 06, 2013 1:36 pm
Weather Station: N96FY
Operating System: Windows 10
Location: Kent

Re: MX 3043 Issues

Postby CBers » Mon Apr 17, 2017 7:03 pm

Hi Steve.

Yes, it seems to be the pages that use the web sockets (port 8002), as the history/records pages work OK.

I added rules to the Windows 10 firewall for the same ports as well.

I'm running CumulusMX as a service via NSSM if that makes a difference, but I am running other services via NSSM and can access them OK via DDNS, so must just be a configuration issue somewhere my end.

Thanks.
Last edited by CBers on Mon Apr 17, 2017 7:09 pm, edited 1 time in total.

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX 3043 Issues

Postby steve » Mon Apr 17, 2017 7:09 pm

No idea, then - sorry (use of the MX user interface across the internet is not something I explicitly considered while wrting the code, because of the issue of the settings being exposed).

Something is apparently stopping the web sockets protocol from working. If you can't get it working, you could try using Ajax instead (as described in the MX FAQ).
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
CBers
Posts: 24
Joined: Tue Aug 06, 2013 1:36 pm
Weather Station: N96FY
Operating System: Windows 10
Location: Kent

Re: MX 3043 Issues

Postby CBers » Mon Apr 17, 2017 7:11 pm

OK thanks.

I'll persevere and report back if I figure it.

I still use the Weather Station widget ob my phone, so noy the end of the world :)

vagos
Posts: 20
Joined: Thu Jan 19, 2017 3:19 pm
Weather Station: WS3083 Aercus Instruments
Operating System: Win10 + Rasrpian (Rpi1)

Re: MX 3043 Issues

Postby vagos » Sun Sep 03, 2017 12:08 pm

Hello everybody,

It has been a long time since my last post.

I have faced problems by running my Cummu (fatal errors etc) so I have to decided to go fresh.

The latest 2017-08-16-raspbian-stretch-lite is pain to have a static ip so I have switched to 5/7/17

I have installed mono but the Cummu has the attached error.

Any idea what is going on?
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX 3043 Issues

Postby steve » Sun Sep 03, 2017 1:56 pm

You haven't changed to the Cumulus directory before running it, so it can't find its directories.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

vagos
Posts: 20
Joined: Thu Jan 19, 2017 3:19 pm
Weather Station: WS3083 Aercus Instruments
Operating System: Win10 + Rasrpian (Rpi1)

Re: MX 3043 Issues

Postby vagos » Sun Sep 03, 2017 2:25 pm

Thank you Steve,

I though by pointing the folder should work

anyway i have moved again the content of the cumu folder to Pi

If I set the station to fine offest with solar I get the following
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX 3043 Issues

Postby steve » Sun Sep 03, 2017 2:52 pm

Looks like you don't have a complete Mono installation, as installed by the Mono-complete package.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

sv1kwz
Posts: 2
Joined: Thu Feb 09, 2017 12:22 pm
Weather Station: 1
Operating System: 1

Re: MX 3043 Issues

Postby sv1kwz » Thu Sep 07, 2017 10:20 am

Hello everyone.

i'm getting the same error.

my installation is latest Rasbian Stretch with mono rasbianstretch 5.2.0.215.

i already read about possible incomplete mono-complete installation but i don't think so.

i removed and reinstalled mono-complete more than 7 times !!!!

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX 3043 Issues

Postby steve » Thu Sep 07, 2017 2:43 pm

Sorry, that's all I can suggest. Perhaps the version of Mono is not compatible with the third party USB library which MX uses. It hasn't been updated for a long time.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

vagos
Posts: 20
Joined: Thu Jan 19, 2017 3:19 pm
Weather Station: WS3083 Aercus Instruments
Operating System: Win10 + Rasrpian (Rpi1)

Re: MX 3043 Issues

Postby vagos » Fri Sep 08, 2017 9:08 am

Linux is pure devil :bash:

I need a new HW to accommodate running Cumu in Windows from now on. Low cost, low power, easy setup.
There is no way of running it with Rpi. I have already spend around a week trying to find a workaround.

Steve how is tour going?

User avatar
steve
Cumulus Author
Posts: 26247
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX 3043 Issues

Postby steve » Fri Sep 08, 2017 9:48 am

vagos wrote:Linux is pure devil :bash:
It's... "different" :lol:

Steve how is tour going?
Very nicely, thank you. Today is our fourth day in France, and we are loving it. Even if the weather today is not good, we are at a very nice place called Montreuil-sur-mer. And it's not actually by the sea :shock:
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
Toxic17
Posts: 542
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.1 Stretch
Location: Bangor, NI
Contact:

Re: MX 3043 Issues

Postby Toxic17 » Fri Sep 08, 2017 10:56 am

vagos wrote:Linux is pure devil :bash:


I say that about Windows 10 and its bloatware
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 5 guests