If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Weather Station data not being logged

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Weather Station data not being logged

Postby orwell341 » Mon Mar 20, 2017 11:38 pm

I am using CumulusMX running on Raspberry Pi 3 with an Oregon WMR100 weather station. This has been working well for about 6 months. But I noticed recently that nothing was being logged and graphs were showing no plots. The current observation was available. Weather underground was receiving and logging observations but Met Office WOW was not. I selected the full diagnostic logging which showed that nothing was being done with the observations that were successfully read from the weather station, except sending it to WU.

I am not quite sure how to proceed or what diagnostic information would be helpful. Any suggestions would be gratefully received.
Thanks

User avatar
Toxic17
Posts: 364
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 8.6
Location: Bangor, NI
Contact:

Re: Weather Station data not being logged

Postby Toxic17 » Tue Mar 21, 2017 10:18 am

I take it you have restarted CumulusMX?

can you post/upload your latest MXDiags folder files here so Steve and others can take a look.
Regards Simon
https://www.conligwx.org
https://www.conligwx.org/pws/
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 11:43 am

Restarted this quite a few times without any joy. Been wondering about a complete reinstall.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 25820
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Weather Station data not being logged

Postby steve » Tue Mar 21, 2017 12:06 pm

You're not getting any readings from your anemometer, so Cumulus isn't doing certain periodic tasks. There is a FAQ about this, you can either use the NoSensorCheck setting as in the FAQ, or correct the problem with your anemometer.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 1:26 pm

This problem coincided with the wireless link to my anemometer failing - I need to get up on the roof to reset it and restart the link. I added the flag as suggested and restarted CumulusMX without any joy. I wanted to keep things running until I can fix the anemometer so that I don't lose my rainfall record. Thank you for your help. I will be back in touch to let you know how it goes.

User avatar
steve
Cumulus Author
Posts: 25820
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Weather Station data not being logged

Postby steve » Tue Mar 21, 2017 1:47 pm

orwell341 wrote:I added the flag as suggested and restarted CumulusMX without any joy.

Sorry, are you saying that adding NoSensorCheck=1 to the [Station] section while Cumulus was stopped didn't change anything? If you attach the latest MXdiags file, I'll take a look.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 2:20 pm

Thanks - here is the file

20170321-130635.txt
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 25820
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Weather Station data not being logged

Postby steve » Tue Mar 21, 2017 2:27 pm

Are you absolutely sure you've done the change to Cumulus.ini correctly, while Cumulus was stopped?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 5:51 pm

For the avoidance of doubt I stopped CumulusMX and checked Cumulus.ini, which had been correctly edited. Nothing is being added to the Monthly Log File and now WU is no longer getting updates. Have attached the diagnostic file and Cumulus.ini.

20170321-173429.txt
You do not have the required permissions to view the files attached to this post.
Last edited by steve on Tue Mar 21, 2017 5:58 pm, edited 1 time in total.
Reason: File with passwords removed

User avatar
steve
Cumulus Author
Posts: 25820
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Weather Station data not being logged

Postby steve » Tue Mar 21, 2017 5:54 pm

You've put it in the [Alarms] section.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 6:00 pm

Sorry, I thought the section annotations were just for documentation. Which section should it appear in?

User avatar
steve
Cumulus Author
Posts: 25820
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Weather Station data not being logged

Postby steve » Tue Mar 21, 2017 7:07 pm

The [Station] section, as mentioned in the FAQ and my earlier reply.

There's a description of the Cumulus.ini file, including its format, in the wiki - http://wiki.sandaysoft.com/a/Cumulus.ini
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

orwell341
Posts: 7
Joined: Wed Jul 06, 2016 4:38 pm
Weather Station: Oregon WMR180
Operating System: Raspian (Jessie)
Location: Hadleigh, Suffolk
Contact:

Re: Weather Station data not being logged

Postby orwell341 » Tue Mar 21, 2017 11:26 pm

Sorry for being a bit slow on the uptake. All working OK now. Thank you for your help.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 3 guests