If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Raspberry (OrangePi) FineOffset meteostation problem

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Sun Apr 09, 2017 7:05 pm

Hello all.

I have installed mono and CumulusMX on my OrangePi (clone of RaspberryPi) with Armbian (Debian Jessie) installed.
Here some info about mono and Debian:
Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-10)

Operating System: Debian GNU/Linux 8 (jessie)
Kernel: Linux 3.4.113-sun8i
Architecture: arm

After ran cumulis with "mono CumulusMX.exe" command, i got this message:

Current culture: English (United States)
Serial: A7517CD484456E480D66F840008514EE
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2017-04-09T20:57:20
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
sysname=Linux release=3.4.113 machine=armv7l
System.DllNotFoundException: libudev.so.0
at (wrapper managed-to-native) HidSharp.Platform.Linux.NativeMethods:udev_new ()
at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00000] in <filename unknown>:0
Not supported
Fine Offset station not found

But station WH-1080 is connected to USB port, logging with pywws works well.

Any idea what is wrong or what can I do to make Cumulus works?

Thanx for your time.

Mickey

myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Mon Apr 10, 2017 6:05 am

After some time of googling I found solution for "libudev.so.0 is missing".
I made copy of libudev.so.1 to libudev.so.0 and message is gone.
But still no station found:

mono CumulusMX.exe
Current culture: English (United States)
Serial: A7517CD484456E480D66F840008514EE
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2017-04-10T07:54:06
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
sysname=Linux release=3.4.113 machine=armv7l
Fine Offset station not found
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Starting web socket server on port 8002
4/10/2017 7:54:07 AM
Type Ctrl-C to terminate

What now?

Mickey

User avatar
steve
Cumulus Author
Posts: 26080
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby steve » Mon Apr 10, 2017 2:14 pm

Does the command lsusb show that your station is detected by linux? If it is (and it sounds like it probably is, as it's working with pywws), then it could be that the hack to copy libudev may have made the error message go away, but it isn't actually working.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Tue Apr 11, 2017 7:56 am

Hi Steve.

lsusb command shows this output:
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So WH1080 "Missile Launcher" :-) is connected and visible.

I dont know what to do now :-/
Thx for any advice to help me to make Cumulus works...

Mickey

User avatar
steve
Cumulus Author
Posts: 26080
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby steve » Tue Apr 11, 2017 9:52 am

Looks like the libudev hack isn't working.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Wed Apr 12, 2017 12:35 pm

Thx for reply.

And little question: is it my fault, did I made something wrong and can I correct it?
Or it is some kind of "bug" in Cumulus?
I am not sure what is libudev hack :-)

Mickey

User avatar
mcrossley
Posts: 4933
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby mcrossley » Wed Apr 12, 2017 2:22 pm

myckei wrote:I am not sure what is libudev hack :-)

You haven't installed a real copy of libudev.so.0, you have just copied version 1 to version 0 and hoped it works.

myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Wed Apr 12, 2017 2:34 pm

Yes, this could be a problem.
But I dont know, how to install libudev.so.0 :-/
Only solution, that I found was to copy files...

Mickey

EDIT: I have found this topic: viewtopic.php?p=107913#p107913, but still no station found...

Bigfish_oz
Posts: 5
Joined: Mon May 16, 2016 2:30 am
Weather Station: WH3081
Operating System: Windows 10
Location: Australia

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby Bigfish_oz » Sun Apr 16, 2017 2:18 am

Sorry, posted this before I remembered that orangepi runs armbian...

====================================
This is a known problem in some versions of debian jessie (see: https://github.com/szwacz/sputnik/issues/20 ) so may apply also to the versions of raspbian jessie.

You could try the following command:

ln -s /lib/arm-linux-gnueabihf/libudev.so.1 /lib/arm-linux-gnueabihf/libudev.so.0

If you get a permissions error try using

sudo ln -s /lib/arm-linux-gnueabihf/libudev.so.1 /lib/arm-linux-gnueabihf/libudev.so.0

Alternatively, upgrade to a current release of jessie here: https://www.raspberrypi.org/downloads/raspbian/

Cheers.

Bigfish_oz
Posts: 5
Joined: Mon May 16, 2016 2:30 am
Weather Station: WH3081
Operating System: Windows 10
Location: Australia

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby Bigfish_oz » Sun Apr 16, 2017 2:28 am

Ok. Just fired up an Orangepi and checked. There is NO libudev.so.0 present on my version of armbian (latest nightly beta). So, the following command (same as previously) might help.

ln -s /lib/arm-linux-gnueabihf/libudev.so.1 /lib/arm-linux-gnueabihf/libudev.so.0

Sorry for the confusion in my previous post.

Cheers.

myckei
Posts: 6
Joined: Sun Apr 09, 2017 12:37 pm
Weather Station: WH1080
Operating System: Linux

Re: Raspberry (OrangePi) FineOffset meteostation problem

Postby myckei » Mon Apr 17, 2017 8:20 pm

Hello all!

Problem is solved now.
I want to apologize - problem wasnt in armbian or libusb library.
The point was in using pywws script which have to write informations from meteostation to mysql database (https://github.com/x4x/pywws2mysql).
After restart orangepi without running the script, Cumulus ran without any problem. After script - station not found :-)

So now Cumulus is running OK, but no daily.txt is created and daily database is empty.
But it will be another problem in another thread.

Thx everyone for help!

Mickey


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests