If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

MX keeps stopping uploading to website

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
beeman
Posts: 114
Joined: Sat Mar 14, 2009 1:04 pm
Weather Station: Davis Vantage Vue
Operating System: Raspbian
Location: South Oxfordshire, UK

MX keeps stopping uploading to website

Postby beeman » Thu Apr 13, 2017 6:32 pm

I installed MX some while ago on a Pi 2 with an Oregon Scientific WMR 928 console. MX would occasionally just stop updating the website and the MX console would not load in Firefox. I could still get to the Pi with PuTTY so I just did a restart.

The WMR 928 was pensioned off in March and was replaced with a Davis Vantage Vue. The problem is still there.

I've attached the end of 2 MX diag files. My version of MX is Cumulus MX 3.0.0 b3035 - yes I know it is quite old :oops:

Thanks.
You do not have the required permissions to view the files attached to this post.
Image

User avatar
steve
Cumulus Author
Posts: 25970
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: MX keeps stopping uploading to website

Postby steve » Fri Apr 14, 2017 3:21 pm

The Microsoft system code is throwing an exception when it tries to access the serial port. That's all I can say, I'm afraid. Perhaps there's a problem with your serial/USB adapter. Are you using a powered USB hub?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

beeman
Posts: 114
Joined: Sat Mar 14, 2009 1:04 pm
Weather Station: Davis Vantage Vue
Operating System: Raspbian
Location: South Oxfordshire, UK

Re: MX keeps stopping uploading to website

Postby beeman » Fri Apr 14, 2017 6:09 pm

Hi Steve,

Thanks for your reply. I'm not using a powered hub but I do have one somewhere. I'd worked out the problem was something to do with the USB port but hoped it was something obvious. I think this is a different Pi that the WMR928 was attached to but I may be wrong. It happened again this morning @11:00 I'll swap Pis and the USB cable.

Where in the world are you at present?
Regards
Dave
Image

User avatar
steve
Cumulus Author
Posts: 25970
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: MX keeps stopping uploading to website

Postby steve » Fri Apr 14, 2017 7:04 pm

You should try with a powered hub, a pi really needs one for a device which consumes significant power, like a weather station. That said, I'm not sure how much power a Davis stations needs to draw from the USB port, given that it has its own power supply.

At the moment, we are at a caravan park close to Inverewe Gardens in the North-West of Scotland. We're spending Easter here before moving off North again, probably arriving back home in Sanday a week on Monday, after seven months away.

This the view from our van today:

inverewe.jpg
You do not have the required permissions to view the files attached to this post.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

beeman
Posts: 114
Joined: Sat Mar 14, 2009 1:04 pm
Weather Station: Davis Vantage Vue
Operating System: Raspbian
Location: South Oxfordshire, UK

Re: MX keeps stopping uploading to website

Postby beeman » Sun Apr 16, 2017 7:35 am

Great view :)

I have one of these which I put in the line last night. As far as I could tell, no power was coming out of the USB port to feed the console.

I have the USB power meter as one of my other RPis has an RTL-SDR dongle which does consume a lot of power from the USB port.
Image

beeman
Posts: 114
Joined: Sat Mar 14, 2009 1:04 pm
Weather Station: Davis Vantage Vue
Operating System: Raspbian
Location: South Oxfordshire, UK

Re: MX keeps stopping uploading to website

Postby beeman » Mon Apr 17, 2017 8:54 am

I put a powered hub in yesterday but it failed again overnight. Do you think there is any point in getting a "better" USB cable or fitting a couple of ferrite chokes?

I have a Pi Zero W on order so I'll do a new installation on that and report back.
Image

User avatar
steve
Cumulus Author
Posts: 25970
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: MX keeps stopping uploading to website

Postby steve » Mon Apr 17, 2017 9:58 am

Yes, I guess anything is worth trying.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: BERNARDD and 2 guests