If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Web pages won't load

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Sun Jul 09, 2017 4:33 pm

Most browsers on the Pi are very basic and not suitable for viewing things like the MX user interface. Do you have particular requirement for using a browser on the Pi rather than on your PC? Many people don't even run a graphical interface on the Pi at all.

There is no indication of an error while attempting an upload to PWS Weather. If you turn on debug logging, the uploads will be logged including the response from PWS Weather.

It's not a good idea to edit the Cumulus.ini file directly unless it's for a setting which can't be edited via the user interface. The realtimegauges.txt setting is configurable from the user interface, as are the vast majority of settings. It's a good idea to restart MX after changing a setting, as many of them require a restart to take effect.

Have you looked at the station settings page to make sure your settings are still correct for your station? You could also check that PWS Weather is still configured correctly.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Tue Jul 11, 2017 12:55 am

Update - I changed the USB port in the config file and, for reasons I cannot explain, the data is now getting sent to my PWS online weather. It must have somehow changed port numbers when I went to the powered USB connection. So, for the moment, two of my three problems are solved. The most important is that the data is getting online so my drip controller can see it. The config.ini problem is gone as well. I just cannot view the actual data.

r/
Jim

User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Tue Jul 11, 2017 7:27 am

hillyjd wrote: I just cannot view the actual data
What browser are you using? As I've mentioned, most browsers on the Pi are very basic and not up to the job. Have you tried using Firefox or Chrome, for example, on your PC?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Thu Jul 13, 2017 11:23 pm

Steve,

When I was using Cumulus on my PC, it was all good. Display was fine, graphics were great and it posted to my PWS online fine. The ONLY reason I went to the RPi was to keep the weather station posting data to PWS online for my drip controller when we are away from home. We throw the PC in the safe (it's a VERY cool, very small new Intel NUC) when we are away. So in the big scheme of things, MX is doing what I need it to do. The graphics are gravy. I honestly don't think it's the RPi browser, it seems to work fine for everything else. But I guess it could be.

r/
Jim

User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Fri Jul 14, 2017 7:14 am

Yes, the Pi is a great platform for running MX. It's not such a great platform for running a web browser. Your reasons for wanting to use a browser on the Pi aren't clear to me - could you explain? Have you actually tried opening the MX user interface running on the Pi from a browser on your PC? Do you not currently have access to any computer other than the Pi at the moment?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Tue Jul 18, 2017 12:24 am

Steve - the only reason that I try to look at the web browser is to look at the real time gauges display. I enjoy the graphics - you did a great job with those. But as I said it's more important that the data gets to the PWS website so my drip controller can see the data. All that was working fine until 2 days ago when the data at my PWS account went stale again. I just noticed it today. I got the same errors as before; then I realized that I had gone back to the original .ini file which still had the realtime FTP enabled. So I went back in and turned those off:

[FTP site]
Host=
Port=21
Username=
Password=
Directory=
AutoUpdate=0
ActiveFTP=0
Sslftp=0
FTPlogging=0
UTF8encode=1
EnableRealtime=0
RealtimeFTPEnabled=0
RealtimeTxtFTP=0

And then restarted CumulusMX. So this will be the real test. If the data doesn't go stale, I'll stay with the RPi. If it does go stale, I'll switch to using Cumulus on my PC. Not sure how I can get the PC to see the RPi, but I'll give it a try.

r/
Jim

User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Tue Jul 18, 2017 7:39 am

hillyjd wrote:And then restarted CumulusMX

To be clear, when you say restarted, do you mean that you stopped Cumulus to edit Cumulus.ini, and then started it again after the edit? You need to have a Cumulus stopped while doing the edit as otherwise it will overwrite most of the settings when you stop it.

To access the user interface on the Pi from a PC, put http://a.b.c.d:8998 into your browser, where a.b.c.d is the IP address of the Pi.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Tue Jul 18, 2017 6:06 pm

Steve - yes I exited Cumulus MX, made the changes to the .ini file and restarted. So far all is well on the PWS website. Updating nicely every 30 minutes. Historically it will hang up after 2 or 3 days. I will attempt to get the PC to view the RPi interface when I get home tonight. Not sure how to locate the a.b.c.d IP values. I've been using "localhost" when I used the RPi browser. And based on previous blogs, I changed the port to 9999 when I start the program. Thanks for all your help.

r/
Jim

User avatar
mcrossley
Posts: 4968
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Web pages won't load

Postby mcrossley » Tue Jul 18, 2017 6:32 pm

hillyjd wrote: Not sure how to locate the a.b.c.d IP values.
Jim

From a command prompt, type ifconfig and look for the inet adr

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Wed Jul 19, 2017 2:07 am

Thanks - worked like a champ. My PC displays the data no problem. Here's the only weird thing (and at this point it's a "don't care") - after I got the displays working on my PC, I went back to the RPi and typed in the IP address and it showed all the graphics as well, but only one time. I closed out the browser, and then went back to it later on and it would only give me the blank browser page with no graphics. Oh well, seeing them on my PC is actually a bonus since I spend most of my computer time there.

Thanks for all the help.

r/
Jim

User avatar
justnetguy
Posts: 5
Joined: Sun Aug 23, 2015 2:26 pm
Weather Station: Davis Provantage 2
Operating System: Raspbian Jessie
Location: Bradford MA USA

Re: Web pages won't load

Postby justnetguy » Wed Jul 19, 2017 12:53 pm

Page loads without any weather data on Chrome Version 59.0.3071.115 (Official Build) (64-bit)

Works OK with FF, Edge, and i.e.

Running Cumulus MX 3.0.0 b3041 on Rpi

any places to look?

User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Wed Jul 19, 2017 2:04 pm

justnetguy wrote:Page loads without any weather data on Chrome Version 59.0.3071.115 (Official Build) (64-bit)
Which pages - all of them, or just the Dashboard, Now, and Gauges pages? If just those three, then as described in the MX FAQ, for some reason web sockets aren't working with that browser.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

User avatar
justnetguy
Posts: 5
Joined: Sun Aug 23, 2015 2:26 pm
Weather Station: Davis Provantage 2
Operating System: Raspbian Jessie
Location: Bradford MA USA

Re: Web pages won't load

Postby justnetguy » Thu Jul 20, 2017 12:53 pm

Dashboard / Now / Gauges do not display any live data.

Everything else seems just fine.

Attached in cap from dashboard.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26199
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Web pages won't load

Postby steve » Thu Jul 20, 2017 1:07 pm

Then as described in the MX FAQ, for some reason web sockets aren't working with that browser.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

User avatar
justnetguy
Posts: 5
Joined: Sun Aug 23, 2015 2:26 pm
Weather Station: Davis Provantage 2
Operating System: Raspbian Jessie
Location: Bradford MA USA

Re: Web pages won't load

Postby justnetguy » Thu Jul 20, 2017 3:16 pm

Thanks Steve _ I will dig around - used to work on the same PC until Google updated Chrome. This websocket test site works fine. http://www.websocket.org/echo.html


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests