If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Web pages won't load

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
User avatar
justnetguy
Posts: 5
Joined: Sun Aug 23, 2015 2:26 pm
Weather Station: Davis Provantage 2
Operating System: Raspbian Jessie
Location: Bradford MA USA

Re: Web pages won't load

Postby justnetguy » Thu Jul 20, 2017 3:42 pm

It was a cookie.... found a cookie under application / storage / cookies in the developers tools in chrome - cleared it and it works now...

User avatar
justnetguy
Posts: 5
Joined: Sun Aug 23, 2015 2:26 pm
Weather Station: Davis Provantage 2
Operating System: Raspbian Jessie
Location: Bradford MA USA

Re: Web pages won't load

Postby justnetguy » Thu Jul 20, 2017 5:50 pm

Seems to be when switching the [other temps] / gauges then going back to dashboard the cookie gets left behind (see attachment). In my case this is repeatable across multiple installs of Win 10 running Chrome 64 bit - current version. I can not duplicate this behavior on MAC OS Chrome installs.

This may just be a Chrome bug but it may be a good thing to know anyway- Clearing the cookie fixes the issue every time.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26080
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: Web pages won't load

Postby steve » Thu Jul 20, 2017 6:29 pm

Seems odd that gauge cookie stops everything working - maybe Mark can suggest what's going on.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

User avatar
mcrossley
Posts: 4933
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Web pages won't load

Postby mcrossley » Fri Jul 21, 2017 8:48 am

I'll have a look when I get back home. Up in the Lake District at mo....

User avatar
mcrossley
Posts: 4933
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Web pages won't load

Postby mcrossley » Mon Jul 24, 2017 8:35 am

I've taken a look, a cookie is created if you change the Apparent temp gauge to something else - this is correct and is the same as the full web site version of the gauges. I cannot get the page to fail to load when the cookie is set and connecting to my local MX instance. My cookie contents are exactly the same as yours - i.e. "dew". Chrome 59.0.3071.115 (Official Build) (64-bit)

The cookie handling code is the same as the full gauges package.

Can you post the dev console output when the page fails to load? Interesting to see what error you are getting...

hillyjd
Posts: 17
Joined: Sun Apr 23, 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Web pages won't load

Postby hillyjd » Wed Aug 09, 2017 12:26 am

I just wanted to report back that everything has worked flawlessly for almost a month now. Not a hint of a problem either with the real time display or the PWS website. Thanks to Steve and all those who helped this old man learn some new tricks.

r/
Jim


Return to “Cumulus MX”

Who is online

Users browsing this forum: l2k and 2 guests