If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

_wapi_connect: error looking up socket handle

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
igorzo
Posts: 10
Joined: Fri Dec 30, 2016 9:03 pm
Weather Station: davis pro 2
Operating System: windows 10

_wapi_connect: error looking up socket handle

Postby igorzo » Fri May 19, 2017 4:06 pm

I have been having this problem since yesterday on raspberry, what can I depend on? And how to repair it. Thanks for help.

_wapi_connect: error looking up socket handle 0x11
_wapi_connect: error looking up socket handle 0x12
_wapi_connect: error looking up socket handle 0x22
_wapi_connect: error looking up socket handle 0x25
_wapi_connect: error looking up socket handle 0x26
_wapi_connect: error looking up socket handle 0x29
_wapi_connect: error looking up socket handle 0x2b
_wapi_connect: error looking up socket handle 0x2d
_wapi_connect: error looking up socket handle 0x2f
_wapi_connect: error looking up socket handle 0x37
_wapi_connect: error looking up socket handle 0x3a
_wapi_connect: error looking up socket handle 0x3a
_wapi_connect: error looking up socket handle 0x3c
_wapi_connect: error looking up socket handle 0x13
_wapi_connect: error looking up socket handle 0x17
_wapi_connect: error looking up socket handle 0x1a
_wapi_connect: error looking up socket handle 0x1b
_wapi_connect: error looking up socket handle 0x1e
_wapi_connect: error looking up socket handle 0x1e
_wapi_connect: error looking up socket handle 0x27
_wapi_connect: error looking up socket handle 0x2f
_wapi_connect: error looking up socket handle 0x30
_wapi_connect: error looking up socket handle 0x36
_wapi_connect: error looking up socket handle 0x39
_wapi_connect: error looking up socket handle 0x10
_wapi_connect: error looking up socket handle 0x16
_wapi_connect: error looking up socket handle 0x19
_wapi_connect: error looking up socket handle 0x1b

User avatar
steve
Cumulus Author
Posts: 25913
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: _wapi_connect: error looking up socket handle

Postby steve » Fri May 19, 2017 6:16 pm

I've seen those messages myself, but I don't remember if I ever worked out what they were referring to. I think they may be bugs in Mono related to http fetches. What actual problems are you having?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

igorzo
Posts: 10
Joined: Fri Dec 30, 2016 9:03 pm
Weather Station: davis pro 2
Operating System: windows 10

Re: _wapi_connect: error looking up socket handle

Postby igorzo » Sat May 20, 2017 2:51 pm

The problem momentarily stops only on this signal, since it has appeared shortly after a few months that the station is working perfectly. I have verified that data transmitted towards pages wunderground and awekas works regularly. Should I install the mono again?

User avatar
steve
Cumulus Author
Posts: 25913
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: _wapi_connect: error looking up socket handle

Postby steve » Sat May 20, 2017 2:53 pm

Sorry, I don't understand. What is the actual problem that you are having? What isn't working?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

igorzo
Posts: 10
Joined: Fri Dec 30, 2016 9:03 pm
Weather Station: davis pro 2
Operating System: windows 10

Re: _wapi_connect: error looking up socket handle

Postby igorzo » Mon May 22, 2017 11:43 am

From checks done everything works, only the page on the raspberry shows me this message. The question can be blocked, even because it has never signaled these strings for months.

User avatar
steve
Cumulus Author
Posts: 25913
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: _wapi_connect: error looking up socket handle

Postby steve » Mon May 22, 2017 11:53 am

They are output by Mono, not Cumulus. There may be a way to turn them off, I don't know.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests