If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Some issues noticed with MX 3043

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
SamiS
Posts: 27
Joined: Sun Feb 27, 2011 5:13 pm
Weather Station: WH1080
Operating System: Windows 10
Location: Kangasala, Finland

Some issues noticed with MX 3043

Postby SamiS » Tue Jul 04, 2017 8:38 pm

Hi Steve (and all),

Just noticed, that daylight calculation is still not working properly here on Finland, where daylight is currently available 24h... Cumulus 1 shows correctly 24:00, but MX shows 00:00. Day length calculation differs for one minute, but that can be caused by decimal rounding being different. Moon rise and moonset also differ a little more, but the difference is still only a few minutes.

Then I also encountered a strange issue with station connectivity. For some reason all values that cumulus read from station were "stuck" to repeat over and over again. Data files and website data were updated as usual on 10min interval, but all values were flatlined. Also MX console on port 8998 was showing those stuck values, only "last station update" was showing odd time and red triangle. Shouldn't it show only ---- for all values if station is not responding?

Stopping and restarting Cumulus resolved the issue, I did not reset my station, did not disconnect usb or reboot the RPi3. I also tested to restore data folder from last backup, and also the history data was read properly from station's memory.

Since my main website still runs on Cumulus 1, it took me over 2 weeks to notice that the values on secondary MX site were not updating. Is there any logs that I should look for explanation?

PS. I'll be away for next weekend, so my answers to possible questions can be delayed after thursday.

PS2. I'm running MX on RPi3 with Ubuntu and mono 4.0.x if I remember correctly.

User avatar
steve
Cumulus Author
Posts: 26148
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Some issues noticed with MX 3043

Postby steve » Tue Jul 04, 2017 8:50 pm

SamiS wrote:Just noticed, that daylight calculation is still not working properly here on Finland, where daylight is currently available 24h... Cumulus 1 shows correctly 24:00, but MX shows 00:00.
Thanks - I'll take a look when I get chance.

Shouldn't it show only ---- for all values if station is not responding?
Perhaps so, but in general, like Cumulus 1 it just re-displays the last good value in the assumption that it will get some new data before long. Perhaps something for a future enhancement.

Is there any logs that I should look for explanation?
The diags log should show something, more likely if you have debug logging on.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

SamiS
Posts: 27
Joined: Sun Feb 27, 2011 5:13 pm
Weather Station: WH1080
Operating System: Windows 10
Location: Kangasala, Finland

Re: Some issues noticed with MX 3043

Postby SamiS » Tue Jul 04, 2017 9:30 pm

Looked at the diags log. All it says that data input seems to have stopped. Since this is the first connectivity issue on over a half a year of running MX I'm not too worried. Just thought to mention about it when reporting the daylight issue. In fact, this was the first case ever (since 2010) when recovering from stopped data did not requre a station reset on my Fine Offset. :D

I did not notice if there is any obvious warning for this on the cumulus console besides the station data last updated -timestamp? The red triangle with the timestamp did not really attract my attention, since I'm used to old Cumulus's blinking red error light. :oops:

Maybe I'll find a way to trigger an email alert if diags log gets the data stopped -error.

PS. Thank You Steve for a very rapid response.

BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Some issues noticed with MX 3043

Postby BigOkie » Fri Jul 07, 2017 10:20 pm

SamiS wrote:Looked at the diags log. All it says that data input seems to have stopped. Since this is the first connectivity issue on over a half a year of running MX I'm not too worried. Just thought to mention about it when reporting the daylight issue. In fact, this was the first case ever (since 2010) when recovering from stopped data did not requre a station reset on my Fine Offset. :D

I did not notice if there is any obvious warning for this on the cumulus console besides the station data last updated -timestamp? The red triangle with the timestamp did not really attract my attention, since I'm used to old Cumulus's blinking red error light. :oops:

Maybe I'll find a way to trigger an email alert if diags log gets the data stopped -error.

PS. Thank You Steve for a very rapid response.


If you do some searching for my recent posts, I'm actually doing some logic to restart CMX if it loses connection. That's using Raspberry Pi however (Debian) so not sure if that's what you're using, as it would likely be a lot more complex if you were running on Windows.

SamiS
Posts: 27
Joined: Sun Feb 27, 2011 5:13 pm
Weather Station: WH1080
Operating System: Windows 10
Location: Kangasala, Finland

Re: Some issues noticed with MX 3043

Postby SamiS » Thu Jul 13, 2017 1:02 pm

Hi BigOkie,

Thanks for the tip, I had not noticed this discussion on the udev rules -topic.

I'm currently running MX on Rpi3 with Ubuntu, and I'm already using the start-stop-script, so your connection monitoring script should also work very easily.

(My profile still shows Windows 10, since I'm running Cumulus 1 on my primary website, and this secondary MX site is now on "testing phase". I happen to have 2 fine offset consoles, but they both receive the same data from one outdoor unit. This also helps on recovering data if the console freezes and needs reset. :mrgreen: )


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 4 guests