If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Major PC crash

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
User avatar
Mapantz
Posts: 441
Joined: Sat Dec 17, 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64 - A beast.
Location: Wareham, Dorset - UK
Contact:

Major PC crash

Postby Mapantz » Tue Jul 25, 2017 1:55 pm

To cut a long story short, we have workman in doing the bathroom, and there was a major electrical fault. All power went off, when it came back on, my PC bluescreened and rebooted. After it had rebooted, the mouse cursor wasn't working, so I couldn't navigate anywhere! I tried every setting via keyboard shortcuts etc, nothing! I couldn't even do a system restore, because it was all turned off for some reason, and I had no previous installation points. In the end, I had to reinstall windows, but keep my old data. I'm now back up and running, but MX has failed to log the data that the station kept while I had these problems. I checked the diags, and there's a ton of archives being read, right back to the 8th July - Not sure what that's about? Anyway, it shows all the intervals being read, right up until I got up and running again, but it hasn't logged anything in the Jul17log.txt - it ended at 10:30am when the power went out, and started again at 14:30

It's not a massive deal, I have just missed 4 hours of data, but I also don't have any lows for today, as it assumed it all started at 14:30 :(

Kind regards.

20170725-141725.txt
You do not have the required permissions to view the files attached to this post.
Image
Image

User avatar
steve
Cumulus Author
Posts: 26200
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Major PC crash

Postby steve » Tue Jul 25, 2017 2:17 pm

The reason the station sent all that old data is that you apparently have the station logger and the Cumulus log interval set to different values. The station is apparently set to 10 minutes, and it looks like Cumulus might be set to 1 minute?

I can't tell you why you have a gap in your data from that diags file, because it looks like you closed Cumulus down at about 14:12 and then this run was at 14:17, so with a log interval of 10 minutes there wouldn't have been any archive data to download, so it all worked correctly. The required information would be in the diags file from when you first started Cumulus after the outage.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

User avatar
Mapantz
Posts: 441
Joined: Sat Dec 17, 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64 - A beast.
Location: Wareham, Dorset - UK
Contact:

Re: Major PC crash

Postby Mapantz » Tue Jul 25, 2017 2:36 pm

steve wrote:The reason the station sent all that old data is that you apparently have the station logger and the Cumulus log interval set to different values. The station is apparently set to 10 minutes, and it looks like Cumulus might be set to 1 minute?

I can't tell you why you have a gap in your data from that diags file, because it looks like you closed Cumulus down at about 14:12 and then this run was at 14:17, so with a log interval of 10 minutes there wouldn't have been any archive data to download, so it all worked correctly. The required information would be in the diags file from when you first started Cumulus after the outage.


Thanks Steve. I managed to edit the today file with the lows for temps/derived temps, from the lows on my console. As for the logging interval, Cumulus is set to 10 mins, the same as the station. I think what happened there, was that I forgot to put back my Cumulus.ini with all the settings in, I didn't realise, so it may have been set at 1 minute when I first ran MX, I then realised, and closed MX down after the archiving finished, and put back my settings. :oops: Four hours of data missing in the Jul17log is not worth worrying over, it was the disaster with the PC that caused the biggest headache. Anyway, everything is stable and uploading, thankfully.
Image
Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 4 guests