If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

NOAA report average wind speed missing since 7/7

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

NOAA report average wind speed missing since 7/7

Postby BigOkie » Sun Jul 30, 2017 7:10 pm

Anyone else seeing this?

Code: Select all

                   Monthly Climatological Summary for Jul 2017

Name: KOKTULSA13   City: Tulsa   State: OK
Elevation: 620 ft  Lat: N 36 09 24   Lon: W 095 52 26

                  Temperature (°F), Rain (in), Wind Speed (mph)

                                      Heat  Cool        Avg
    Mean                              Deg   Deg         Wind                 Dom
Day Temp  High   Time   Low    Time   Days  Days  Rain  Speed High   Time    Dir
----------------------------------------------------------------------------------
01  79.0  88.0   16:36  72.2   06:27   0.0  14.0  0.00   0.5   6.0   10:44   ESE
02  76.9  91.6   15:33  69.2   21:39   0.0  11.9  0.54   1.0  30.0   17:27     S
03  75.5  87.1   16:07  68.0   04:00   0.0  10.5  0.16   0.9  12.0   14:40    SE
04  74.8  85.0   16:51  69.4   03:51   0.0   9.8  0.66   0.7   9.0   00:27   NNW
05  78.2  89.3   16:49  68.2   04:02   0.0  13.2  0.00   0.9  11.0   13:08    NW
06  81.7  93.5   16:23  69.9   06:09   0.0  16.7  0.00   0.6   8.0   12:45     N
07  85.8  98.6   15:33  71.5   04:53   0.0  20.8  0.00   1.4  11.0   13:32   WSW
08  77.5  85.3   18:22  70.3   09:09   0.0  12.5  0.56   0.9  17.0   07:48   WSW
09  81.4  91.7   15:41  70.3   06:20   0.0  16.4  0.00  ----  11.0   15:21     S
10  83.8  94.2   16:24  72.7   06:36   0.0  18.8  0.00  ----  17.0   12:42   SSW
11  86.1  96.7   16:30  76.0   06:32   0.0  21.1  0.00  ----  14.0   19:09   SSW
12  87.1  97.3   16:40  77.5   06:25   0.0  22.1  0.00  ----  17.0   10:26   SSW
13  87.4  98.2   16:55  77.1   06:35   0.0  22.4  0.00  ----  11.0   14:02   SSW
14  80.9  88.6   17:08  75.8   06:29   0.0  15.9  0.00  ----  14.0   11:22     E
15  81.6  92.3   16:34  74.8   04:25   0.0  16.6  0.05  ----   8.0   16:51   ESE
16  83.9  95.0   14:53  74.0   05:43   0.0  18.9  0.00  ----  10.0   16:16     E
17  84.1  95.6   15:46  73.7   06:39   0.0  19.1  0.00  ----  10.0   08:59   SSE
18  83.5  95.8   15:03  70.2   06:15   0.0  18.5  0.00  ----  10.0   16:14     S
19  87.3  98.5   15:22  75.3   05:29   0.0  22.3  0.00  ----  10.0   14:15     S
20  88.7 100.5   15:16  77.4   05:56   0.0  23.8  0.00  ----  14.0   13:48   SSW
21  89.6 101.0   15:00  78.1   06:42   0.0  24.6  0.00  ----  13.0   09:14     S
22  91.1 102.6   15:54  81.5   06:23   0.0  26.1  0.00  ----  13.0   04:54     S
23  86.3  97.1   16:16  77.4   05:52   0.0  21.3  0.00  ----  11.0   08:53   ENE
24  84.3  97.7   16:18  70.8   06:54   0.0  19.3  0.00  ----   9.0   12:37    SE
25  86.8  97.8   15:15  74.2   06:20   0.0  21.8  0.00  ----  12.0   20:06     S
26  88.3  99.0   17:15  78.5   05:24   0.0  23.3  0.00  ----  14.0   09:59     S
27  84.0  92.9   17:05  77.7   08:04   0.0  19.0  0.14  ----  10.0   01:21   SSW
28  84.2  94.6   17:03  78.0   05:07   0.0  19.2  0.00  ----  10.0   18:18    NE
29  81.3  92.9   15:53  68.1   06:49   0.0  16.3  0.00  ----  12.0   13:51   ENE
----------------------------------------------------------------------------------
    83.5 102.6    22    68.0     3     0.0 536.2  2.11   0.8  30.0     2      SW

Max >=  90.0 23
Max <=  32.0  0
Min <=  32.0  0
Min <=   0.0  0
Max Rain: 0.66 on day 4
Days of Rain: 6 (>= 0.01 in)  5 (>= 0.10 in)  0 (>= 1.00 in)
Heat Base: 65.0  Cool Base: 65.0  Method: Integration


I can provide any files needed to try and troubleshoot, but I'm confounded right now.

User avatar
steve
Cumulus Author
Posts: 26200
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: NOAA report average wind speed missing since 7/7

Postby steve » Sun Jul 30, 2017 7:43 pm

Probably an error in your data file(s). Any error messages in the diags file?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

richard_newberry
Posts: 247
Joined: Tue Apr 12, 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Jessie (VMWARE Esxi 6.0)
Location: Leicester
Contact:

Re: NOAA report average wind speed missing since 7/7

Postby richard_newberry » Sun Jul 30, 2017 8:28 pm

I have it to the data file had lines spaced out had to correct it so it doesn't display -- on average wind speed
Kirby Muxloe Weather
http://kirbymuxloe-weather.dyndns.org web forward to http://kirbymuxloe-weather.co.uk
Also on Kirby Muxloe weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

BigOkie
Posts: 210
Joined: Tue May 28, 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: NOAA report average wind speed missing since 7/7

Postby BigOkie » Sun Jul 30, 2017 10:18 pm

Looks like you might be right...found this just now looking through it:

Code: Select all

2017-07-30 14:12:51.012 Error at line 2202 of data/Jul17log.txt : Input string was not in a correct format.
2017-07-30 14:12:51.013 Please edit the file to correct the error
2017-07-30 14:12:51.013 Loaded 0 entries to last hour data list
2017-07-30 14:12:51.536 Error at line 2202 of data/Jul17log.txt : Input string was not in a correct format.
2017-07-30 14:12:51.536 Please edit the file to correct the error
2017-07-30 14:12:51.536 Loaded 0 entries to last 3 hour data list
2017-07-30 14:12:52.056 Error at line 2202 of data/Jul17log.txt : Input string was not in a correct format.


EDIT: it was the dreaded "row of nuls". wiped those out and all is well...I also had another problem that was corrected by this..I did a CMX restart and the interface graphs were no longer populating past my last reboot. Correcting that fixed that problem as well. I may need to put a check in to notify me when the diag file has this message so I can catch it early.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 4 guests