If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

CumulusMX gets no connection to Wh1080

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Tue Aug 08, 2017 6:12 pm

Hello,
I installed the latest Mono 5.0.1.1 with the latest CumulusMX v3.0.0 build 3043 on a Raspbian Jessie on a Raspi 1

lsusb says:

Code: Select all

lsusb
Bus 001 Device 009: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 001 Device 004: ID 046d:c502 Logitech, Inc. Cordless Mouse & iTouch Keys
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Starting Cumulus with

sudo mono CumulusMX.exe -lang de-DE

results in:

Code: Select all

Current culture: German (Germany)
Serial: 74FECEABEB2DA94ECB5EBA0CD11A7137
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2017-08-08T20:03:43
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
System.MissingMethodException: Method 'Mono.Unix.Native.Syscall.uname' not found.
  at System.RuntimeType.InvokeMember (System.String name, System.Reflection.BindingFlags bindingFlags, System.Reflection.Binder binder, System.Object target, System.Object[] providedArgs, System.Reflection.ParameterModifier[] modifiers, System.Globalization.CultureInfo culture, System.String[] namedParams) [0x0070c] in <9bc402929dff445999ba28b84751d284>:0
  at System.Type.InvokeMember (System.String name, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object target, System.Object[] args, System.Globalization.CultureInfo culture) [0x00000] in <9bc402929dff445999ba28b84751d284>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.String& release, System.String& machine) [0x00047] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.Version& release, System.String& machine) [0x00004] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00002] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
Not supported
Fine Offset station not found
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Starting web socket server on port 8002
08.08.2017 20:03:49
Type Ctrl-C to terminate


Now my question: Why there is no connection? What does

Code: Select all

System.MissingMethodException: Method 'Mono.Unix.Native.Syscall.uname' not found.
mean?

Thanks for help!

Martin

User avatar
steve
Cumulus Author
Posts: 26074
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: CumulusMX gets no connection to Wh1080

Postby steve » Tue Aug 08, 2017 8:41 pm

It could be that you don't have a full installation of Mono (as installed by package mono-complete). Or perhaps they have changed something in Mono 5 which means it is not compatible with the libraries which MX uses.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Wed Aug 09, 2017 7:18 am

Hi Steve,

It could be that you don't have a full installation of Mono (as installed by package mono-complete)
I made complete install. Maybe there are changes in the libraries of mono.

From where can I get the version 4.0.2.5 mentioned in that topic http://sandaysoft.com/forum/viewtopic.php?f=27&t=14222?

I would try this.

Thx Martin

philpugh
Posts: 107
Joined: Tue May 24, 2011 8:34 am
Weather Station: DAVIS VantageVue
Operating System: Debian (RPi) 3.18.11-v7
Location: Antrobus, Cheshire
Contact:

Re: CumulusMX gets no connection to Wh1080

Postby philpugh » Wed Aug 09, 2017 2:23 pm

I'm running mono v 5.0.1.1 under Debian Jessie on BananaPi Pro. I am using GB locale so decimal points (not commas).

To download older version go to http://www.mono-project.com/download/ and check towards the bottom about older versions

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Thu Aug 10, 2017 1:51 pm

Well it's not that easy. In the archieve there are only versions for Windows or MacOS, but none for Linux/Raspian. Has anyone tried the Mono v5.0.1.1 with success?

Greetings Martin

User avatar
steve
Cumulus Author
Posts: 26074
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: Davis VP2
Operating System: Raspbian
Location: Sanday, Orkney
Contact:

Re: CumulusMX gets no connection to Wh1080

Postby steve » Thu Aug 10, 2017 2:22 pm

maddinthebrain wrote:Well it's not that easy. In the archieve there are only versions for Windows or MacOS, but none for Linux/Raspian.

The instructions there for Linux don't work, then? You completely removed the current Mono before trying to install an older version?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Sun Aug 13, 2017 12:29 pm

Hi,
my problem is, that I am not really familiar with Linux. I just want to get Cumulus MX run on rasbian to save my PC. My somebody help with a step by step to install mono 4.0.2.5. The older howtos do not help as mono is now on newer Versions.

Please can someone help me out. The other solutions like Weewx or so don't work either. Cumulus Runs on Windows prefectly, so I want to on Raspian the same way. But there are to many traps.

Thanks for support!!

Martin

Herbaldew
Posts: 46
Joined: Sun Mar 12, 2017 8:33 pm
Weather Station: VP2+
Operating System: Raspbian Jessie
Location: US Mid-Atlantic

Re: CumulusMX gets no connection to Wh1080

Postby Herbaldew » Sun Aug 13, 2017 1:21 pm

Here is how I install Mono:

Code: Select all

sudo apt-get install mono-complete


That is what I found when I searched how to install it when I got my rPi. It installs v3.2.8. I assumed it was installing the latest until I read this thread. At any rate - CmX runs flawlessly with it.

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Sun Aug 13, 2017 3:54 pm

Yapp. This would be the 3.2.8. But this doesn't work for me, because of some language issues. So I want to try the 4.0.2.5. How to install this one? I assume I have to change something in the repository, right? And something with a key…?

Thx.

Martin

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Mon Aug 14, 2017 6:54 pm

Anyone? Please! It sucks, as it doesn't work.

Thx Martin

maddinthebrain
Posts: 7
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: CumulusMX gets no connection to Wh1080

Postby maddinthebrain » Fri Aug 18, 2017 11:14 am

Hello Guys,

now installed Mono 4 it works now for 3 day perfectly.

Have a nice day!


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 1 guest