Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

MX not recording rainfall from WMR200

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
jdlco
Posts: 5
Joined: Sat Dec 27, 2014 8:59 pm
Weather Station: WMR200A
Operating System: Windows 10
Location: Cottage Grove, Oregon US

MX not recording rainfall from WMR200

Postby jdlco » Sun Sep 03, 2017 9:29 pm

This started some time ago and have just had time to investigate. MX shows zero rainfall but will show rain rate when I tip the gauge to test. I'm running 3043 on Win10. I have reset my gauges and MX. Rainfall does show on WMR200 console but not in MX Dayfile. Would like to get this resolved before my rain season begins.

Thanks for any ideas

User avatar
steve
Cumulus Author
Posts: 26250
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX not recording rainfall from WMR200

Postby steve » Sun Sep 03, 2017 9:33 pm

Turn on data logging and debug logging, wait a couple of minutes and then do a test tip. Wait a few more minutes, and then attach the latest MXdiags file here. I'll look at it when I can.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

jdlco
Posts: 5
Joined: Sat Dec 27, 2014 8:59 pm
Weather Station: WMR200A
Operating System: Windows 10
Location: Cottage Grove, Oregon US

Re: MX not recording rainfall from WMR200

Postby jdlco » Mon Sep 04, 2017 2:16 am

Will do in morning. Thank you.

jdlco
Posts: 5
Joined: Sat Dec 27, 2014 8:59 pm
Weather Station: WMR200A
Operating System: Windows 10
Location: Cottage Grove, Oregon US

Re: MX not recording rainfall from WMR200

Postby jdlco » Mon Sep 04, 2017 5:51 pm

Steve,

Here is the file.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26250
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX not recording rainfall from WMR200

Postby steve » Mon Sep 04, 2017 8:11 pm

Thanks, I'll look at it as soon as I can on my PC (currently under the channel on the way to France).
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
steve
Cumulus Author
Posts: 26250
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: MX not recording rainfall from WMR200

Postby steve » Tue Sep 05, 2017 7:16 pm

Here are all of the rainfall data packets in that diags file:

2017-09-04 10:47:38.222 9/4/2017 10:47:38 AM Packet:D4 16 37 0A 04 09 11 00 B0 00 00 1E 00 00 B0 00 0C 01 01 07 DC 02

2017-09-04 10:48:25.214 9/4/2017 10:48:25 AM Packet:D4 16 38 0A 04 09 11 00 B0 0D 00 1E 00 00 B0 00 0C 01 01 07 EA 02

2017-09-04 10:49:12.214 9/4/2017 10:49:12 AM Packet:D4 16 39 0A 04 09 11 00 B0 0D 00 1E 00 00 B0 00 0C 01 01 07 EB 02

2017-09-04 10:49:59.214 9/4/2017 10:49:59 AM Packet:D4 16 39 0A 04 09 11 00 B0 0D 00 1E 00 00 B0 00 0C 01 01 07 EB 02

2017-09-04 10:50:46.214 9/4/2017 10:50:46 AM Packet:D4 16 3A 0A 04 09 11 00 B0 0D 00 1E 00 00 B0 00 0C 01 01 07 EC 02

The total rainfall counter in all of those hasn't changed, it's the two bytes "00 B0", so your station isn't incrementing it. I seem to remember that value is sometimes used by the WMR200 to indicate an overflow condition. Perhaps a reset will get your station working again.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
mcrossley
Posts: 4979
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: MX not recording rainfall from WMR200

Postby mcrossley » Tue Sep 05, 2017 9:16 pm

The decoded packet is...

Code: Select all

Packet Length:           22  OK
Checksum:               748  OK
Time:                 10:58
Date:            04/09/2017
Rainfall rate (in/hr):  1.1  (27.9mm/hr)
Rainfall 1h (in):       1.3  (33mm)
Rainfall 24h (in):      1.4  (35.6mm)
Since last reset (in):  1.1  (27.9mm)
Date/Time of last reset: 01/01/2007 12:00

Which implies it has registered some rain in the last hour?
Though the "Since last reset" and last 24h don't seem consistent?

jdlco
Posts: 5
Joined: Sat Dec 27, 2014 8:59 pm
Weather Station: WMR200A
Operating System: Windows 10
Location: Cottage Grove, Oregon US

Re: MX not recording rainfall from WMR200

Postby jdlco » Tue Sep 05, 2017 11:51 pm

Station Reset did it. Must have maxed out internal memory? I thought data was cleared as station reported but maybe not. I will have to keep an eye on.

Thank you very much.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 6 guests