If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Unable to connect to station, windows 10

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
b.e.wilson
Posts: 86
Joined: Tue Jul 26, 2011 11:07 pm
Weather Station: Davis Vantage VUE
Operating System: Windows 10
Location: Utah, United States
Contact:

Unable to connect to station, windows 10

Postby b.e.wilson » Wed Sep 27, 2017 3:38 am

I'm seeing some strange behavior, and have for some time:
I had the station running perfectly before I moved the computer, using Davis Vue. When I moved it, I plugged the USB into a different port. Since that time I get the Unable to connect to station error a lot, but am able to get it working if I change the com speed in the windows driver. Sometimes I move it way up, like 115k, and it finally works (after many attempts), but it won't work the next time I connect. Then maybe I move it down, try a bunch more times, and then it connects. Very intermittent behavior. I need many attempts before it finally connects. I updated the drivers and the behavior did not change.

Any ideas?

kf7yqc
Posts: 3
Joined: Mon Sep 25, 2017 2:08 am
Weather Station: Vantage Vue
Operating System: Win 8.1

Re: Unable to connect to station, windows 10

Postby kf7yqc » Wed Sep 27, 2017 10:39 pm

Hace you tried using the virtual serial converter that comes with cumulus? I havent personally experienced the problem you are having but i have checked on a few weather station softwares and I got tired for setting the USB back so I left it as the virtual serial. This might work for you?

b.e.wilson
Posts: 86
Joined: Tue Jul 26, 2011 11:07 pm
Weather Station: Davis Vantage VUE
Operating System: Windows 10
Location: Utah, United States
Contact:

Re: Unable to connect to station, windows 10

Postby b.e.wilson » Thu Sep 28, 2017 4:02 am

I'm using the cp210x drivers, the newest version.

Anyway, here are the relevant log entries:
2017-09-26 21:50:07.887 Station type = Davis
2017-09-26 21:50:07.887 LOOP2 enabled
2017-09-26 21:50:07.887 Serial device = COM5
2017-09-26 21:50:07.888 Access to the port 'COM5' is denied.
2017-09-26 21:50:07.888 Not Connected

Com port access denied? I'm running as administrator. I need to look this up.

EDIT: COM speeds have nothing to do with it...I just need to keep retrying. And I used process explorer to see if any other app was claiming the com port as it's own; none was.

User avatar
steve
Cumulus Author
Posts: 26193
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: Unable to connect to station, windows 10

Postby steve » Thu Sep 28, 2017 11:55 am

Can't help much, I'm afraid, but a common reason for access denied on the com port is that another process has it open at the time.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Like Cumulus and want to support it? Please donate! Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests