If you use Cumulus, please donate Image

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

First run on a Mac with OSX 10.12

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
fractonimbus
Posts: 154
Joined: Thu Feb 03, 2011 1:15 am
Weather Station: WH1091
Operating System: Windows 7 on a Dell Vostro
Location: Canberra

First run on a Mac with OSX 10.12

Postby fractonimbus » Tue Oct 03, 2017 9:50 am

I installed Cumulus MX today on my Mac to see how it ran. The answer is (once I had the FTP correct and the necessary website files in place), very well.

As with the old Cumulus on Windows, I found I needed to specify the IP address of the ftp site, not the ftp name. At present I'm using an old Fine Offset station, and that works perfectly.

One bug/glitch I've found is that when I terminate Cumulus MX in the Mac terminal using control-C, Mono won't shut down, and hogs the CPU, needing a kill -9 to get rid of it. I have the latest Mono (v 5.2).

I intend to run CuMX on either a Raspberry Pi or a Meteobridge, so the Mac was a trial run. All good so far.

One question (which may be somewhere in the instructions, if so I missed it): which files do I need to upload to the website manually? I uploaded everything and moved things around until the css file etc worked, but I may have overdone the uploads :-)
Image

sfws
Posts: 341
Joined: Fri Jul 27, 2012 11:29 am
Weather Station: Mixed manufacturers
Operating System: off-line W10 pc
Location: UK

Re: First run on a Mac with OSX 10.12

Postby sfws » Tue Oct 03, 2017 12:24 pm

fractonimbus wrote:which files do I need to upload to the website manually?

This is coverered in Steve's Cumulus MX Announcements http://sandaysoft.com/forum/viewtopic.php?f=27&t=12908&start=45#p101008 (that is a long text to work through), but also more briefly in the Wiki: http://wiki.sandaysoft.com/a/Simple_Website_setup#Cumulus_MX

fractonimbus
Posts: 154
Joined: Thu Feb 03, 2011 1:15 am
Weather Station: WH1091
Operating System: Windows 7 on a Dell Vostro
Location: Canberra

Re: First run on a Mac with OSX 10.12

Postby fractonimbus » Tue Oct 03, 2017 10:40 pm

Thanks. Yes, I had overdone the file uploads.

Has anyone come across the Mono not quitting problem on a Mac? Simple to fix but annoying.
Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 7 guests