Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Dew point zero immediately after restart

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
User avatar
jpsc
Posts: 163
Joined: Tue Aug 23, 2011 6:06 pm
Weather Station: Davis Vantage Vue, belfryboy USB
Operating System: Raspbian Jessie
Location: Wye valley, Herefordshire, UK
Contact:

Dew point zero immediately after restart

Postby jpsc » Wed Oct 18, 2017 1:40 pm

I have a new Oregon Scientific WMR180 and as recommended elsewhere on here I have Cumulus MX (3043) calculating the dew point. This works apart from the first logged value after a restart which is always zero.

Zero dewpoint on restart.png

Is the first line written to the log file before the first calculation is done?
You do not have the required permissions to view the files attached to this post.
John Cooper

Cumulus MX on RPi3 with SSD

http://weather.mountpleasanthouse.uk

Image

User avatar
jpsc
Posts: 163
Joined: Tue Aug 23, 2011 6:06 pm
Weather Station: Davis Vantage Vue, belfryboy USB
Operating System: Raspbian Jessie
Location: Wye valley, Herefordshire, UK
Contact:

Re: Dew point zero immediately after restart

Postby jpsc » Wed Oct 18, 2017 2:01 pm

Sorry, brain fade, For dew point in the above read windchill.

The station is set as a WMR100 as recomended

The console always shows NA for windchill, but I think that's because it is very sheltered here.
John Cooper

Cumulus MX on RPi3 with SSD

http://weather.mountpleasanthouse.uk

Image

User avatar
steve
Cumulus Author
Posts: 26551
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Dew point zero immediately after restart

Postby steve » Wed Oct 18, 2017 2:51 pm

I think this is a known issue, discussed and/or reported previously. It’s because the station doesn’t have a logger and also sends its data in separate packets for each sensor; MX calculates the wind chill before it has both wind and temperature packets. I probably forgot to add it to the list of known issues, sorry.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

User avatar
jpsc
Posts: 163
Joined: Tue Aug 23, 2011 6:06 pm
Weather Station: Davis Vantage Vue, belfryboy USB
Operating System: Raspbian Jessie
Location: Wye valley, Herefordshire, UK
Contact:

Re: Dew point zero immediately after restart

Postby jpsc » Wed Oct 18, 2017 3:14 pm

No problem. Hopefully this new station will require restarts much less often
John Cooper

Cumulus MX on RPi3 with SSD

http://weather.mountpleasanthouse.uk

Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 5 guests