Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

CWOP / APRS Upload Problem

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
MCQ
Posts: 22
Joined: Sat Jun 11, 2011 11:11 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspbian
Location: Minden, NV USA

CWOP / APRS Upload Problem

Postby MCQ » Fri Oct 27, 2017 6:10 pm

I have been running CumulusMX on a Raspberry Pi 2B since it was first released. I've also been registered with CWOP for many years and I get daily data quality reports from weather.gladstonefamily.net. I noticed a few days ago that my total number of daily reports was low. I have CumulusMX set to report every 10 minutes, so I should be sending 6/hr x 24hrs = 144 reports per day. However, on 10/26 gladstone only shows 63 total reports, 10/25 59 reports, etc.

I looked at findu.com which shows raw data received and weather.gladstone.family.net which shows the data analyzed and they are the same including many missing reports. Here is a sample of 10 records from each:

http://weather.gladstonefamily.net/cgi- ... 477&days=7
10 entries

2017-10-26 17:40:00,1023.30,56.0,32.6,41,0,0,1024.28,55.5,31.9,40,0.6,321
2017-10-26 17:50:00,1023.40,57.0,32.9,39,0,291,1024.27,54.2,31.9,42,0.6,306
2017-10-26 18:10:00,1023.50,60.0,32.3,34,0,292,1024.52,59.5,32.0,35,1.1,295
2017-10-26 18:20:00,1023.50,61.0,33.1,34,0,290,1023.77,59.5,32.0,35,1.1,295
2017-10-26 18:30:00,1023.20,62.0,32.6,33,0,279,1023.78,59.5,31.7,34,1.1,295
2017-10-26 18:40:00,1023.00,63.0,32.7,32,1,268,1023.75,59.5,31.7,34,1.1,295
2017-10-26 19:00:00,1022.90,65.0,34.4,31,0,254,1022.48,64.3,32.6,30,1.2,287
2017-10-26 19:20:00,1022.60,67.0,34.5,30,1,230,1022.81,64.3,32.7,30,1.2,287
2017-10-26 19:30:00,1022.40,68.0,34.5,28,1,195,1023.80,64.3,32.7,30,1.2,287
2017-10-26 20:40:00,1021.30,73.0,33.0,22,0,245,1022.00,70.2,31.6,23,0.4,295

http://www.findu.com/cgi-bin/raw.cgi?call=DW9477
10 entries

DW9477>APRS,TCPXX*,qAX,CWOP-4:@261740z3901.98N/11942.33W_000/000g000t056r000p000P000h41b10233eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261750z3901.98N/11942.33W_291/001g003t057r000p000P000h40b10234eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261810z3901.98N/11942.33W_292/001g003t060r000p000P000h35b10235eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261820z3901.98N/11942.33W_290/001g004t061r000p000P000h35b10235eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261830z3901.98N/11942.33W_279/001g006t062r000p000P000h33b10232eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261840z3901.98N/11942.33W_268/002g006t063r000p000P000h32b10230eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261900z3901.98N/11942.33W_254/001g004t065r000p000P000h32b10229eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261920z3901.98N/11942.33W_230/002g006t067r000p000P000h30b10226eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@261930z3901.98N/11942.33W_195/002g006t068r000p000P000h29b10224eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@262040z3901.98N/11942.33W_245/001g005t073r000p000P000h23b10213eCumulusDsVP

The only logs I see in CumulusMX showing uploads to CWOP are in MXdiags. I don't see any errors there to explain the missing records at CWOP. In fact, it logs the same "Updating CWOP" on a consistent 10 minute interval:

pi@weatherpi ~/CumulusMX/MXdiags $ cat 20171024-100214.txt | grep "CWOP"
19 entries

2017-10-26 17:40:05.201 Updating CWOP
2017-10-26 17:50:05.263 Updating CWOP
2017-10-26 18:00:05.377 Updating CWOP
2017-10-26 18:10:05.541 Updating CWOP
2017-10-26 18:20:05.459 Updating CWOP
2017-10-26 18:30:05.514 Updating CWOP
2017-10-26 18:40:05.598 Updating CWOP
2017-10-26 18:50:05.660 Updating CWOP
2017-10-26 19:00:05.755 Updating CWOP
2017-10-26 19:10:05.856 Updating CWOP
2017-10-26 19:20:05.932 Updating CWOP
2017-10-26 19:30:06.024 Updating CWOP
2017-10-26 19:40:06.077 Updating CWOP
2017-10-26 19:50:06.129 Updating CWOP
2017-10-26 20:00:05.223 Updating CWOP
2017-10-26 20:10:05.264 Updating CWOP
2017-10-26 20:20:05.399 Updating CWOP
2017-10-26 20:30:05.391 Updating CWOP
2017-10-26 20:40:05.500 Updating CWOP

Is there a way to turn up the logging level in CumulusMX for CWOP uploads so I can see if they are erroring or if they are properly received (that would tell me that CWOP is dropping my reports intermittently and I could follow up with them)?

User avatar
steve
Cumulus Author
Posts: 26246
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: CWOP / APRS Upload Problem

Postby steve » Fri Oct 27, 2017 6:20 pm

If you don’t already have debug logging turned on as suggested in one of the MX announcement posts, then you could try that, it may give more information.

I see that all of your listed uploads are going to the same server, CWOP-4, so perhaps there is a problem at CWOP, as updates should automatically rotate through different servers.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

MCQ
Posts: 22
Joined: Sat Jun 11, 2011 11:11 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspbian
Location: Minden, NV USA

Re: CWOP / APRS Upload Problem

Postby MCQ » Fri Oct 27, 2017 7:14 pm

Thanks Steve. I'll update this post so if anyone else runs into this problem and does a forum search, this might help them out.

I turned on debug logging temporarily from the web interface - "You can turn the logging on or off temporarily (i.e. for the current run only, changes do not get affect Cumulus.ini) using the station settings in the user interface."

I waited for the 10-minute interval to elapse, then checked the MXdiags log vs. raw data on findu.com:

2017-10-27 11:50:05.557 Updating CWOP
2017-10-27 11:50:05.722 Sending user and pass to CWOP
2017-10-27 11:50:08.776 Sending: DW9477>APRS,TCPIP*:@271850z3901.98N/11942.33W_288/002g007t063r000p000P000h29b10250eCumulusDsVP
2017-10-27 11:50:11.776 End of CWOP update

2017-10-27 12:00:05.636 Updating CWOP
2017-10-27 12:00:05.903 Sending user and pass to CWOP
2017-10-27 12:00:08.930 Sending: DW9477>APRS,TCPIP*:@271900z3901.98N/11942.33W_279/003g008t063r000p000P000h28b10248eCumulusDsVP
2017-10-27 12:00:11.931 End of CWOP update

http://www.findu.com/cgi-bin/raw.cgi?call=DW9477
DW9477>APRS,TCPXX*,qAX,CWOP-4:@271840z3901.98N/11942.33W_280/002g007t062r000p000P000h30b10251eCumulusDsVP
DW9477>APRS,TCPXX*,qAX,CWOP-4:@271900z3901.98N/11942.33W_279/003g008t063r000p000P000h28b10248eCumulusDsVP

findu.com had an 11:40 update when I turned on debug logging. The 11:50 upload never showed up at findu.com, but the 12:00 upload did. Since CumulusMX shows the exact same entries (no errors) for both uploads, I assume that CumulusMX didn't receive any errors and the upload was dropped on the CWOP end for some unknown reason. I will follow up with CWOP and see what they have to say.

User avatar
steve
Cumulus Author
Posts: 26246
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: CWOP / APRS Upload Problem

Postby steve » Fri Oct 27, 2017 7:24 pm

This status page isn’t showing any issues with the other servers - http://status.aprs2.net (at the bottom of that page) and apparently other Cumulus users are uploading to the other servers. So perhaps there is a problem with the routing from your system to the other servers.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

MCQ
Posts: 22
Joined: Sat Jun 11, 2011 11:11 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspbian
Location: Minden, NV USA

Re: CWOP / APRS Upload Problem

Postby MCQ » Fri Oct 27, 2017 8:14 pm

It does seem that all my connections are being logged at findu.com as coming in on cwop-4 which is 129.15.108.117. I have my own internal Windows DNS Server and I am using the default CWOP setting in CumulusMX for cwop.aprs.net:14580. I ran a ping and a nslookup from a Windows box and it returned this, so it appears my DNS is correct:

C:\>nslookup cwop.aprs.net
Server: saits.foodtechsystems.com
Address: 192.168.71.5
Non-authoritative answer:
Name: cwop.aprs.net
Addresses: 63.251.153.99
129.15.108.116
44.155.254.4
70.57.237.99
85.188.1.27
129.15.108.117
66.151.32.203

Pinging cwop.aprs.net [129.15.108.117] with 32 bytes of data:
Reply from 129.15.108.117: bytes=32 time=77ms TTL=43
Reply from 129.15.108.117: bytes=32 time=84ms TTL=43
Reply from 129.15.108.117: bytes=32 time=89ms TTL=43
Reply from 129.15.108.117: bytes=32 time=81ms TTL=43
Ping statistics for 129.15.108.117:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 77ms, Maximum = 89ms, Average = 82ms

I then ran the same thing from the RPi and it looks like it has the same information as well:

pi@weatherpi ~ $ ping cwop.aprs.net
PING cwop.aprs.net (70.57.237.99) 56(84) bytes of data.
64 bytes from cwop.fuller.net (70.57.237.99): icmp_req=1 ttl=46 time=95.5 ms
64 bytes from cwop.fuller.net (70.57.237.99): icmp_req=2 ttl=46 time=93.5 ms
64 bytes from cwop.fuller.net (70.57.237.99): icmp_req=3 ttl=46 time=97.8 ms
64 bytes from cwop.fuller.net (70.57.237.99): icmp_req=4 ttl=46 time=101 ms
^C
--- cwop.aprs.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 93.549/97.077/101.273/2.894 ms

pi@weatherpi ~ $ host cwop.aprs.net
cwop.aprs.net has address 63.251.153.99
cwop.aprs.net has address 70.57.237.99
cwop.aprs.net has address 129.15.108.116
cwop.aprs.net has address 129.15.108.117
cwop.aprs.net has address 44.155.254.4
cwop.aprs.net has address 85.188.1.27
cwop.aprs.net has address 66.151.32.203

So, I don't see any kind of permanent issue with connecting to aprs.net servers. The RPi can also ping each of the IPs listed in the DNS lookup directly by address.

User avatar
steve
Cumulus Author
Posts: 26246
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: CWOP / APRS Upload Problem

Postby steve » Sat Oct 28, 2017 10:25 am

Hopefully CWOP will be able to throw some light on the problem, if you’re confident it’s not a DNS/routing/firewall issue at your end.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

User avatar
mcrossley
Posts: 4979
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Jessie Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: CWOP / APRS Upload Problem

Postby mcrossley » Sat Oct 28, 2017 2:24 pm

The DNS TTL isn't longer than the update interval is it?


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 5 guests