IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

I strongly advise all users using my server for their web site to make alternative arrangements.

Outgoing mail is disabled because of the malware on the server. No new forum registrations are currently possible, and mail to the forum administrator will not work.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

nothung TTYUSB present when connect consolle to Rapsberry

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
meteosp
Posts: 35
Joined: Thu Mar 29, 2012 7:10 am
Weather Station: PCE-fws20
Operating System: xp sp3
Location: la spezia

nothung TTYUSB present when connect consolle to Rapsberry

Postby meteosp » Tue Dec 12, 2017 9:38 am

Hello,
i've installed the CumulusMX and follow the guide downgraded the mono version also.
All seems fine because the program start correctly at boot and can be reach via browser without problem. The problem is that i can't set the USB address into settings because when search into /dev/ directory the system do not create any ttyUSB device file. If i digit lsusb i see the station correctly.

Any idea?
Thank in advance

P.S.
Station is WH1080

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: nothung TTYUSB present when connect consolle to Rapsberry

Postby steve » Tue Dec 12, 2017 12:53 pm

You don’t specify a serial port for a USB station, it should just find it. If it’s not then you have some kind of problem with your system software - there may be a solution on the forum somewhere.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

meteosp
Posts: 35
Joined: Thu Mar 29, 2012 7:10 am
Weather Station: PCE-fws20
Operating System: xp sp3
Location: la spezia

Re: nothung TTYUSB present when connect consolle to Rapsberry

Postby meteosp » Tue Dec 12, 2017 1:04 pm

Thanks for replay, you mean that i need to leave the field about serial port empty or with de default value (ttyUSB0)?

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: nothung TTYUSB present when connect consolle to Rapsberry

Postby steve » Tue Dec 12, 2017 7:15 pm

The field is ignored for usb stations
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

meteosp
Posts: 35
Joined: Thu Mar 29, 2012 7:10 am
Weather Station: PCE-fws20
Operating System: xp sp3
Location: la spezia

Re: nothung TTYUSB present when connect consolle to Rapsberry

Postby meteosp » Wed Dec 13, 2017 9:53 am

May be i've found the problem, when execute mono Cumulus.exe i've this output with error about fineset not found. My mono version is 5.4.1.6
Current culture: Italian (Italy)
Serial: 74FECEABEB2DA94ECB5EBA0CD11A7137
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2017-12-13T10:49:31
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
System.MissingMethodException: Method 'Mono.Unix.Native.Syscall.uname' not found.
at System.RuntimeType.InvokeMember (System.String name, System.Reflection.BindingFlags bindingFlags, System.Reflection.Binder binder, System.Object target, System.Object[] providedArgs, System.Reflection.ParameterModifier[] modifiers, System.Globalization.CultureInfo culture, System.String[] namedParams) [0x0070c] in <62f5937022004555807e6c57c33f6684>:0
at System.Type.InvokeMember (System.String name, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object target, System.Object[] args, System.Globalization.CultureInfo culture) [0x00000] in <62f5937022004555807e6c57c33f6684>:0
at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.String& release, System.String& machine) [0x00047] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.Version& release, System.String& machine) [0x00004] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00002] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
Not supported
Fine Offset station not found
[ERROR] FATAL UNHANDLED EXCEPTION: System.Net.Sockets.SocketException (0x80004005): Address already in use
at System.Net.Sockets.Socket.Bind (System.Net.EndPoint localEP) [0x00043] in <50d80b08c1a5449282b22aedf03ce925>:0
at System.Net.EndPointListener..ctor (System.Net.HttpListener listener, System.Net.IPAddress addr, System.Int32 port, System.Boolean secure) [0x00047] in <50d80b08c1a5449282b22aedf03ce925>:0
at System.Net.EndPointManager.GetEPListener (System.String host, System.Int32 port, System.Net.HttpListener listener, System.Boolean secure) [0x0009d] in <50d80b08c1a5449282b22aedf03ce925>:0
at System.Net.EndPointManager.AddPrefixInternal (System.String p, System.Net.HttpListener listener) [0x0005e] in <50d80b08c1a5449282b22aedf03ce925>:0
at System.Net.EndPointManager.AddListener (System.Net.HttpListener listener) [0x0009c] in <50d80b08c1a5449282b22aedf03ce925>:0
at System.Net.HttpListener.Start () [0x0000f] in <50d80b08c1a5449282b22aedf03ce925>:0
at Unosquare.Labs.EmbedIO.WebServer.RunAsync (System.Threading.CancellationToken ct, Unosquare.Labs.EmbedIO.Middleware app) [0x00040] in <45ad3255b89a4abd88a385276d744f3d>:0
at CumulusMX.Cumulus..ctor (System.Int32 HTTPport, System.Int32 WSport) [0x025b3] in <e5374d62bd7e4591847a6042233be333>:0
at CumulusMX.Program.Main (System.String[] args) [0x00205] in <e5374d62bd7e4591847a6042233be333>:0

Any Idea?

User avatar
steve
Cumulus Author
Posts: 26700
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: nothung TTYUSB present when connect consolle to Rapsberry

Postby steve » Wed Dec 13, 2017 11:25 am

Yes, see the very many other posts about this, including one I replied to in the last day or two.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 8 guests