IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

I strongly advise all users using my server for their web site to make alternative arrangements.

Outgoing mail is disabled because of the malware on the server. No new forum registrations are currently possible, and mail to the forum administrator will not work.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

[solved] Ftp connection refused

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
maddinthebrain
Posts: 33
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

[solved] Ftp connection refused

Postby maddinthebrain » Thu Feb 01, 2018 7:52 pm

Hi
I tried to setup a ftp upload on a local NAS. With Filezilla the connection works fine. When I use the same parameters like address, username, password etc. it doesn't work. In MXDiag file I found

Code: Select all

2018-02-01 20:29:25.615 Error connecting ftp - Connection refused
2018-02-01 20:29:25.743 Error uploading realtime.txt to /array1/Webserver/CumulusMX/realtime.txt : Connection refused
2018-02-01 20:29:25.774 Error uploading web/realtimegauges.txt to /array1/Webserver/CumulusMX/realtimegauges.txt : Connection refused


How to fill in the server address? I do it this way: ls-qvl500.fritz.box
Port is 21

As I said, this works fine with Filezilla. The FTP-Server uses TLS for authentication.

Help is highly appreciated!

Martin
Last edited by maddinthebrain on Fri Feb 02, 2018 8:34 pm, edited 1 time in total.

User avatar
steve
Cumulus Author
Posts: 26693
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Ftp connection refused

Postby steve » Thu Feb 01, 2018 7:57 pm

Have you enabled FTP over TLS in MX and restarted?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

maddinthebrain
Posts: 33
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: Ftp connection refused

Postby maddinthebrain » Thu Feb 01, 2018 8:48 pm

steve wrote:Have you enabled FTP over TLS in MX and restarted?

Is this the option "Use SSL for FTP (FTPS)"?

maddinthebrain
Posts: 33
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: Ftp connection refused

Postby maddinthebrain » Thu Feb 01, 2018 9:19 pm

OK it's working NOW. But some html files are empty. Like index.htm. What's missing?

Thx

User avatar
steve
Cumulus Author
Posts: 26693
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Ftp connection refused

Postby steve » Thu Feb 01, 2018 9:42 pm

One possible cause mentioned in the FAQ, I think. Caused by incorrect active/passive ftp mode. If not that, you could turn on ftp logging and look at ftp log.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

DonaldDuck
Posts: 1
Joined: Fri May 19, 2017 3:46 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspian

Re: Ftp connection refused

Postby DonaldDuck » Fri Feb 02, 2018 2:17 pm

I had to install ftpd to enable RPi to Synology FTP connection
sudo apt-get install ftpd
Michael

maddinthebrain
Posts: 33
Joined: Mon Aug 07, 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: Ftp connection refused

Postby maddinthebrain » Fri Feb 02, 2018 8:33 pm

Now it's fine. It was that the rename option was not active.
Thx.


Return to “Cumulus MX”

Who is online

Users browsing this forum: Abrego77 and 3 guests