Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Cumulusmx does not recognize station wh1080

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Cumulusmx does not recognize station wh1080

Postby RunningEv » Sat Feb 03, 2018 3:54 pm

Good morning, sorry for my English and for the little experience as a programmer. I managed to install Cumulusmx and its start / stop script inside a raspberry pi with installed raspbian stretch lite. Works well. I reached the graphical interface of cumulus from the browser to associate the station (froggit wh1080) but Cumulus does not detect anything, the station data does not arrive, it is as if there were no connected stations. Tips ?

User avatar
steve
Cumulus Author
Posts: 26626
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby steve » Sat Feb 03, 2018 4:28 pm

What version of Mono?
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sat Feb 03, 2018 5:03 pm

Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)

User avatar
Toxic17
Posts: 817
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby Toxic17 » Sat Feb 03, 2018 5:10 pm

I think you need a lower version of Mono (3.x) for the WH1080 fine offsets to work properly, it is mentioned here a few times on the forums.

Also can you confirm the rasbpi sees your Console by going to SSH and typing the following: lsusb

you should see something like so:

Code: Select all

root@cumulusmx:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 027: ID 8087:07dc Intel Corp.
Bus 001 Device 002: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@cumulusmx:~#
Regards Simon

https://www.conligwx.org
https://www.conligwx.org/pws/
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sat Feb 03, 2018 5:32 pm

lsusb command:

Code: Select all

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


so I should do a downgrade of mono ?

I do not know if it can serve, but if I defect the following command, it seems that there are errors:

Code: Select all

pi@raspberrypi:~/CumulusMX $ sudo mono CumulusMX.exe
Current culture: English (United Kingdom)
Serial: 74FECEABEB2DA94ECB5EBA0CD11A7137
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2018-02-03T18:30:29
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
System.MissingMethodException: Method 'Mono.Unix.Native.Syscall.uname' not found.
  at System.RuntimeType.InvokeMember (System.String name, System.Reflection.BindingFlags bindingFlags, System.Reflection.Binder binder, System.Object target, System.Object[] providedArgs, System.Reflection.ParameterModifier[] modifiers, System.Globalization.CultureInfo culture, System.String[] namedParams) [0x008a0] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Type.InvokeMember (System.String name, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object target, System.Object[] args, System.Globalization.CultureInfo culture) [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.String& release, System.String& machine) [0x00047] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.Version& release, System.String& machine) [0x00004] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00002] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
Not supported
Fine Offset station not found
[ERROR] FATAL UNHANDLED EXCEPTION: System.Net.Sockets.SocketException (0x80004005): Address already in use
  at System.Net.Sockets.Socket.Bind (System.Net.EndPoint localEP) [0x0004c] in <bd46d4d4f7964dfa9beea098499ab597>:0
  at System.Net.EndPointListener..ctor (System.Net.HttpListener listener, System.Net.IPAddress addr, System.Int32 port, System.Boolean secure) [0x0004a] in <bd46d4d4f7964dfa9beea098499ab597>:0
  at System.Net.EndPointManager.GetEPListener (System.String host, System.Int32 port, System.Net.HttpListener listener, System.Boolean secure) [0x000be] in <bd46d4d4f7964dfa9beea098499ab597>:0
  at System.Net.EndPointManager.AddPrefixInternal (System.String p, System.Net.HttpListener listener) [0x00064] in <bd46d4d4f7964dfa9beea098499ab597>:0
  at System.Net.EndPointManager.AddListener (System.Net.HttpListener listener) [0x00030] in <bd46d4d4f7964dfa9beea098499ab597>:0

scilab
Posts: 2
Joined: Sat Feb 03, 2018 2:11 pm
Weather Station: PCE FWS 20
Operating System: Raspbian

Re: Cumulusmx does not recognize station wh1080

Postby scilab » Sat Feb 03, 2018 8:57 pm

To use correctply CumulusMX on Raspberry you need mono max at v.4.0.5, i've also the wh1080 and i do this procedure:

If you had installed mono, uninstall it with:
$ sudo apt-get remove mono-complete

The add the mono repository:
$ cd /etc/apt/sources.list.d
$ sudo vi mono-xamarin.list

add below line:
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main

Go an Update Repo:
$ sudo apt-get update

Just ignore the warnings about signatures and conflicting distribution.

In order to fix dependencies, aptitude must be used to install mono:
$ sudo aptitude install mono-complete=4.0.5.1-0xamarin1

Then you will get a proposal from aptitude to solve the dependencies:

Keep the following packages at their current version:
1) Do NOT accept this solution, when that would install the current version of mono(4.6.2) which has errors (as documented by SpaceHiker).
Respond with "n"

2) Accept the next solution from aptitude to install mono version 4.0.5 with this warning:
Respond with "Y"

3) At the next prompt:
Respond with "Y"

4) At the last prompt:
Do you want to ignore this warning and proceed anyway?
To continue, enter "yes"; to abort, enter "no":
Respond "yes"

Now mono-complete 4.0.5 will be installed.

In order to protect this old mono version (4.0.5) from future upgrades:
$ sudo apt-mark hold mono-runtime mono-complete

How to show the current Installed version:
$ mono --version

It should respond with:
Mono JIT compiler version 4.0.5 (Stable 4.0.5.1/1d8d582 Thu Nov 12 12:22:41 UTC 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: normal
Notifications: epoll
Architecture: armel,vfp+hard
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 04, 2018 9:31 am

thank you scilab, I try

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 04, 2018 2:47 pm

damn, my little experience stopped me, I can not add add below line:
deb http://download.mono-project.com/repo/debian wheezy / snapshots / 4.0.5 main

inside "mono-xamarin.list" I can not write or add anything and now I must have messed something up and I get this message out, sorry

Code: Select all

E325: ATTENTION
Found a swap file by the name ".mono-xamarin.list.swp"
          owned by: root   dated: Sun Feb  4 15:28:43 2018
         file name: /etc/apt/sources.list.d/mono-xamarin.list
          modified: YES
         user name: root   host name: raspberrypi
        process ID: 925
While opening file "mono-xamarin.list"

(1) Another program may be editing the same file.  If this is the case,
    be careful not to end up with two different instances of the same
    file when making changes.  Quit, or continue with caution.
(2) An edit session for this file crashed.
    If this is the case, use ":recover" or "vim -r mono-xamarin.list"
    to recover the changes (see ":help recovery").
    If you did this already, delete the swap file ".mono-xamarin.list.swp"
    to avoid this message.

"mono-xamarin.list" [New File]
Press ENTER or type command to continue

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 04, 2018 8:13 pm

I think I made a mess,
the error message for the swp file is still present,
if I uninstall mono-complete, the system tells me it's not there, but if I check the mono version, the system tells me that there 4.6.2 is still installed :?

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Mon Feb 05, 2018 9:13 am

ok, sorry, I found other similar discussions, I try to solve

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Mon Feb 05, 2018 7:03 pm

sorry I wanted a confirmation, the content of the file "mono-xamarin.list" is correct:

Code: Select all

pi@raspberrypi:/etc/apt/sources.list.d $ sudo vi mono-xamarin.list
deb http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5 main
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"mono-xamarin.list" 1 line, 76 characters

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Mon Feb 05, 2018 7:20 pm

I give up, I can not follow the guide

Code: Select all

pi@raspberrypi:~ $ cd /etc/apt/sources.list.d
pi@raspberrypi:/etc/apt/sources.list.d $ sudo vi mono-xamarin.list
pi@raspberrypi:/etc/apt/sources.list.d $ cd
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Ign:3 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5 InRelease
Ign:4 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5 Release
Ign:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Ign:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Ign:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Ign:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Ign:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Err:5 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main armhf Packages
  404  Not Found
Ign:6 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main all Packages
Ign:7 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en_GB
Ign:8 http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5/main Translation-en
Reading package lists... Done
W: The repository 'http://download.mono-project.com/repo/debian wheezy/snapshot/4.0.5 Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.mono-project.com/repo/debian/dists/wheezy/snapshot/4.0.5/main/binary-armhf/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
pi@raspberrypi:~ $ sudo aptitude install mono-complete=4.0.5.1-0xamarin1
Unable to find a version "4.0.5.1-0xamarin1" for the package "mono-complete"
Unable to apply some actions, aborting
pi@raspberrypi:~ $

User avatar
Toxic17
Posts: 817
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby Toxic17 » Mon Feb 05, 2018 8:57 pm

there is no link called

http://download.mono-project.com/repo/debian%20wheezy/

it does not exist. where did you get that URL from?

http://download.mono-project.com/repo/d ... .0.5/main/
Regards Simon

https://www.conligwx.org
https://www.conligwx.org/pws/
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Tue Feb 06, 2018 10:40 am

I copied the link from the scilab post, the correct one is the one you told me?:

http://download.mono-project.com/repo/d ... .0.5/main/

User avatar
Toxic17
Posts: 817
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby Toxic17 » Tue Feb 06, 2018 12:48 pm

RunningEv wrote:I copied the link from the scilab post, the correct one is the one you told me?:

http://download.mono-project.com/repo/d ... .0.5/main/


try it and see, if it does not work then you will need to find the correct url for your device from within that link or find a new source.
Regards Simon

https://www.conligwx.org
https://www.conligwx.org/pws/
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 1 guest