Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Gauges Page Broken with 2018-06-27-raspbian-stretch

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Herbaldew
Posts: 78
Joined: Sun Mar 12, 2017 8:33 pm
Weather Station: VP2+
Operating System: Raspbian Stretch
Location: US Mid-Atlantic

Gauges Page Broken with 2018-06-27-raspbian-stretch

Postby Herbaldew » Sat Jun 30, 2018 2:23 pm

No idea where to look for what is causing this...

No changes have been made from my settings with the last release.

But now, my "index" page works fine including the wind gauges. My "gauges" page will load but the gauges will not connect (this is using the Chromium browser on the rPi). Eventually I get a "Page Unresponsive" message with "Exit Page" and "Wait" buttons. "Wait" just results in the same messsage, "Exit Page" results in the "Aw, Snap!" page - none of its recommendations fix the problem.

The gauges page does work fine when connecting from another machine on the LAN, so I am guessing this has something to do with the new version of Chromium shipped with 2018-06-27-raspbian-stretch. I leave my rPi with my gauges page running in full screen all the time as it is next to my TV - I just toggle the input button on the TV and can look at my gauges at will so I really want to fix this.

Any suggestions?


Thanks - Herb

water01
Posts: 1450
Joined: Sat Aug 13, 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Gauges Page Broken with 2018-06-27-raspbian-stretch

Postby water01 » Sat Jun 30, 2018 2:58 pm

Sounds like this problem in mainstream Chrome viewtopic.php?f=21&t=16908

Herbaldew
Posts: 78
Joined: Sun Mar 12, 2017 8:33 pm
Weather Station: VP2+
Operating System: Raspbian Stretch
Location: US Mid-Atlantic

Re: Gauges Page Broken with 2018-06-27-raspbian-stretch

Postby Herbaldew » Sat Jun 30, 2018 3:27 pm

Thanks, I had read that as it was unfolding but it didn't cross my mind for my problem.

My symptoms are slightly different in that my gauges page won't load to start with. That was fixed in regular Chrome, but maybe whatever the problem was made it to the rPi version without getting fixed and is generating my "slightly different symptoms"? Oddly, I couldn't recreate the original situation on my PC - go figger.


Edit: Guess Chromium isn't the culprit - IceWeasel won't work either.

Herbaldew
Posts: 78
Joined: Sun Mar 12, 2017 8:33 pm
Weather Station: VP2+
Operating System: Raspbian Stretch
Location: US Mid-Atlantic

Re: Gauges Page Broken with 2018-06-27-raspbian-stretch

Postby Herbaldew » Sat Jun 30, 2018 8:35 pm

Heat index here is 105 f - good day to play with this thing :)

Turns out that IceWeasel does NOT work properly for the gauges page with the last version of Raspbian either.

I had never fooled with another browser other than the included Chromium so didn't know anything about them. IceWeasel if basically Firefox for Raspbian so that's what I tried. I Googled alternate browsers for Raspbian and saw and tried Luakit. The gauges page works fine with it.

The lastest Raspbian image comes with Chromium 65 not 66 that was reported to be the problem in the thread water01 pointed out above. That said, it sure is looking the Chromium 65 is the problem.

There will not be an upgrade of the Chromium version for Raspbian at least until the next image release so I will either use Luakit or stick with the last image unless someone finds another solution.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests