Page 1 of 1

CMX "Changes you made may not be saved." Pop-up

Posted: Thu Jul 12, 2018 5:11 pm
by radilly
Anyone run into a "sticky" "Changes you made may not be saved." pop-up on the local CMX dashboard (site)?

I've had it for maybe a week now, every time I navigate off one of the pages for the "site.". I'm not sure if it's a browser glitch and I'm not very Java literate to debug it. I didn't find that phrase in any of the CMX files.

Chrome is my primary browser and has the issue. Firefox does not. I seldom use IE, but I get "WebSocket NOT supported by your Browser!" so I can't test without addressing.

Any ideas?

Oh, I flushed cache and all that - no joy...

Re: CMX "Changes you made may not be saved." Pop-up

Posted: Thu Jul 12, 2018 6:08 pm
by steve
It's not something that MX does itself, so I don't know where it would be coming from. It does sound like it's coming from the javascript engine in the browser, for whatever reason.

Re: CMX "Changes you made may not be saved." Pop-up

Posted: Thu Jul 12, 2018 7:44 pm
by radilly
steve wrote:It's not something that MX does itself...


Thanks Steve! That was my inclination when I couldn't find the message text or any significant substrings across the CMX files. I started to Google it and found a few things but haven't dug into them yet. I'll post, of course, if I figure something out...

Hope you're enjoying retirement. I decided I was too in January. Tired of the "rat race" as we say in the States... Be safe! Enjoy!

Bob

Re: CMX "Changes you made may not be saved." Pop-up

Posted: Fri Jul 13, 2018 4:59 pm
by radilly
Still poking around, but based on https://stackoverflow.com/questions/398 ... -have-been I looked for files containing "beforeunload":

Code: Select all

$ grep -lr "beforeunload" *
interface/lib/jquery/jquery-latest.min.js
interface/lib/datatables/media/js/jquery.js
webfiles/lib/jquery/jquery-latest.min.js

First and last appear to be the same file based on a checksum.

In my modest searching, I saw jquery mentioned a few times. I won't pretend to know anything beyond the most basic Java, but if the header comments are any indication these file make be a bit dated. I got the idea that the Chrome changed in early 2016.

Code: Select all

==> interface/lib/jquery/jquery-latest.min.js <==
/*! jQuery v1.9.1 | (c) 2005, 2012 jQuery Foundation, Inc. | jquery.org/license

==> interface/lib/datatables/media/js/jquery.js <==
/*! jQuery v1.11.1 | (c) 2005, 2014 jQuery Foundation, Inc. | jquery.org/license */

==> webfiles/lib/jquery/jquery-latest.min.js <==
/*! jQuery v1.9.1 | (c) 2005, 2012 jQuery Foundation, Inc. | jquery.org/license


Seems possible, as widely used as I suspect jQuery is, there may be updated versions of this/these available.

That's as far as I've gotten...
Bob

Ref: https://code.jquery.com/jquery/

Re: CMX "Changes you made may not be saved." Pop-up

Posted: Fri Jul 13, 2018 5:36 pm
by sfws
radilly wrote:Seems possible, as widely used as I suspect jQuery is, there may be updated versions of this/these available.

That's as far as I've gotten...
Bob

Ref: https://code.jquery.com/jquery/

The Wiki http://wiki.sandaysoft.com/a/Simple_Website_setup#Cumulus_MX mentions how to get and install latest version of jQuery

Re: CMX "Changes you made may not be saved." Pop-up

Posted: Sat Jul 14, 2018 2:24 pm
by radilly
sfws wrote:The Wiki http://wiki.sandaysoft.com/a/Simple_Website_setup#Cumulus_MX mentions how to get and install latest version of jQuery


Thanks @sfws!

I typically don't think to use the Wiki because it seemed like there hadn't been any recent changed (last time I looked). But it looks like you've been making updates recently!

Cheers, and Thanks!
Bob