Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

WOW authentication key

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
wxmasterton
Posts: 2
Joined: Fri Feb 20, 2015 7:03 pm
Weather Station: LaCrosse 1081
Operating System: Win7
Location: New Zealand
Contact:

WOW authentication key

Postby wxmasterton » Fri Feb 20, 2015 8:16 pm

Cumulus is not uploading automatically to WOW. I have searched this forum and have read numerous posts on difficulties with WOW but still cannot find the solution.

Here is the debug log:

7748.7834 : WOW update done
7748.7834 : 12:45:02 p.m. WOW Response Code: 403 Response = {"errorMessage":"Failed authentication. Please check the authentication key in the site settings."}

Looking at my WOW site settings, I do not see an "authentication key" but I do see this:
"If you wish to send observations automatically, you will need to add the PIN number you create here to any data feed sent to WOW."
However I do not see anywhere in Cumulus to put a PIN number.

My WOW Site ID 908976001
WOW in Cumulus: Enabled, Catch Up (both ticked), and password entered

Are there other settings in Cumulus that are needed for auto uploads to WOW?
My Cumulus does manage to upload to Weather Underground with no problems.

Thanks for your assistance.

User avatar
steve
Cumulus Author
Posts: 26246
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in France
Contact:

Re: WOW authentication key

Postby steve » Fri Feb 20, 2015 8:54 pm

wxmasterton wrote:However I do not see anywhere in Cumulus to put a PIN number.
It's in the WOW settings panel. Make sure you are putting in your site PIN and not your MetOffice login password.

2015-02-20 20_51_33-Internet Settings.png
You do not have the required permissions to view the files attached to this post.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

wxmasterton
Posts: 2
Joined: Fri Feb 20, 2015 7:03 pm
Weather Station: LaCrosse 1081
Operating System: Win7
Location: New Zealand
Contact:

Re: WOW authentication key

Postby wxmasterton » Fri Feb 20, 2015 9:21 pm

:o Well that was an easy fix - thanks for the quick reply - it is :P uploading now.

As in your post, I was putting in the MetOffice login password.
Even though I have read the 'AWS 6 digit PIN' instructions numerous times it did not occur
to me that my Site PIN was different than the MetOffice password, and the Cumulus debug
text "authentication key" further confused me.

paulmcg
Posts: 2
Joined: Sun Sep 30, 2012 9:24 pm
Weather Station: WS-3081
Operating System: Windows 7 VM
Location: Australia
Contact:

Re: WOW authentication key

Postby paulmcg » Sun Oct 22, 2017 9:56 pm

Log on to WOW, Choose "My Sites" option.
Site ID is visible in address bar and under site name on right of screen.
Choose Edit Site, The PIN is displayed on the Site Details section headed Authentication Key
This info is also quoted at http://wow.metoffice.gov.uk/support/dat ... #automatic.


Return to “Cumulus 1”

Who is online

Users browsing this forum: Google [Bot], hvd51 and 3 guests