Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Please help with this error

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
shaunfish
Posts: 8
Joined: Wed Apr 23, 2014 5:18 am
Weather Station: Wastson W-8681
Operating System: win 7
Location: Pietermaritzburg, South Africa

Please help with this error

Postby shaunfish » Sat Sep 23, 2017 6:23 am

Good day
I have tried but failed to resolve this error
23 Sep 2017 8:13:07 AM : Error on line 1 of C:\Cumulus\data\Sep17log.txt: '''' is not a valid integer value

any help will be appreciated

Regards
Shaun

sfws
Posts: 345
Joined: Fri Jul 27, 2012 11:29 am
Weather Station: off-line Fine Offset plus others
Operating System: off-line Vista and W10 PCs
Location: UK

Re: Please help with this error

Postby sfws » Sat Sep 23, 2017 7:39 am

shaunfish wrote:C:\Cumulus\data\Sep17log.txt

This part of the message tells you which file has an error (the current monthly log).
shaunfish wrote: Error on line 1

This part of the message says which line (the first).
shaunfish wrote:not a valid integer value

This part tells you that in looking for an integer value, Cumulus found a floating point number.

How to solve
Cumulus FAQ: http://wiki.sandaysoft.com/a/FAQ#Error_messages_with_.22Error_on_line....22_or_.22Error_at_line....22.


If that solution does not work, then make sure your file is consistent in what it uses as separator for decimal and integer parts of floating point numbers and consistent in using a different separator character to separate one figure from another. See more at http://wiki.sandaysoft.com/a/Monthly_log_files

shaunfish
Posts: 8
Joined: Wed Apr 23, 2014 5:18 am
Weather Station: Wastson W-8681
Operating System: win 7
Location: Pietermaritzburg, South Africa

Re: Please help with this error

Postby shaunfish » Sun Sep 24, 2017 5:14 am

Hi
I have done as you suggested but I still have the same problem. I have also checked the number format and separators all is correct I have even re-installed the program but to no avail. also the program will insert some strange rainfall figures such as 200mm/hr. I am getting to a point where I will have to purchase a commercial program and not use cumulus

Regards
Shaun

sfws
Posts: 345
Joined: Fri Jul 27, 2012 11:29 am
Weather Station: off-line Fine Offset plus others
Operating System: off-line Vista and W10 PCs
Location: UK

Re: Please help with this error

Postby sfws » Sun Sep 24, 2017 7:48 am

Post your Sep17log.txt as an attachment here.
If Cumulus says it has an error, then that file does have an error, and the FAQ tells you how to solve it, so we need to be sure you are not misreading your file. Proof readers exist as a job because we often see what we expect, not what is actually there.

Reinstalling Cumulus does not correct an error in a log file. I'm not being unkind, but you sound as if you are in a panic mode, and that is not the best for solving problems. Even if I can't solve your problem (and I'm working one step at a time), there are plenty of others to offer their help. Cumulus outputs a lot of diagnostic information and it might be necessary to look at that.

Also are you letting either your pc or the USB go to sleep while Cumulus is running? There are a lot of posts on the forum about those sort of problems, so far I have focussed on trying to rectify the problem with your file, but you may need to find the cause too.
shaunfish wrote: the program will insert some strange rainfall figures such as 200mm/hr.

The wrong rainfall figures is probably unrelated to the log file issue, but it certainly is not a feature of Cumulus (as Steve says in other posts, Cumulus has incorporated a lot of features to try to reject incorrect figures), it might be an indication of a faulty set bit in your weather station output message or it might indicate your computer had a hiccup when reading the input. Again both the FAQ and the forum make lots of references to strange or rogue figures. Editing rainfall is fairly easy, see the FAQ. You can't expect your Watson to be perfect, even professional weather stations have to manually edit out some rogue figures from time to time.

shaunfish
Posts: 8
Joined: Wed Apr 23, 2014 5:18 am
Weather Station: Wastson W-8681
Operating System: win 7
Location: Pietermaritzburg, South Africa

Re: Please help with this error

Postby shaunfish » Mon Sep 25, 2017 5:11 am

Hi
No not in panic mode but frustration mode. for years this software worked fine the suddenly this trouble.
You do not have the required permissions to view the files attached to this post.

water01
Posts: 1401
Joined: Sat Aug 13, 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Please help with this error

Postby water01 » Mon Sep 25, 2017 6:51 am

Looks pretty obvious to me, remove lines 1 & 2 starting
24 09 17,06:53
and all should be well.

sfws
Posts: 345
Joined: Fri Jul 27, 2012 11:29 am
Weather Station: off-line Fine Offset plus others
Operating System: off-line Vista and W10 PCs
Location: UK

Re: Please help with this error

Postby sfws » Mon Sep 25, 2017 6:57 am

Shaun

shaunfish wrote:Hi
No not in panic mode but frustration mode. for years this software worked fine then suddenly this trouble.

You've made progress - Cumulus is no longer indicating an error. You have corrected the "error at line ..." problem.
water01 wrote:Looks pretty obvious to me, remove lines 1 & 2 starting
24 09 17,06:53
and all should be well.

(The September log file you have attached does not include the start of the month with the line 1 that was causing the problem, so the solution by David (water01) is not valid, he has not picked up that you have been using Cumulus for years... but only included recent lines from the log).

The monthly log file does however show that you have multiple lines with the same time-stamp (not just the two that David (water01) reports), suggesting that you either had more than one copy of Cumulus in use, or you were stopping and starting Cumulus (or the pc was sleeping and waking) frequently and that could well be the source of both your problems. On the Configuration menu, station settings, tick "Close on Suspend" and "Stop 2nd instance".

RAINFALL PROBLEM
It looks to me as if the rainfall today is probably okay. Normally after a day, any error will be eliminated as Cumulus just looks at one counter and it is the difference between its value at the start of the day and its current value that is reported as rainfall. If you had two copies of the Cumulus software running, they could be working with different counters and could complicate the rainfall problem.

Correcting the rainfall for yesterday is covered at http://wiki.sandaysoft.com/a/FAQ#.28Invented_rain.29_Error_in_yesterday.27s_total.
When you restart Cumulus after doing that, the figures for this month and this year will be correct.

The fact that the record light is showing suggests that you need to edit some of the extremes, again the FAQ explains that in succeeding paragraphs. In edit menu, correct as needed the high rain rate and high daily rain for All-time records, Monthly records, This month's records, and This year's records. The Wiki contains advice on where to look for previous values, in your case I would look in the Cumulus\back-up\daily directory for the date before you saw the wrong rainfall. The relevent files are respectively alltime.ini, monthlyalltime.ini, month.ini and year.ini.

The chances are that your station will again operate for ages before it has another hiccup with the rainfall.

I'm not suggesting you try it this time, but Cumulus does provide another option, it stores back-ups of earlier contents of the cumulus\data directory, and by overwriting the current contents with those older contents you can rewind and attempt to read the station again from that earlier period. Such a new read might not see the error again. However, such a read only has access to what is stored in the station log and so you lose the detail of changes in-between those logged measurements that Cumulus processed when it was running before the rewind.


Return to “Cumulus 1”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests