Page 1 of 1

Previous month rainfall and temp not updating

Posted: Sun Apr 15, 2018 5:38 pm
by Philip
Has anybody else had this problem and if so how did you fix it please?

On the 2nd of April a power failure on my remote weather station (3 miles from home ) caused the laptop batteries to discharge and the laptop to shut down without shutting down Cumulus. This has happened twice before and on restoring power everything restarts: Cumulus picks up the missing data from the weather station and all is well
.
However this time the computer powered down at about 15:30 and was not restored until the following day. Again cumulus picked up the missing data and all appeared well: however at midnight when the daily rainfall and max/min temps should have updated nothing happened and the update has failed every day since.

I have twice powered down Cumulus and the laptop, also removing the batteries from the weather station, to effect a clean restart and this has had no effect.

The problem can be viewed at:- http://www.jollyroger2.eclipse.co.uk/weather in the trends tab.

Any help would be appreciated

Philip

Re: Previous month rainfall and temp not updating

Posted: Mon Apr 16, 2018 12:06 pm
by steve
From your web site, it appears that it did the midnight rollover successfully last night?

Re: Previous month rainfall and temp not updating

Posted: Mon Apr 16, 2018 7:53 pm
by Philip
Hello Steve

Thanks for the swift response, the midnight rollover and update of the months rainfall and temp highs and lows all seem to be working normally. It is just the two graphs that are not updating as per the attached screen dumps.

Philip

Re: Previous month rainfall and temp not updating

Posted: Tue Apr 17, 2018 7:31 am
by steve
Not updating just on the web site or in Cumulus too? If both, then you may have a corruption in dayfile.txt. Normally the red error light would be flashing if that were the case. The latest diags file may have error messages regarding the file, telling you where the problem is (as would clicking on the error light if it was flashing).

Re: Previous month rainfall and temp not updating

Posted: Tue Apr 17, 2018 8:28 am
by Philip
Good morning
FIXED IT
Grand order of the digit trouble! When I restarted the laptop after it's crash I had to set the bios again including the date. I made an error and put in 2017: that is all it was. Lesson learned! :groan: