Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Windows 8 - LoadCurrentVantageData_V, error = -32701

Discussion specific to Davis weather stations
hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Wed Oct 09, 2013 2:34 am

I recently purchased a replacement PC to run my installation of Cumulus 1.9.3 s/w which in turn monitors my Davis Vantage Vue console. This new PC is Windows 8. I previously used Windows Vista and Windows 7 platforms to run Cumulus with no issues communicating with my weather console.

The new Windows 8 PC and the Cumulus s/w have never worked more than a few days without losing communication with the weather station console. Tonight, I sort of inadvertently created a bugreport.txt file by actively manipulating the COM port setting in Cumulus during my efforts to 'reestablish' communication between the s/w and the console.

Over the previous few weeks I have fiddled with the run environment of the cumulus.exe file to be both Window 7 and Windows 8 modes with no difference in reliability of the s/w. The most recent failure occurred while setting the exe to run in 7 mode.

I will upload the bug report along with the diag directory log file during the s/w error and restart timeframe in hopes that someone can help me figure out why the s/w is randomly locking up while talking to the console.

Thanks very much for any help.

Kelly
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26297
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in Spain
Contact:

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby steve » Wed Oct 09, 2013 7:47 am

Is your logger USB or serial? If it's USB, then a possible explanation for the loss of communication is that the USB port is going to sleep; you need to check your USB hub power settings in Windows to make sure that isn't happening. And assuming it is a USB logger, are you using the latest drivers from Silicon Labs? There's a link in the FAQ: http://wiki.sandaysoft.com/a/FAQ#How_do_I_get_my_Davis_station_with_USB_working_with_Cumulus.3F

Some people have had problems with Davis loggers where the logger comes loose; as it was working OK on the other PC this is unlikely to be the problem in this case. But you should still check your connections anyway.

The reason for large number of entries being downloaded at start up is that you don't have Cumulus and the station set to the same interval: http://wiki.sandaysoft.com/a/FAQ#Cumulus_takes_a_long_time_to_download_the_data_from_my_Davis_station_at_start_up
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Fri Oct 11, 2013 1:36 am

Steve,

Thanks for the suggestions. The connections have been double-checked a couple of times, so I think those are good.

I hadn't thought about the USB ports having a sleep setting, so I've adjusted them to not sleep. Hopefully that will do the trick.

Thanks again.

Kelly

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Fri Oct 11, 2013 1:12 pm

Steve,

Ironically, the issue reoccurred again about 20 minutes after I posted. Not sure what to do at this point. I verified that I do have the latest drivers from Silicon Labs. I had no problems with any of the installation that I can recall.

Short of setting the interval of the console via Weatherlink (which I don't think is contributing to the loss of comm) I don't think there's any other adjustment to make from your original suggestions.

Would reloading everything make any difference in your opinion?

I really hate resorting to running scheduled batch file restarts every hour or two to keep the communication flowing. Doing that ensures that the Wunderground feed is disrupted for long enough that the PWS forecasting element for my station is disabled on their website. Of course, this random disconnect has the same affect. So I'm kind of in the same boat either way.

Any other ideas?

Kelly

User avatar
steve
Cumulus Author
Posts: 26297
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in Spain
Contact:

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby steve » Fri Oct 11, 2013 1:26 pm

Reinstalling won't make any difference; the problem is the communication between the Davis DLL and the console, and the DLL is just reporting what it sees. The usual cause of this that I've read about previously is the USB power setting. Just to confirm, you went into Device Manager, and under "Universal Serial Bus Controllers", you right-clicked on each hub device, clicked 'properties', selected the Power Management tab, and unticked "Allow the computer to turn off this device to save power"?

If that hasn't helped, the only other thing I can think of to suggest is trying a different USB cable and/or a different USB port.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Fri Oct 11, 2013 1:36 pm

Affirmative. Those are the actions that I performed, on all USB hub devices visible in the tree.

When I return home this evening, I'll try connecting to a different port. Then a different cable if the port doesn't help.

Thanks much for the thoughts and advice on the issue.

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Thu Oct 17, 2013 3:37 am

Steve,

I believe I have finally figured out the solution to the problem I posted about.

The PC that I monitor the weather console with is plugged into a UPS device. I hadn't taken that into account when troubleshooting before. I happened to be in the room with the UPS device/PC this evening when we had a small power spike and I heard the UPS circuit click over to battery and then back off. This coincided precisely with a fresh set of disconnect errors like those in the original post I made.

I quickly changed the "USB selective suspend setting" to 'On battery: Disabled' in the Power options for the PC. I emulated a quick power spike by uplugging/replugging a nearby printer (which always sends a surge through the circuit) and amazingly, no errors were produced in the Cumulus logs. I did regression testing by setting the setting to Enabled, recycled the printer and voila, same nastly errors I've been fighting for a couple months.

I think I'll declare victory on this. PC + UPS + Weather Console + Windows 8 (et al) + USB Hub Power Settings = Thorough testing needed

I've attached a screen shot of the power setting that provided me relief.

Thanks for indulging my queries.

Kelly
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26297
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in Spain
Contact:

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby steve » Thu Oct 17, 2013 6:47 am

Sounds like you've identified the problem - well done.

hallkd wrote:I emulated a quick power spike by uplugging/replugging a nearby printer (which always sends a surge through the circuit)
As an aside, I've read in a number of places that you shouldn't connect (laser) printers to a UPS, so I don't do it with mine.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

BCJKiwi
Posts: 847
Joined: Mon Jul 09, 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby BCJKiwi » Thu Oct 17, 2013 9:25 pm

Agree,
It is not good practise to connect a Laser printer to a UPS.

The issue is the fusing system - it draws a significant current.
Also if you need to run on the UPS, the Laser printer will drain it real fast is used.

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Thu Oct 17, 2013 10:14 pm

Thanks for the advice on the laser printer, however I may not have been clear.

The printer is not plugged into the UPS.

The printer is plugged into an outlet on the same circuit breaker as the UPS. The printer, which I'm assuming draws peak current as it kicks on, is causing a surge/deficit on the circuit that contains the outlet that the UPS uses. This in turn affects the UPS (by causing a switch to battery), which further affects the PC and the USB hub and the software as described previously.

I'm not an electrician and not very wise in the world of wiring and EE, but I think that's what's going on.

Anyway thanks for the commentary, as it may help someone else along the way.

BCJKiwi
Posts: 847
Joined: Mon Jul 09, 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby BCJKiwi » Fri Oct 18, 2013 5:06 am

In that case it comes down to the type of UPS you have.
The better UPS for computers is the 'online' type where the charging, battery and standby power circuits are always on and in parallel with the mains with the output waveform synched with the mains waveform - the 'switch over' is transparent to the load.

There are 3 basic types;
standby
Line-interactive
Online

A good line-interactive will usually be OK but the online is better. Standby is asking for trouble - even with your PC as the power supply capacitors are unlikely to cope too well and their life may well be shortened if outages are frequent.
Naturally there is a cost consideration!

hallkd
Posts: 7
Joined: Wed Oct 09, 2013 1:49 am
Weather Station: Davis Vantage Vue
Operating System: Windows 8
Location: St. Louis MO USA

Re: Windows 8 - LoadCurrentVantageData_V, error = -32701

Postby hallkd » Fri Oct 18, 2013 11:30 am

Thanks for the insights. I may be doing some shopping!


Return to “Davis VP/VP2/Vue”

Who is online

Users browsing this forum: No registered users and 3 guests