Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

error 32701

Discussion specific to Davis weather stations
cladder
Posts: 1
Joined: Mon Jul 10, 2017 9:34 am
Weather Station: davis vantage vue
Operating System: win 10

error 32701

Postby cladder » Mon Jul 10, 2017 9:56 am

i have a davis vantage vue with a and win 10. the batteries went in the station console it was acouple of days before i change batteries when on start of progam i get error 32701 up and till this point it had not miss a beat even changed batteries before.
just disconnected usb and computer does not recognise it and i found kaspersky and quarantine cumulus thought it was a trojan

StormCapture
Posts: 27
Joined: Tue Feb 16, 2016 11:16 am
Weather Station: Davis Pro 2 Plus / WH1081
Operating System: Win 7 HP / Win 8
Location: UleyBury South Australia

Re: error 32701

Postby StormCapture » Sat Jul 15, 2017 12:12 pm

By memory that error is no communication to the station. Because you have restated the console due to a battery change, your PC probably changed the COM port to a different number.

So you will have to experiment by finding what COM port its in or take the easy way out and use WeatherLink to communicate first to identify what COM port it's reading.

I'm not sure why it thinks it's a Trojan, the software is clean of viriuses and malware, Steve might be able to touch up on that one but reckon I've helped with the Error issue.

StetsonWX
Posts: 1
Joined: Sun May 03, 2015 3:44 am
Weather Station: WH1080
Operating System: Windows 7
Location: USA

Re: error 32701

Postby StetsonWX » Sun Jul 30, 2017 1:14 am

The COM port is exactly the issue. I ended up running WeatherLink to find/set the COM port and it cleared the issue.

Tony_J
Posts: 29
Joined: Wed Aug 20, 2014 9:35 am
Weather Station: Davis Vantage Pro 2+
Operating System: Windows 10
Location: Isle of Mull, UK
Contact:

Re: error 32701

Postby Tony_J » Thu Feb 15, 2018 11:45 am

I am getting this error with my Vantage Pro 2 on Win 8 - the configuration has been stable for a couple of years, but today after a PC re-boot Cumulus won't communicate with the Vantage Pro station and gives error -32701 regardless of the com port setting (was port 4, and looking in Device Manager on the PC, com port 4 is the only one that appears to be in use - listed as Silicon Labs CP210x USB to UART Bridge (COM4).

Any ideas...?

Tony_J
Posts: 29
Joined: Wed Aug 20, 2014 9:35 am
Weather Station: Davis Vantage Pro 2+
Operating System: Windows 10
Location: Isle of Mull, UK
Contact:

Re: error 32701

Postby Tony_J » Thu Feb 15, 2018 12:06 pm

Further info...when I try running WeatherLink to test the USB comms under settings/Communications Port, I get "error communicating through USB". If I select "Serial" and auto detect, mostly it fails to find a station, but occasionally finds the Vantage Pro. Of course, when switching back to Cumulus, it mostly fails to find it again...but occasionally does. Most peculiar.

User avatar
PaulMy
Posts: 1617
Joined: Sun Sep 28, 2008 11:54 pm
Weather Station: Davis Vantage Pro 2 w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: error 32701

Postby PaulMy » Thu Feb 15, 2018 2:26 pm

When I have had error 32701 it was usually because I had Weatherlink already running when starting Cumulus. To get a connection again I would stop Cumulus (make sure Cumulus is not running) start Weatherlink, confirm the WL settings/Com port, etc. and after Weatherlink got connected then close it and start Cumulus. You must make sure that Weatherlink is set up and running as Serial and not USB. I think there is a FAQ on 32701 and several past discussion on the forum.

Enjoy,
Paul


Return to “Davis VP/VP2/Vue”

Who is online

Users browsing this forum: No registered users and 4 guests