Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Cumulux on Armbian - Orange PI

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
riddick81
Posts: 5
Joined: Tue Dec 20, 2016 8:35 pm
Weather Station: Hyunday WSP 3080 WIND
Operating System: Hyper V

Cumulux on Armbian - Orange PI

Postby riddick81 » Fri Aug 11, 2017 8:12 pm

Hi.

I try run Cumulus on Orange PI ZERo. Software is running but connection with weather station not work.
I think, that is problem with COM port - I setup Port name /dev/usbdev6.2 . On linux lsusb show this:

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

If I starts mono CumulusMX.exe I see this
Current culture: English (United States)
Serial: E629B2E2201099E5FF95D00CCB18AD20
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2017-08-11T22:11:55
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
sysname=Linux release=3.4.113 machine=armv7l
System.DllNotFoundException: libudev.so.0
at (wrapper managed-to-native) HidSharp.Platform.Linux.NativeMethods:udev_new ()
at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00000] in <filename unknown>:0
Not supported
Fine Offset station not found
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Starting web socket server on port 8002

What I have wrong? Thank you.

User avatar
steve
Cumulus Author
Posts: 26311
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: On tour in Portugal
Contact:

Re: Cumulux on Armbian - Orange PI

Postby steve » Fri Aug 11, 2017 9:25 pm

It's not a problem with the COM port setting, because that's not used for USB stations. The problem is as in the error message - you don't have libudev.so.0 on your system.
Steve
-----
Hosting available for Cumulus web sites. See http://sandaysoft.com/forum/viewtopic.php?f=2&t=11876

Please read the posts in the Announcements section about the current status of Cumulus development since I have retired from my day job

riddick81
Posts: 5
Joined: Tue Dec 20, 2016 8:35 pm
Weather Station: Hyunday WSP 3080 WIND
Operating System: Hyper V

Re: Cumulux on Armbian - Orange PI

Postby riddick81 » Sat Aug 12, 2017 11:06 am

yes you have right. Thanks. In my Linux is this /lib/arm-linux-gnueabihf/libudev.so.1.5.0
/lib/arm-linux-gnueabihf/libudev.so.1

riddick81
Posts: 5
Joined: Tue Dec 20, 2016 8:35 pm
Weather Station: Hyunday WSP 3080 WIND
Operating System: Hyper V

Re: Cumulux on Armbian - Orange PI

Postby riddick81 » Sat Aug 12, 2017 11:53 am

So in armbian (debian 8) is libudev1 and downgrade from repository isn't possible.

riddick81
Posts: 5
Joined: Tue Dec 20, 2016 8:35 pm
Weather Station: Hyunday WSP 3080 WIND
Operating System: Hyper V

Re: Cumulux on Armbian - Orange PI

Postby riddick81 » Sat Aug 12, 2017 12:01 pm

now is working - I created symlink to libudev

First I found where is my libudev -
find / -name "libudev.so.*"

then
cd /lib/arm-linux-gnueabihf/

and finally
ln -s libudev.so.1 libudev.so.0

Now station are connected.
Thanks for help.


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 3 guests