IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

I strongly advise all users using my server for their web site to make alternative arrangements.

Outgoing mail is disabled because of the malware on the server. No new forum registrations are currently possible, and mail to the forum administrator will not work.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Problem with date and time for update

Discussion of Ken True's web site templates

Moderator: saratogaWX

perl
Posts: 25
Joined: Wed Jun 24, 2015 7:02 pm
Weather Station: Viking and Davis Vantage Pro
Operating System: windows 10 and Raspberry
Location: Taasinge, Denmark
Contact:

Problem with date and time for update

Postby perl » Sun Oct 15, 2017 10:27 am

Hi,
I have a PI with CumulusMX and and Davis running, which works perfect.

Now I am trying to get another station with fineoffset, PI and CumulusMX up running.

The status is ok
ScreenShot430.jpg


But I have troubles with the index.php. When the page loads, date and time is ok, but less than 1 second it fall bach to show an old time :
ScreenShot429.jpg


Can anyone explain to me why?

Where does this wrong date and time come from.

The realtime file shows: 15/10/17 12:11:46 14.6 99 14.4 1.0 2.7
You do not have the required permissions to view the files attached to this post.
____________
Per

User avatar
Toxic17
Posts: 698
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: Problem with date and time for update

Postby Toxic17 » Sun Oct 15, 2017 4:25 pm

not sure where the issues is as when i looked at your site it is behaving correctly.

though you do need to update some templates.

http://vejr.perlaustsen.dk/check-fetch- ... w=versions
Regards Simon

https://www.conligwx.org
https://www.conligwx.org/pws/
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image

perl
Posts: 25
Joined: Wed Jun 24, 2015 7:02 pm
Weather Station: Viking and Davis Vantage Pro
Operating System: windows 10 and Raspberry
Location: Taasinge, Denmark
Contact:

Re: Problem with date and time for update

Postby perl » Mon Oct 16, 2017 1:43 am

Thanks for the reply, but the site is all about is https://ljm.brugergruppen.dk/vejr2:
ScreenShot434.jpg


ScreenShot435.jpg


Suddenly yesterday evening everything was all right, but now at 03:40 AM the time is wrong.
You do not have the required permissions to view the files attached to this post.
____________
Per

User avatar
saratogaWX
Posts: 896
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows XP SP3
Location: Saratoga, CA, USA
Contact:

Re: Problem with date and time for update

Postby saratogaWX » Mon Oct 16, 2017 3:13 pm

Looking at https://ljm.brugergruppen.dk/vejr2/chec ... w=settings shows the PHP pages are getting the tags and realtime from the ./vejr2/ directory (same directory as the vejr2 site is located).

the ./vejr2/ajaxCUwx.js script shows

Code: Select all

var realtimeFile = '/realtime.txt'; //  URL location of realtime.txt relative to document root of website
so it is picking up the realtime.txt file from the document root of ljm.brugergruppen.dk
Change that to

Code: Select all

var realtimeFile = 'realtime.txt'; //  URL location of realtime.txt relative to document root of website
to have it get the realtime.txt file from the same directory (./vejr2/) as the template pages.

That's why the date/time is odd when the AJAX JavaScript does a partial page update.

perl
Posts: 25
Joined: Wed Jun 24, 2015 7:02 pm
Weather Station: Viking and Davis Vantage Pro
Operating System: windows 10 and Raspberry
Location: Taasinge, Denmark
Contact:

Re: Problem with date and time for update

Postby perl » Thu Oct 19, 2017 7:06 am

Now it works perfect. Thanks for the help Ken.
Best regards
Per
____________
Per


Return to “Saratoga Templates”

Who is online

Users browsing this forum: No registered users and 2 guests