Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Cumulusmx does not recognize station wh1080

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 18, 2018 10:52 am

Yes, I received the API call from WU, consisting of numbers and letters with a length of 16 digits. within easyweathersetup I put the station name IBUSTOGA4 and then the key.
The forecasts have appeared, but the graphs of temperature, wind etc., Still no .....
even inside cumulus the "charts" work ...

weatherist34
Posts: 603
Joined: Wed Apr 13, 2016 11:09 am
Weather Station: Oregon WMR300 + Weatherflow
Operating System: OSX High Sierra
Location: Istanbul
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby weatherist34 » Sun Feb 18, 2018 1:12 pm

RunningEv wrote:Yes, I received the API call from WU, consisting of numbers and letters with a length of 16 digits. within easyweathersetup I put the station name IBUSTOGA4 and then the key.
The forecasts have appeared, but the graphs of temperature, wind etc., Still no .....
even inside cumulus the "charts" work ...

searched on wunderground for IBUSTOGA4 nothing found ..can you provide a link to this station on wunderground.

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 18, 2018 2:12 pm

I have the feeling of having made some mistakes, however the station is this:

https://www.wunderground.com/personal-w ... =IBUSTOGA4

User avatar
PaulMy
Posts: 1698
Joined: Sun Sep 28, 2008 11:54 pm
Weather Station: Davis Vantage Pro 2 w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby PaulMy » Sun Feb 18, 2018 3:01 pm

Your WU station IBUSTOGA4 is showing regular data so that is all good. Your forecast, which I think comes from your IBUSTOGA4 station location also seems correct for your location.

Your history is not displaying. The history comes from your WU data that is accessible through the API key. Would you double check your API key number making sure no spaces before and after and check it at
https://www.wunderground.com/weather/ap ... stats.html substituting your key number for xxxxxxxx

Enjoy,
Paul

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 18, 2018 3:23 pm

I put the key in the address you gave me and go to the features page of my key.
there is a strange error at the bottom of the page
the key in easyweathersetup is fine, I checked it several times

Image

User avatar
PaulMy
Posts: 1698
Joined: Sun Sep 28, 2008 11:54 pm
Weather Station: Davis Vantage Pro 2 w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby PaulMy » Sun Feb 18, 2018 4:41 pm

That OFFLINE error may be the cause but don't know what it would be. I have had some errors in the past but nothing recently and mine is working fine currently.

Good luck,
WU-api.png
You do not have the required permissions to view the files attached to this post.

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sun Feb 18, 2018 5:17 pm

maybe I understand, the mistake is mine.
when I registered the pws, by mistake, I registered two, IBUSTOGA3 and IBUSTOGA4.
Probably the first station is seen offline so it does not update the charts.
now I try to set in cumulus IBUSTOGA3, the first stage I created.

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Mon Feb 19, 2018 5:41 pm

nothing has changed, the statistics are not available.
but is it possible to bypass WU and manage statistics from cumulusmx?

User avatar
PaulMy
Posts: 1698
Joined: Sun Sep 28, 2008 11:54 pm
Weather Station: Davis Vantage Pro 2 w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby PaulMy » Tue Feb 20, 2018 1:54 am

That is strange that you cannot access WU historical. I can't recall, can you get another WU API key?

Yes, an alternative is the MySQL version of the template that I think is included in Brian's latest zip (Tony's modified). I have it at http://www.komokaweather.com/pws-mysql

Enjoy,
Paul

weatherist34
Posts: 603
Joined: Wed Apr 13, 2016 11:09 am
Weather Station: Oregon WMR300 + Weatherflow
Operating System: OSX High Sierra
Location: Istanbul
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby weatherist34 » Tue Feb 20, 2018 8:08 am

RunningEv wrote:nothing has changed, the statistics are not available.
but is it possible to bypass WU and manage statistics from cumulusmx?


*please note the historical charts from WU do NOT use a api key (api key is for forecast only) it simply downloads historical direct from the your pws page at wu .

i would check the folder/file permissions however i have tested your wu ID IBUSTOGA4 i see no data for today in charts but i see data for the month starting 17th of feb ends 18th.

if i goto your WU pws page it returns IBUSTOGA4
This PWS is not reporting
Last updated: 18/02/2018, 20:00:01,
1 day ago..



with IBUSTOGA3 it is fully working ok so i would check your folder/file permissions for the chartswu folder.see screenshot capture of your data in my demo.hope that helps..brian

Image

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Tue Feb 20, 2018 9:33 am

sorry Brian, you have to be patient, but I did not understand anything lol

I can tell you that by mistake I created on WU two PWS stations, IBUSTOGA3 (currently online) and IBUSTOGA4, used for 1 day

I did not understand what checks or controls, on file or folder permissions, I have to do and where I have to do it

kartracer
Posts: 1
Joined: Sun Nov 03, 2013 2:19 am
Weather Station: Fineoffset
Operating System: win7
Location: Ohio

Re: Cumulusmx does not recognize station wh1080

Postby kartracer » Tue Feb 20, 2018 4:24 pm

scilab wrote:To use correctply CumulusMX on Raspberry you need mono max at v.4.0.5, i've also the wh1080 and i do this procedure:

If you had installed mono, uninstall it with:
$ sudo apt-get remove mono-complete

The add the mono repository:
$ cd /etc/apt/sources.list.d
$ sudo vi mono-xamarin.list

add below line:
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main

Go an Update Repo:
$ sudo apt-get update

Just ignore the warnings about signatures and conflicting distribution.

In order to fix dependencies, aptitude must be used to install mono:
$ sudo aptitude install mono-complete=4.0.5.1-0xamarin1

Then you will get a proposal from aptitude to solve the dependencies:

Keep the following packages at their current version:
1) Do NOT accept this solution, when that would install the current version of mono(4.6.2) which has errors (as documented by SpaceHiker).
Respond with "n"

2) Accept the next solution from aptitude to install mono version 4.0.5 with this warning:
Respond with "Y"

3) At the next prompt:
Respond with "Y"

4) At the last prompt:
Do you want to ignore this warning and proceed anyway?
To continue, enter "yes"; to abort, enter "no":
Respond "yes"

Now mono-complete 4.0.5 will be installed.

In order to protect this old mono version (4.0.5) from future upgrades:
$ sudo apt-mark hold mono-runtime mono-complete

How to show the current Installed version:
$ mono --version

It should respond with:
Mono JIT compiler version 4.0.5 (Stable 4.0.5.1/1d8d582 Thu Nov 12 12:22:41 UTC 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. http://www.mono-project.com
TLS: __thread
SIGSEGV: normal
Notifications: epoll
Architecture: armel,vfp+hard
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen


Thanks for this post, saved the day for me

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Fri Feb 23, 2018 7:22 am

weatherist34 wrote:
RunningEv wrote:nothing has changed, the statistics are not available.
but is it possible to bypass WU and manage statistics from cumulusmx?


*please note the historical charts from WU do NOT use a api key (api key is for forecast only) it simply downloads historical direct from the your pws page at wu .

i would check the folder/file permissions however i have tested your wu ID IBUSTOGA4 i see no data for today in charts but i see data for the month starting 17th of feb ends 18th.

if i goto your WU pws page it returns IBUSTOGA4
This PWS is not reporting
Last updated: 18/02/2018, 20:00:01,
1 day ago..



with IBUSTOGA3 it is fully working ok so i would check your folder/file permissions for the chartswu folder.see screenshot capture of your data in my demo.hope that helps..brian

Image



Hi Brian, sorry if I'm bothering you, but I wanted some clarification about your post.
Specifically I did not understand what checks I have to do in order to folder/file permission on chartswu, for make the graphs work.

thanks in advance

EDIT:

if then someone can also explain how to make the file NSRealtime.txt for lightning, I thank him

weatherist34
Posts: 603
Joined: Wed Apr 13, 2016 11:09 am
Weather Station: Oregon WMR300 + Weatherflow
Operating System: OSX High Sierra
Location: Istanbul
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby weatherist34 » Fri Feb 23, 2018 7:47 pm

RunningEv wrote:
weatherist34 wrote:
*please note the historical charts from WU do NOT use a api key (api key is for forecast only) it simply downloads historical direct from the your pws page at wu .

i would check the folder/file permissions however i have tested your wu ID IBUSTOGA4 i see no data for today in charts but i see data for the month starting 17th of feb ends 18th.

if i goto your WU pws page it returns IBUSTOGA4
This PWS is not reporting
Last updated: 18/02/2018, 20:00:01,
1 day ago..



with IBUSTOGA3 it is fully working ok so i would check your folder/file permissions for the chartswu folder.see screenshot capture of your data in my demo.hope that helps..brian

Image



Hi Brian, sorry if I'm bothering you, but I wanted some clarification about your post.
Specifically I did not understand what checks I have to do in order to folder/file permission on chartswu, for make the graphs work.

thanks in advance

EDIT:

if then someone can also explain how to make the file NSRealtime.txt for lightning, I thank him


hello its not a problem but i cant help you as I no nothing about raspberry pi based servers but you should check that the file/folder permissions are writable for the chartswudata folder i dont know how else to explain it ..

NSRealtime.txt if you own a Boltek Lightning Detector device and package and run NexStorm Software.

RunningEv
Posts: 40
Joined: Wed Jan 31, 2018 5:00 pm
Weather Station: Froggit WH1080SE
Operating System: Win 10
Location: Italy, near Milano
Contact:

Re: Cumulusmx does not recognize station wh1080

Postby RunningEv » Sat Feb 24, 2018 9:14 am

ok, thanks anyway Brian, I start work to find a solution! Thanks again


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 1 guest