IMPORTANT! The server may go down soon - possibly permanently. Please read the latest post in Announcements and News

FTP is broken. I advise all users using my server for their web site to make alternative arrangements.

Please read the posts in the Announcements section about the current status of Cumulus development now that I have retired

Please read this post before posting

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See this post for download

Mono and CumulusMX under jessie and stretch

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Joe Curtis
Posts: 11
Joined: Sun Jun 07, 2009 2:07 pm
Weather Station: W-8681
Operating System: Windows 10 pro, Fedora 27, RPI \

Mono and CumulusMX under jessie and stretch

Postby Joe Curtis » Thu Mar 01, 2018 11:06 am

I have three Pi's, a 2B running Moode 4, a 3B running Nginx as a proxy sever under stretch for my home network and a 3b which is mainly running CumulusMX under jessie via mono for my weather station and website (www.craythorneweather.info).

I would like to upgrade the jessie Pi3 to stretch but unfortunately, when I try, the latest version of mono ( 5.xx.x)which is automatically installed on the upgrade is incompatable with CumulusMX and CumulusMX is unlikely to be further developed to take account of changes in mono.

I have tried to uninstall mono and reinstall an earlier version (4.xx.x) but that too is incompatible with CumulusMX and I am not sure that the instructions I have used, copied from various places on the web, are that current or comprehensive.

The version of mono that does work under jessie is 3.2.8. If anyone can help me with instuctions that would completely uninstall mono from stretch and reinstall mono 3.2.8 from an archive I would be most grateful.
Joe Curtis

User avatar
dazza1223
Posts: 393
Joined: Sun Jan 25, 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: Mono and CumulusMX under jessie and stretch

Postby dazza1223 » Thu Mar 01, 2018 1:30 pm

what weather station you got?
have fun and keep learning

dazza :D

water01
Posts: 1465
Joined: Sat Aug 13, 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Mono and CumulusMX under jessie and stretch

Postby water01 » Thu Mar 01, 2018 1:42 pm

It says in his profile a W-8681 and to be honest what on earth has that to do with the question?

If you search the Forum you will find a Topic that explains how to do this. Sorry have not got time to do this at the moment.

rich27gc
Posts: 69
Joined: Thu Jul 08, 2010 3:15 pm
Weather Station: WeatherDuino Pro2
Operating System: Raspbian
Location: Shap, Cumbria
Contact:

Re: Mono and CumulusMX under jessie and stretch

Postby rich27gc » Thu Mar 01, 2018 5:57 pm

Hi

This forum link might be useful
viewtopic.php?f=27&t=13587&hilit=Version

Be sure to read all the posts

Hope it helps as I haven't tried it myself!!

User avatar
Toxic17
Posts: 692
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis VPro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: Mono and CumulusMX under jessie and stretch

Postby Toxic17 » Thu Mar 01, 2018 8:59 pm

water01 wrote:It says in his profile a W-8681 and to be honest what on earth has that to do with the question?



Fine offset Weather stations only seem to work with older versions of Mono. The application crashes with newer versions which are default in Jessy and Stretch.
Regards Simon

https://www.conligwx.org
https://www.conligwx.org/pws/
https://twitter.com/conligwx
Davis Vantage Pro2+ - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS
Image


Return to “Cumulus MX”

Who is online

Users browsing this forum: No registered users and 2 guests